Text messaging problems Zmax Pro & Metro PCS

scan718scan718 United StatesPosts: 65 ✭✭✭✭✭

So here's my problem, some times when i send a text, it will be stuck on sending for a very long time, also people have told me they have received like 15 duplicate text messages from my phone

even though i only sent one message. while it is stuck on sending I cannot receive messages, Metro PCS store said they "changed some settings" but it did not help, Sometimes I notice when it is stuck on sending, if I

go to the task manager and clear all it will go through, don't know if that really helps on just coincidence. I have also tried to clear the messaging app data and cache. Anyone have this problem or any suggestions to fix it?

thanks

«134

Answers

  • sagudfoodsagudfood Posts: 102 ✭✭✭

    I've had the same issue. At first I thought it was because I was on MetroPCS with no signal and using WiFi calling. But I have since switched over to H2O on ATT towers and I still get the issue of text messages hanging in limbo. Sometimes they go through after a while and sometimes they fail to go through at all. I was thinking that the apn settings were off but I think it might be the phone. Anyone else on H2O got the APN settings handy?

  • sshasansshasan Staff Member United StatesPosts: 4,077 ✭✭✭✭✭✭✭✭

    Are you using the stock messenger when this is happening? Have you defaulted to a new messenger?

  • sagudfoodsagudfood Posts: 102 ✭✭✭

    Not sure what OP is using. But I'm using the stock messenger app. If I notice that a text is stuck sending, sometimes rebooting the phone helps. Very annoying issue.

  • sshasansshasan Staff Member United StatesPosts: 4,077 ✭✭✭✭✭✭✭✭

    Have you tried clearing the cache on the messaging app?

  • scan718scan718 United StatesPosts: 65 ✭✭✭✭✭

    yup, tried clearing cache, data , still the problem returns, as sagudfood said rebooting fixes it till it returns, wondering if i should return the phone

    also saw on android forums someone mentioned something about a messaging problem, and an update coming but rumors are everywhere

  • sagudfoodsagudfood Posts: 102 ✭✭✭

    If they do an update of some sort, they need to make it available to ALL Zmax Pro owners. Some people have moved to different(better) carriers. Not everyone wants to deal with Tmobile spotty coverage.

  • I too have been getting this same problem, it is very annoying.  Only way I have found to fix it, is to restart the phone.  I have even had times where I didn't realize for some time that it didn't send it and then hours later would see that it was stuck on sending.  I have found that when this happens and I reboot, sometimes the person receiving the message then gets it a couple times.  The duplicate messages however, I have had with other phones on MetroPCS so I just chocked it up to that.  The stalling text messages though I was thinking maybe there was something with my phone, but seeing now that more people are having this issue, I'm thinking it's more of a software issue and it needs to be updated.

  • Same issue here. When I try to send a text about 30% of the time it doesn't send and I have to do a hard reset to get it to send. I also get messages saying that I didn't get a text and I can try to download them. Usually I can't download them and I end up asking the person what they tried to text me. This second issue happens most often in group texts. I've spoken with people at Metro and they walk me through clearing things out and hard resets, and it works temporarily but later I'll try to send a text again and it doesn't work. The odd thing is my wife and I are on the same plan, both with the Zmax pro and the same apps installed and her phone has no problems at all.

  • sshasansshasan Staff Member United StatesPosts: 4,077 ✭✭✭✭✭✭✭✭

    Do you happen to have wifi calling/texting on when this is happening?

  • I didn't have wifi calling on. I did however have voice over LTE enabled. I don't know what wifi texting is or where to check that. I just turned off voice over LTE to see if that helps.

  • scan718scan718 United StatesPosts: 65 ✭✭✭✭✭

    I never have wifi calling on, its still happens frequently I wish i could find a solution as this is getting annoying

  • Same problem here... So u dumped stock messenger for Chomp SMS. It's only been a few days, but I have had no issues sending or receiving texts since I switched.

  • I never have WiFi calling on.  The only way that I let my phone use it, is if there is no service at all in the area that I'm at.  I hate having it enabled and the phone is using it, then say I leave my house still talking on the phone, until they can come up with a way to get the phone to flawlessly switch from WiFi to cellular without dropping the call, I'm not going to have it use WiFi calling unless there is no other option.  With that said, I constantly have problems with the phone doing this same thing.  There will be times that it doesn't receive them either and I don't realize it till finally someone calls and says "You didn't respond to my text" or "didn't you get the answer in my text".  If I restart, I don't get them either, they seem to be lost forever. This is starting to happen more and more often and is really starting to get annoying.  Then I have to reboot the phone to even get it to start working again and getting them from the point they are being sent then.  I hope they fix this soon, because this can really be something that causes serious problems in some circumstances.

  • I'm having trouble with texting also..it sends one letter at a time when I'm not even sending anything yet.  My second problem is that my phone does what it wants like it's stuck on an icon.  I've only had this phone for 2 months. I do like it I'm just having issues with those two things.  I did download another SMS app and it is a little better but still had issues.

    Let me know if you found out what was causing the problems..

    Thanks

    Stephanie

  • ironbaybeedollironbaybeedoll United StatesPosts: 4,630 mod

    Hello Everyone, and sorry you are having issues.Those of you that are using the default text app, if you press and hold the message that fails, a menu will pull up. can you please tap on message details. What error codes is listed?

  • ironbaybeedoll wrote:Hello Everyone, and sorry you are having issues.Those of you that are using the default text app, if you press and hold the message that fails, a menu will pull up. can you please tap on message details. What error codes is listed?

    It doesn't really "fail", it never sends, it will just sit there and say "sending" and never move on from that state.  If a message fails you'll get "failed" at the bottom, but in this sense, it never does that, just stays at "sending".  It will do that with every message that you send to everybody until rebooting the phone.  Once rebooted it will then send the messages, but then at that time when I talk to the people that I sent the messages to and they now went through, they all state that they got the message multiple times.  Mostly just twice, but I have had times where they have gotten the message up to four times.  I've also entered contests where they send you a message back confirming that they got the message, and I don't get the response while it says sending, after rebooting and the sending changes to the time that it went through, I'll get the message back saying thank you for entering, then I might get 1 or 2 more messages telling me that I have already sent that word and only get once to send it.

  • ironbaybeedollironbaybeedoll United StatesPosts: 4,630 mod

    ​ Hello,  I was hoping it would return an error code for us to work with. Have you tried changing your APN settings? I know with my carrier, they have default APN settings they have everyone use, but there is also another set, and I had to use this other set in order for my text and data to work properly. It is definitely worth trying, and fairly easy to do.

  • I haven't tried making any changes to the APN settings, they are what they were set for when the phone was issued.  However, this is a MetroPCS only phone so I can't imagine that they wouldn't be set right.  Thing of it is, it will work fine for a while and then all the sudden start doing this.  After resetting the phone, it will work fine again for a while and then do it again.  This can be 20 minutes, 20 hours, 20 days.....It's very random, and sometimes I have to restart the phone many times a day, and other times I can go for days without having any issues.  It doesn't seem to be any certain person that I'm texting either, it just all the sudden will stop sending the texts.  I've also been recently getting people calling me up asking why I haven't been responding to their texts.  I tell them I haven't gotten them, and then I'll test it using my work phone and I won't get texts from that either.  Reboot will start it getting the messages again, but I'll never get backfilled with the texts that didn't come through, they are simply lost in space somewhere.

  • ironbaybeedollironbaybeedoll United StatesPosts: 4,630 mod

    ​ Hello Again, I haven't forgotten you I wanted to suggest that you clear the cache on the messaging app, if you haven't already. I also would like to see if perhaps one of our CPAs are able to give you some other troubleshooting steps, as this is a little bit out of my territory, and I would hate to give you advice that isn't going to move you to a better spot.I will keep an eye on this thread, and check back to see how things are moving along. Should you need anything, please just ask

  • hollaphollap United StatesPosts: 8,377 ✭✭✭✭✭✭✭✭

    Hello ​.  Why don't we just verify your APN settings are correct.  Here is a link to some MetroPCS settings you can try.  It has fixed some other users issues:

    https://bestmvno.com/apn-settings/metropcs-apn-settings/

  • This is what everything is set at already.....It just did it again too, it has been doing really well and all the sudden this morning, again....

  • I would like to know how to fix not only my texting problem but also a few

    other problems I'm having..my phone seems to do what it wants..for example

    say I'm watching a YouTube video or strolling through videos ..my phone

    will go off the video or page I was on and go to something else or if I'm

    playing a game it will stop in mid game and will go to something else in my

    phone..as for my texting or using the Google search bar ..I will be typing

    something in the search bar and it will only let me type so much and it

    erases what I wrote..each and every time...it won't let me finish my search

    and when in texting it sends out each letter of the word I'm writing if I'm

    saying I'll talk to you later it will send

    I

    L

    L

    T

    A

    L

    K

    T

    O

    Y

    O

    U

    L

    A

    T

    E

    R...

    Do you know how annoying that is...please fix these problems or give me

    some suggestions.. I've done several factory resets..I've done some other

    changes on my phone and NOTHING is helping.. IT seems like it's getting

    worse..I've only had this phone for 2 months..other than these for I

    absolutely love this phone but the annoying parts are starting to over ride

    my love for it..please tell me there is something I can do about this

    I do have insurance I'm even willing to send it back in and get an

    exchange.. But I can't keep going on like this..it's ridiculous ..please

    get back with me as soon as possible..thank you...

  • My problem is that it's sending with no problem.. But it sends out each letter of my word. If I'm writing I'll see you later it will look like this

    I (send)

    L (send)

    L (send)

    S

    E

    E

    Y

    O

    U

    L

    A

    T

    E

    R

    That is annoying

    My send problem is if I'm playing a game or on YouTube.. Dorian matter really what I'm doing it will stop and go to something else as if it's stuck on one page..and when I'm using Google it will not allow me to write my full sentence it will delete ..

    I have done several factory resets..along with other things but NOTHING IS HELPING..and today I noticed when I'm on the web or YouTube it is difficult for me to scroll down and when I do it will go on to another page or video as if I pushed it..also I'm starting to get things that pop up(settings, or the copy delete, paste icons) in the middle of a video or website..how do I fix these problems...I do love this phone..but really I'm becoming very annoyed..

    Please give me some kind of advice..or even if you could explain on a YouTube video that would be SO HELPFUL!!!!!?!!

    Thank You

    Stephanie

  • asianrockerasianrocker ILPosts: 243 ✭✭✭✭✭

    Use their live chat. I love using their live chat support. They are fast to help you. If they can't troubleshoot your problem. I highly suggest you ask for a replacement while you are still in warranty. That's weird. I am glad I don't have that problem I have MOST of  the USUAL glitch and bugs like most people or dare I say ALL zmax pro owners but not this one.

    We love your phone ZTE, but come on now, we want and need the fix and most importantly  - Android N! ASAP.

  • Having the same problem as everyone else and the error code is "-1" hopefully that helps because we are all getting frustrated by this, we need a fix some sort of update please.

  • Error code "-1"  

  • ironbaybeedollironbaybeedoll United StatesPosts: 4,630 mod

    ​ Hello, and Welcome to Z-Community. I first need to suggest that you verify that your APN settings are correct.Who is your current carrier? I would also like to see if one of our CPAs ​ are able to help troubleshoot further. There are many reasons that a text will not send, and sometimes the error code can give us some insight, other times, it isn't quite as useful. I will check back in to see how this is going, and should you need anything else please just holler

  • Thank you for your reply..I will do just that..thankfully it's not doing it as dialectal anymore..but if it start up again I will do just that...last few weeks  for some reason my phone did what it wanted..but for now it's behaving itself.. Lol..hope it stays that way...I do love this phone...I'm thinking to getting another one when the new ones come out if the screens are as big...(that's the reason only reason why I got this one)

    But anyways thank you!!!

  • hollaphollap United StatesPosts: 8,377 ✭✭✭✭✭✭✭✭

    Maybe it was an issue with the tower in your area.  Who knows.  Like ​ mentions, there is so much that can go wrong between someone pressing send on their device to the time it gets to the device on the other end   Glad for now your phone is behaving though!

  • I'm with Metropcs and my APN setting is set at fast.metropcs.com...sometimes text won't send out or come in and I also sometimes don't get calls and I have to reboot my phone in order for it to work...I just bought the phone like 2weeks ago and my other phone never had this problem...

Sign In or Register to comment.