No Miracast or WiFi/WiDi connection

I recently purchased the Spro2 and can't get any wireless connection to go to it. My laptop is wireless screen capable (brand new i7 Dell) and I have a Galaxy S6 phone. I can hook the laptop up with HDMI only. Even the USB connection does not work. I am beginning to wonder if there is a defect in the unit. I can cast from the laptop & phone to a DLNA TV, but no app or native program will cast to the Spro. In the Windows 10 add device it can show up as a phone sometimes, a projector randomly, or in "other devices" all depending on how it is hooked up, or not. Seems a bit flaky. I am pretty frustrated with it after wasting 3 days trying to get a wireless connection to it from the PC (the MAIN reason I chose this projector over some others). Am I doing something wrong, or is the unit defective, or is it false advertising?

«1

Answers

  • fzrrichfzrrich United States Posts: 4,244 mod

    I'm sorry for the issus you are experienceing. I don't have a Spro2 and am not sure what else you should try, lets see if ​ or our community technical ambassadors have some suggestions for you ​ 

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ Hello, and congrats on your purchase! I do have the Spro2 and am going to try to help you. Windows 10 and even 8 was a little weird about casting to the projector. How things should, or would work are not always the case with these to operating systems. I am able to get my Win10 laptop to project (cast) onto the Spro2, but not how Win10 implies in their programs. Give me a couple minutes to grab the Spro2 and I will post back here a step by step of what seems to work for me with Win10 and the Spro2. Promise I will just be a couple short minutes.

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ ok so as I said Win10 implies in several apps that it can cast to your device, and as you have seen it doesnt work as it claims. I also have the same issue with adding a device, it shows when it wants to, and never connects.

    The way to connect/ cast from your laptop to the Spro2 is as follows, and it works everytime for me.

    On the Spro2, Hit the projector button/turn on projection->then change Source to Cast (you must do this on Spro2 before trying to connect with laptop)

    Now go to your laptop. On the bottom right corner, to the right of the clock, you will see your notification box/square, tap that to open up the menu (sometimes you may need to click expand), you now want to look for the setting labeled "Connect"(pic1) and then you will choose Spro2 from the list(pic2).

    Next step is to choose how to want to cast, Again down bottom right corner, click the notification box, this time you will want to choose "Project"(pic3) from here you need to choose what option works best for you(pic4). I choose duplicate, as I need full control of my laptop obviously.It can take 30-40 seconds for it to cast over sometimes, so wait a sec If you need any further help please ask.

    1IMG_20160929_162035.jpg2IMG_20160929_162157.jpg

    3IMG_20160929_163235.jpg4IMG_20160929_163411.jpg

  • No Joy. I know all the steps, but tried your's anyway. The Spro just does not show up in the list to choose from. Wifi is on, bluetooth is on, Miracast is on. If it is not hooked up via cable it does not exist. When I go to add devices, nothing.

    Any other ideas?

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ Can you possibly tell me which  model # and software version you have? I'm still wanting to try to help you, and this information can possibly help me do that. Also are you able to get your galaxy to connect via the remote app?

  • Model is MF97V (I assume for Verizon, which I am not using)

    Android 4.4.4

    Baseband MF97VB01

    Software Version SPRO2V1.0.0B07

    I did finally get it to show up on the computer by going into settings on the Spro display/cast screen and unchecking "enable wireless display"  which was on when I got it. However, even though I chose to connect to it from the laptop, and click to accept on the Spro, nothing more happens.

    So I have made a little progress, but not there yet.

    Thanks for your help so far. Maybe we can get this thing connected!

    (and of course windows updated last night and completely removed WiDi saying it was no longer functional)

  • I also have no luck with the Galaxy connecting other than to send some stuff via bluetooth.

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ Hello Again! Thank you for providing this information. When you try connecting  the Spro2 to your Galaxy, what happens, does it provide any message? Is Remote Control turned on in settings? I know this isn't what your worried about, but it could in fact provide us further information to go on.

  • My Galaxy has been pretty well crippled by Samsung. No Miracast, no screen cast. There is a "connect to" that doesn't ever find anything. I am looking at 3rd party apps to try and make that work. I can cast to my Sony TV with both the phone and the laptop via DLNA I assume (although I haven't tested it since the update last night).

    I am new to this wireless casting so I am reading everything I can find and none of it sounds good for the Galaxy S6 Active.

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ A few other things to check, you need to make sure both your laptop and the Spro2 are both on either 2.4ghz or 5ghz or this will not work. You can also try updating your WIDI drivers. Are you able to possibly take a video of what is happening, as this may also help.

  • They are both on the same network. When I checked there is now a network that I don't recognize, using my computer's name as the middle of the name and  msqD on the end. Never seen it before. I am in a moderately rural area and my own wifi is the only thing my machines can see from here. Wonder what that is? It is asking for a password, but since I didn't make it I don't have a clue what it is.

    I also now have an app showing as Wfd service. Never saw that before either.

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ I don't have a galaxy, but I am pretty sure if you got to the play store you should be able to download "spro2 remote" It will not let you cast but it will let you control the projector, and can also give us some insight.

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ I am not sure what msqD is as it is not on my system. Wfd however should be active on the Spro2 when casting is on, that is a good thing Since you have Wfd running right now on the projector, can you please go back to my "step by step post" and make 1 more attempt? When I was first trying to get this working with my laptop, it was not until this came up on my spro2 that I was able to get it going.  I know it is a pain, but I assure you, that it is the way Win10 needs to do it with the Spro2 and I am hoping that with Wfd confirmed running, we may have something

  • I downloaded the remote and it could never see the projector, then suddenly it started working. No changes made by me. I have been beating my head on the wall all night and just tried the phone again to send to the projector and it hooked up. How or why I have no idea. One thing I did was find under wifi the wireless direct button. No instructions anywhere for that. Chose it and saw the laptop and chose it to connect. It sent an invite and I accepted, but nothing more has happened. At least the phone is working for now.

  • Poked around settings a while with varying results. I actually somehow ended up casting the projector to the computer! But when I turned off screen casting on the Spro that went away. Still can't get them the other way around.

  • Well, I don't know what I did so I don't know if I can duplicate it! I just hammered away at connecting time and time again following your instructions and finally it just connected. Makes me crazy when something so simple can get so convoluted. Now to see if I can repeat the performance, before I try it at a friend's house. Then they have apple products there so I don't know if I will be able to let them hook their phones or laptops to it. Another challenge awaits?

  • Well, decided to unhook everything and try to rehook. Now nothing works again, Wfd does not show it is running, Spro won't show in the laptop connect to area anymore and I can't hook to it with the phone. Rebooted it and no change. This is just maddening. What is wrong with this thing??

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ Sounds like you had a very frustrating night! If nothing is recognizing  the Spro2 now, please make sure it is still connected to WIFI. Also for me, when trying to cast, I had to change the source on the Spro2 before anything, or Wfd wouldn't startup. It is good that you were able to get it connected, even if it was only once, as it shows you are getting closer and also that your laptop is able. When I first tried doing this, it was maddening. I tried so many different ways, and nothing worked. It really came down to me closing out everything, and forgetting that I was casting to the Spro2. Win10. I needed to go at it like I was connecting my laptop to my tv, because Win10 ad all these different spots within, that made claims like "connect wireless device" and many of these areas were misleading, and not the spot I needed to be. Once I decided to go added with the different mindset, I was able to get it going, and now it works every time. I am going to go looking a little deeper today, and see what else I can do to help you with this. Also I have no idea how this works on the Apple line of products, but we can cross that bridge when we get there.

  • I can't get it to do anything today so I reset it to factory just to see what the "out of box" experience would be like, in case I deleted or disabled something important. Now it does even less in terms of hooking up.

    I worked at it a while and can get the phone to hook up again, and have even been able to replicate the steps (will need to test the theory by rebooting both!)

    Wfd would not come on until I hooked up the phone, but the computer still has no ability to see the projector. It shows in devices, but as not connected. I also don't get that "connect to wireless display" link anymore.

    Last night I could get it to project to the PC even though I really didn't want to, today it says that feature is not even available to my PC (a windows setting message). So why did it work last night??

  • techlifetvtechlifetv Canoga Park,CAPosts: 282 ✭✭✭✭✭
  • Right now the issue is casting or mirroring FROM the computer. I did just reinstall airpin (airplay now) and can cast or mirror that way, but the lag is horrendous. Last night I got the laptop itself to connect to the projector for real time display, but today, nothing.

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ Hello!  I didn't think resetting the Spro2 back to factory, would help, however it didn't hurt anything either, so no harm done   It definitely is within the windows system. You state your "the computer still has no ability to see the projector. It shows in devices, but as not connected"  This is what I was meaning earlier, Win10 would not, and does not detect  the projector, other than in the one spot I described in my step by step. That is the only place it is going to work. The other spots are not meant for this device, even though they imply differently.  There is no other spot where you are going to be able to connect to it, or see it consistently listed.  The device list is reserved for devices like cell phones. I have gone through my settings, and can't see anything that would prevent if from casting, on the spro2 side. I do know that some have had issues getting it going in win10, and I am fairly confident that it is on the win10 side that needs to be looked at.

  • This is getting maddening! I downloaded and updated all the Intel drivers and the new Intel program that is supposed to be for the WiDi/Miracast. Got it all installed and rebooted and the projector hooked right up! Cool. Easy as can be. So being the skeptic I am I rebooted the computer and have not been able to get it hooked up again! Good grief! What is the deal here? I have literally spent 2 days doing nothing but scouring the internet and trying to make these things play nicely together. I finally had to go out and stack firewood for 2 hours just to keep from throwing this thing upside the wall. Now I am back and the computer and projector have fresh boots so I will see what happens. Wish me luck!

    And just to be clear here, I am no noob to computers, I built my own desktopfinally so I could get what I wanted, tore apart and repaired laptops (including putting in new screens and inverters) installed programs and operating systems since my Kaypro 8088, Windows 3.1 and DOS, and play tech support for family and friends. I have never been stumped so badly by something that should be so simple.

  • Ok, here is the latest. Windows did another update before I could test things out so had to wait. Once that was done I turned on the projector, turned on Miracast, went to the computer and tried to connect to the projector, only it wasn't there. Sigh. So went and looked at the cast setting and the "enable wireless display" was checked again. This seems to cause a problem. I finally took a snapshot of the message that pops up when it is enabled (by toggling it off then back on) and it says "Cast screen was enabled, Miracast sink cannot be use until cast screen disable" (bad english was theirs, not mine) So I uncheck the "enable wireless display" and now the projector at least shows up when I try to connect.

    I have the projector on, Miracast on, click on the projector on the laptop, it says to follow instructions on the projector. It asks to allow access and I consent. Back to laptop. Nothing. Still saying to follow instructions on the projector. Says this for several minutes then switches back to the plain projector icon/name. No "connected" or "failed to connect". So I click it again, allow again, wait again. Do this 2 more times, then finally get an error message "no response from projector" Try one more time and it connects. I choose to extend the display and all is fine. Then I want to look at something else in settings in the projector and the screen sharing goes away. I try to reconnect and it says "couldn't connect" on the computer. So now we go around again with it not connecting.

    This now leads me to believe that the computer is capable, but the projector is not replying to the laptops request to connect.

    Just filmed the message that flashes by on the projector's miracast connect screen (there was no way to tell that it even had text it was so fast!), when connection is failing it says "Miracast connection error. Please check your WiFi settings". There is nothing out of order with my WiFi settings and they are both on the 5gHz setting.

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​  I hope you did not think I was implying in anyway that you didn't know your way around a computer. I do apologize if I made you feel that way, and assure you that never crossed my mind.  When you say tried to connect to projector, can you be specific, What screen, where are you trying to connect from? You only need to turn on Projection and change source on the Spro2 to Cast, you do not want to use anything that says miracast.  Also you  are in fact connecting a wireless display , so unchecking this, is going to prevent it from sending the display to the projector.

    So make sure you check the box to enable wireless display, change the source on the Spro2 to cast, if you have apps or anything relating to miracast that you installed, disable or remove them. It is not what you need. If you notice in the step by step, in step one where I show you where to hit connect, the screen that pulls up, actually says search for "Wireless Displays and Audio Devices". This is how your laptop and Spro2 need to connect. Ignore anything that specifically says miracast, it will only keep you in a loop, and not work in this case.  Once you have "enable wireless display enabled, please go back and try the steps again.

  • I didn't think you were implying I didn't know my way around a computer, I just wanted to offer a baseline for the level of knowledge I have, when giving tech support to some people I have to sometimes drop all the way down to how to push a button, if you know what I mean.

    I put the laptop to sleep, left the projector idling with the lamp off and had dinner. Came back after about an hour. Turned everything back on, connected first try no issues. Worked perfectly. Then I wanted to see if the remote switch was on so I changed to the settings screen and was immediately disconnected from the laptop, as happens every time I get it connected. And as every other time I have not been able to get it connected since.

    I don't know if we have a different version of Spro software or what, but if I enable wireless display (I have to go to settings, device, display, cast screen, and the little 3 dot icon in the upper right just to get to that setting), the Spro no longer shows up in my laptop and will in no way ever connect, even though I follow your instructions to the letter. The only thing it eventually does is nag me to allow the projector to cast TO the laptop, exactly the opposite of what I am trying to do. It makes no sense that it will hook up once and work perfectly, then never again if I disconnect it, unless I leave it alone a few hours. If it can connect once, then the capability is there and I should be able to connect any time.

    I had gotten the phone so I could connect and disconnect and reconnect this morning, now it won't connect. Nothing was changed in either the phone or projector.

    I am feeling that it may be time to start an RMA and have this exchanged. As another complaint, when the unit is plugged in it won't stay on low power, I change it to low, it jacks it back up to high and as such it gets hotter and the fan gets louder than necessary while I am troubleshooting. It should stay where I put it.

    Are there any firmware or software updates? I see others talking about B02 and AT&T has a B04 update, but I haven't seen or been offered any for this. Mine is only B01.

    Thanks for sticking with me. I just think the projector has bugs at this point and I have tried in good faith to make it right. If I were being paid by the hour for this I could have bought a new one by now.

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    Good Morning. Sorry, I am so late replying back. We do have slightly different Spro2, as I have the WIFI version, however for this task it should not be any different. If I was however trying to connect to 3g, I'd have some issues for sure You can check for updates on the device, Under the System category, tap Software Update > Check for Updates.

    As far as the power scheme, if it is plugged in I keep mine on high. The fan is doing it's job, and I want the brightest picture. So I am not sure about this.

  • Wireless version VS 4g hotspot version shouldn't be any issue (I am not hooking it up to a provider anyway, I could have just gotten the WiFi version, but this was cheaper at the time). I already checked for updates, says there are none. If the lamp is on high when I want it to be I expect the fan to ramp up. I just don't want it on high when I am just dinking with it trying to make it go, besides it making it charge slower. It shouldn't just randomly ramp back up to high when it feels like it.

    Is your software & baseband version the same as mine? I seem to have the only one from other posts I have read that the BB is version 01. Maybe that is a buggy version?

  • rikkkurdrikkkurd United statesPosts: 318 ✭✭

    Hey,

    It should be possible to use dlna streaming on the SPRO2 At this moment I do not know what the problem could be.

    DLNA is unfortunately not the most stable protocol, and miracast is not supported by all devices.

    I would contact customer support by phone for now.

    If you could give us more information we might be able to give some tips

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​  I just noticed this. I will check my version, and let you know. I don't however think this is the issue.

Sign In or Register to comment.