ZTE ZMAX PRO wifi issue

my zmax pro is having a bad wifi issue and im not sure what to do. i have restarted the phone and tried the test as soon as it came up and even after a few minutes. this phone just seems to hate any wifi network.  i have tried a different router at home and i even have two different routers i tried connecting to. i have tried it at work on our Comcast business modem. it is getting 30.78Mbps up and 22.38 down over 4g but when it comes to Comcast 25Mbps wifi ping is 16ms, up 0.11Mbps and down is 0.01 Mbps. OK so i tried it on my lg tablet on the Comcast business router and its getting 10ms ping, up 28.04Mbps and down 12.29Mbp. even tried it on a few other devices with about the same results as the lg tablet. something is wrong with my phone. any suggestions? thanks

Best Answer

  • thomasking101thomasking101 Posts: 2
    Accepted Answer

    well. i guess i should have looked into this more before giving up and posting it here. i just about reset my phone and when i went to settings, Backup&reset i saw an option for "Network settings reset" so i clicked it and for right now, this moment... its fast again. ping 11ms, down 29.87 and up 12.32 over the Comcast business connection. i have no idea what caused this. i have never had a phone do this to me before. at least its working for now.

    i stand corrected.. again. i connected my Bluetooth head phones. was listing to music. went to look something up and it was slow again. so i thought to my self.. what did i do this time. i then turned off the Bluetooth and bam.. back to full speed. its to Bluetooth that's causing slow internet performance on my zte zmax pro. even when the Bluetooth isn't connected to anything and just turned on it causes slow performance. with Bluetooth on and not connected to anyting the speed dropped to 5Mbps down and 2Mbps up... and when connected to my head phones it dropped all the way down to 0.12Mbps down and 0.03Mbps up.

Sign In or Register to comment.