Disable ZTE My Voice?

I love this phone. But honestly, Google Now is far superior to ZTE''s My Voice. However, i can't seem to get OK Google detection to work on this phone. I suspect it's because it is conflicting with My Voice. Is there anyway I can disable My Voice or turn it off?

Answers

  • shoman94shoman94 MainePosts: 605 ✭✭✭✭✭

    I get OK Google detection without issue in any screen including the lock screen. Make sure you set it up for any screen detection in the Google app settings.

  • runtohell121runtohell121 Analyst United StatesPosts: 2,262 ✭✭✭✭✭✭✭✭

    As far as I know, there is no actual way to disable My Voice, but Google Now should work fine if you enable the options in Google Settings and maybe train your voice to it.

    To get to Google Settings, launch Google app (Google Now, etc.) -> Menu/option key on top left (3 dash) -> Settings -> Voice -> "Ok Google" detection and enable "From any screen" and try training your voice.

    Another way to get to Google Settings is by going to Settings (ZTE stock Settings) -> All settings -> Scroll down to "Google" -> scroll to "Search & Now"

  • I got the ok google to work after i installed the google launcher.

  • adrbadrb Toronto, CanadaPosts: 719 ✭✭✭✭✭✭

    I have disabled My Voice with Windows DeBloater, I dislike voice commands.

  • stevenkelby@gmail.com[email protected] South AustraliaPosts: 70

    Does that require root ?

  • runtohell121runtohell121 Analyst United StatesPosts: 2,262 ✭✭✭✭✭✭✭✭

    Nope, the Debloater software do not require root. Just need to enable USB Debugging if I remember correctly. To enable USB Debugging, you will need to get the Developer option to show up in the Settings.

    To get the Developer option to show up:

    Go to Settings -> All settings -> Scroll to About phone -> Tap the build number 5 times (or more.. forgot how many times); and you should get a message saying Developer mode enabled

    Go back to the Settings menu, the Developer options should be above the "About phone"

  • When I try and train the phone to listen to my voice, I get a error message telling me that it can't use the microphone and to restart the phone. Restarting the phone though does not help.

  • runtohell121runtohell121 Analyst United StatesPosts: 2,262 ✭✭✭✭✭✭✭✭

    Maybe it's the permission settings; microphone might have been disabled?

    Go to Settings -> Apps -> Google App -> Permissions

  • stevenkelby@gmail.com[email protected] South AustraliaPosts: 70

    I'm hoping to turn off the loud beep and "please say a voice command " message if you hold the back button . Maybe the settings are in a similar place in Debloater. I'll look tomorrow .

    Plus a dozen other things that are senselessly annoying , beep on connection to charger , random volume loss with a " loud volumes damage ears" warning message etc, etc .

Sign In or Register to comment.