AXON 7 - No data while roaming - Is this a phone or carrier issue?

  • Week One: On AT&T - No Issues with Data

  • Week Two: On TMobile - No Issues with Data

  • Week Three: On Tmobile (with working Tmobile data) but when roaming in the same AT&T network area as Week One.
      • No Data Services | Voice Service Yes.-  Phone detects, registers, and connects to AT&T voice, while roaming, but no data.
      • Different ZTE phone on same Tmobile plan roaming on the AT&T network with data, right next to me, without issue.

Can anyone definitively answer this question for me? Is this a phone or carrier issue? - Thank you so much!

Message was edited by: C D - Added one point of clarification ((with working Tmobile data)) in red

Message was edited by: C D - Clarified one bullet point in blue: (No Data Services | Voice Service Yes.-  Phone detects, registers, and connects to AT&T voice, while roaming, but no data).

Answers

  • harleyriderharleyrider Puyallup WAPosts: 19 ✭✭✭✭✭

    Clear out the old APN settings. I would never change sim cards on a unlocked phone without resetting the APN settings.

  • syaoransyaoran Manassas, VA/Toronto, CanadaPosts: 185 ✭✭

    In some areas, like West Virginia, T-Mobile does not allow data roaming onto AT&T's network.  If you are a T-Mobile customer, call customer service to verify you can data roam onto AT&T with your plan and to ensure that the area you are in isn't exempt from their data roaming. 

  • osmosizosmosiz USA - NJPosts: 250

    Honestly, you probably used your free roaming data that first time around. tmobile only gives 50-100mb of roaming data since roaming is extremely expensive for them. if you used that the first time round, then you were just out of roaming data.

  • Appreciate the response - I had another Tmobile phone right next to me, on the same plan, that was roaming. This was not the issue, roaming works fine in that area.

  • That you for the reply - It was the first time roaming with the Axon (and the TMobile line) in the AT&T area, so no data had been used. So, when I say there was no data, the data would not connect e.g. no data services e.g. no 3G/4G/LTE signals / icon, but cellular service was there.

  • Yes - I verified roaming was enabled for data (toggled it), went to airplane mode and back, and even reboot the phone. APN settings are automatically created by Tmobile, and we (are) working without issue on Tmobile.

  • Thanks for the reply - That is exactly what I did - I did all the normal 'reset' things I could think off. At least we are on the same page!

  • louisdlouisd Arguer in Chief United StatesPosts: 1,160 ✭✭✭✭✭✭✭✭

    How about swapping the SIMs from the phone that's working to the A7 and vice-a-versa.  If the A7 still doesn't work, then you likely have an A7 issue, if on the other hand the other SIM works in the A7 for roaming data, then you know you've got a SIM card/account issue.

  • syaoransyaoran Manassas, VA/Toronto, CanadaPosts: 185 ✭✭

    I am starting to think it may just be a stuck or non-responsive toggle issue with the software.  This is one of the reasons why some of us like to update our phones manually with an unlocked bootloader is because sometimes updates don't always apply perfectly or something minor gets corrupted.  On my Nexus 6P a few months back, it was stuck on not allowing data roaming even though the toggle says it's enabled.  I tried reboots after changing the setting with no luck.  I did a factory reset and that didn't help.  A complete wipe and reflash solved the issue. If this is the case with your Axon 7, then you will either have to wait for the revised bootloader unlock to come out or send it back to ZTE to be completely reflashed.  I have had this issue with every single one of my Nexus phones at one point and even as far back as my Sidekick 4G. 

  • ironbaybeedollironbaybeedoll United StatesPosts: 4,614 mod

    Hello and Welcome to Z-Community. I have not experienced this issue. I would like to see if perhaps one of our CPAs     are able to assist you in troubleshooting this issue further. Should you need anything else please let me know

  • maulgandhimaulgandhi United StatesPosts: 519 ✭✭✭✭✭

    Can you confirm whether or not you have data roaming enabled on your device?

    By going to Settings> All Settings> Dual Sim Settings> Mobile Network Settings. The first option is Data Roaming, please make sure it is enabled.

  • musicdjmmusicdjm United StatesPosts: 3,124 ✭✭✭✭✭✭✭✭

    ​ can you please take a screenshot of the Sim Status and post for us to look into further ?

    (dont forget to use the built in drawing feature in the screenshot option for the Axon 7 to cover your IMEI and phone #)

  • nosmohtacnosmohtac Posts: 6 ✭✭✭

    I've been having the exact same issue, and finally got it working. The default APN settings have the APN protocol set to IPv6. To data roam on AT&T it has to be IPv4. I couldn't edit the default APN settings so I created a new one just named T-Mobile. You can keep all the settings the same, as default APN except APN protocol. Change this to IPv4/IPv6.

    The picture I've attached is a screen shot from a web page that claimed they were the correct APN settings, but with the APN protocol set to IPv4 I couldn't get the phone to connect to data on T-Mobile. When I looked at the default settings I noticed it was set at IPv6, so I went to edit my new APN settings I touched on the APN protocol and a pop-up box gave me an option for IPv4/IPv6.

  • edrock200edrock200 Posts: 27 ✭✭✭

    Thanks for the information all! This confirms some of my experiences. I ran into this with my OnePlus two last year where the phone would have trouble staying locked on LTE, it kept falling back to hspa. In my case I had to change apn from ipv4/ipv6 to just ipv4. I've noticed no impact on speed via speed test in doing so. I also entered the mmsc info even though T-Mobile said not required. This not only fixed my roaming issues but also fixed other problems I was having like being unable to stream my skybell doorbells video stream while on mobile. I don't think all service providers are fully ipv6 aware yet. since T-Mobile basically built out their LTE networks new vice retrofitting like att and Verizon, they are probably "true" ipv6 ready vs dual stacking/routing hacks by other providers. Because of that, I recommend creating a third apn setting that is locked to ipv4.

    The interesting thing about your discovery is, at least on my phone with a new tmo sim, the default unchangeable apn setting has two settings, apn protocol and apn roaming protocol. My default is set to v4/v6 and my roaming protocol is locked to ipv4, but I couldn't roam on att until changing the default apn protocol to locked v4. This tells me two things, it must keep trying ipv6 even when connected to v4 and either tmo or the phone is not registering/recognising the att tower as a roaming tower, which is odd.

    I recently upgraded to the axon 7 but didn't think to double check apn settings again. This thread reminded me, so thank you for posting! Now if we can just get wifi calling working this will be my new favorite phone!

  • edrock200edrock200 Posts: 27 ✭✭✭

    Just a quick update, I've noticed my TMO service get no data at all in some areas when locked to ipv4. I'm guessing there new band 12 700mhz towers only accept ipv6, which makes sense since these areas rely on LTE for voice and data and ipv6 has better qos management. Therefore I changed the APN protocols to ipv4/ipv6 vice the default ipv6 locked APN profile.

Sign In or Register to comment.