Google Play Store problem - waiting for network

When i try to update or download an app, the loading bar stays at waiting for network. I already went to storage and cleared the cache and also i forced a stop and cleared the storage and still doesn't work. This is my 2nd axon my first had camera problems now this, wtf is going on?

Best Answer

  • sshasansshasan Staff Member United StatesPosts: 3,986 admin
    Accepted Answer

    UPDATE: Google is currently rolling out an update for the issue with the Play Store.

    If you are experiencing this issue please "Clear Data'' within the ''Play Store'' App.

«13456725

Answers

  • adrbadrb Toronto, CanadaPosts: 719 ✭✭✭✭✭✭

    Are you connected to WiFi internet?

  • yes i tried updating and downloading on my data and wifi still doesnt work

  • pauldowpauldow Posts: 8 ✭✭✭

    I've got this problem too. I've got the US version running on Verizon, but this is going through a Wi-fi connection.

    It looks like background application updates work, but doing one manual, or installing a new application fails with the "Waiting for network" message.

    A temporary way around is to go to Settings -> Apps -> Google Play Store, and press Disable. It will revert to what they call a factory version. Enable the Play store. Then you can then quickly open the Play Store and do an update or installation. In the background the Play Store quickly puts the so-called update back in.

  • thank you!

  • I'm having this exact issue, and that fix above didn't work.  Can anyone figure out what the permanent solution is???  Very frustrating.

  • I had to repeat the process a couple times

  • Does it only allow you enough time to update a few apps?

  • I had to disable it a couple times before it went back to normal

  • sonicvatosonicvato Posts: 3 ✭✭✭

    I have had this exact problem ever since the Nougat update. Any fix yet?

  • No fix yet for me everytime I want to update or download an app I would have to disable it but it doesn't work everytime

  • musicdjmmusicdjm United StatesPosts: 3,124 ✭✭✭✭✭✭✭✭

    The fix will be coming through from Google, this is why disabling the app and enabling resolves temp is because it removes the update from google before re-updating its self again to ensure its up to date. Google pushes out alot of updates to its shouldnt be to long

  • sonicvatosonicvato Posts: 3 ✭✭✭

    Did not work for me. Ugh. Guess I will need to wait for official solution.

  • musicdjmmusicdjm United StatesPosts: 3,124 ✭✭✭✭✭✭✭✭

    I will also reach out to the ZTE team as well and see if there is anything they can do to look into it as well and see what can be done.

  • jasonejasone United StatesPosts: 2,039 ✭✭✭✭✭✭✭✭

    I've not experienced this issue I'd probably factory data reset if it were me. Especially if reverting back to the original Play Store or clearing the cache didn't work. The Axon 7 at least gives you the option to not erase your files. Although I know installing all your apps and logging in again is a pain.

  • Has anyone thought about how the split-screen feature of Nougat interferes with many apps working correctly ? I would like to delete the split-screen feature all together but no one seems to know if that's possible .On MM   6.0.1  a real estate app I had worked smoothly .Now it stalls and works  a little crazy on  a split -screen extremely hard to maneuver .Any help would be  appreciated .Otherwise , I am totally in love with the hardware including beautiful detailed pictures ,and the sound quality for my music interests.

  • hollaphollap United StatesPosts: 8,376 ✭✭✭✭✭✭✭✭

    ​, don't take this the wrong way, but if using split screen makes an ap work incorrectly, can't you just not use split screen when using that app?  Why do you even need to turn off SS completely?

  • vanguyvanguy USAPosts: 597 ✭✭✭✭✭

    Not trying to be rude here at all,  but this thread is about issues with the play store.

    If you have a different issue such as split screen, it's best to start a new discussion. You will get much better response

  • Ok that actually has worked for me once now. Interesting

  • pauldowpauldow Posts: 8 ✭✭✭

    Looks like this issue can be considered fixed with the 7.1.1 (B19) update.

  • Not for me. I still have the problem. The play store is updated to 7.6.08, which I believe came with the 7.1.1 update.

    I still get the"waiting for network" when I install or update any app.

    Did you have to do anything special after the 7.1.1 update for this problem to go away?

  • pauldowpauldow Posts: 8 ✭✭✭

    Oops. My mistake. It's still not working. I thought I saw an update downloading, but when I go back in, I see it's still stuck on the ol' Waiting for Update.

  • Problem surfaced on my A7 last night. Like others noted, if you disable the Play Store temporarily or uninstall the Play Store updates you can then update old apps or install new apps. Hopefully fix comes soon.

  • Appa69Appa69 United StatesPosts: 46 ✭✭✭✭✭

    Me, too. Same exact thing. Reverted to version 7.2.13, working for now.

  • adrbadrb Toronto, CanadaPosts: 719 ✭✭✭✭✭✭

    Yesterday it started for me, then it worked I do not know how for a batch of app updates, but today again "waiting for network connexion".

    Reverting to the 7.2.13 from the firmware enabled again the app download.

  • Just had this happen to me as well, I have a  Galaxy S7 and it has not seen this problem. Like others have said seems to be zte software issue.

  • alferalfer Posts: 136 ✭✭✭✭✭

    Been running Nougat since day one with pretty much no issues until last night when I too got the dreaded Google Play "Waiting for network".  WTF?  Why now all the sudden? I haven't done anything different to cause this.

    Had to do the disable trick to make it work. Has to be software issue since all other Android devices in our house are having no issues with Play Store.  Arrrrgh.

  • kylefromjakylefromja United StatesPosts: 27 ✭✭✭✭

    I started having this exact same problem last night, I had uninstall the play store updates and revert back to the factory version, i was able to download the updates then

  • Exactly the same story here. Been running fine with no issues and then out

    of nowhere this happens.

  • musicdjmmusicdjm United StatesPosts: 3,124 ✭✭✭✭✭✭✭✭

    Also had this problem yesterday as well. Same thing as everyone else, going into the settings > then apps > clicking play store and then disable. Once disabled click enable and open the play store and accept. After that it was working fine again

  • Yup, woke up with this issue today. Really damn annoying. I guess we`ll wait for a fix. The disabling and enabling is the only temporary fix at the moment. Hurry up Google!!!!!!

Sign In or Register to comment.