Google Play Store problem - waiting for network

2456725

Answers

  • busymanbusyman CanadaPosts: 401 ✭✭✭✭✭✭

    I tried disabling and re-enabling, but it didn't work. This problem came up today, as did with everyone else. Ugh

  • Try uninstalling the updates for Google Play.

  • adrbadrb Toronto, CanadaPosts: 719 ✭✭✭✭✭✭

    The updates are automatically uninstalled on disable.

  • i got mine fixed for now. go to settings , apps ,all apps find google play services , click on 3 dots on right top corner and click on uninstall updates . go back into google play and fillow instructions. works for now anyways !

  • That definitely helped. Now what exactly happened ? Did it update my pending apps under the older version of Play Store ? Will this error come back ? Thanks

  • It will keep coming back until ZTE addresses problem.

  • busymanbusyman CanadaPosts: 401 ✭✭✭✭✭✭

    It's not ZTE's fault lol, it's Google's. My Samsung tablet won't update apps either.

  • fatdoggyfatdoggy Posts: 23 ✭✭✭✭

    Also had this issue suddenly today. Hope the fix comes out soon.

  • sshasansshasan Staff Member United StatesPosts: 3,986 admin

    This is a confirmed Google Play Store issue and not an OEM issue.

  • jtmackjtmack Posts: 59 ✭✭✭✭✭

    Welcome to the buggy world of Android! It's a freaking joke. With this "solution" you have to uninstall the new version of Google Play every time you wanna update. Has anyone figured a real answer yet? Like preventing GP from updating itself every time?

  • scientist07scientist07 Posts: 10 ✭✭✭✭

    Started happening to me a while ago as well.

  • tom604tom604 Vancouver BCPosts: 102

    I started having this problem since the 7.1.1 update. I cant even download any new apps.

    Very frustrating, hope they fix this asap.

  • Appa69Appa69 United StatesPosts: 46 ✭✭✭✭✭

    Settings>apps>Google play Store

    hit disable, this will remove updates.

    Re enter play Store, now should work.

  • landzonelandzone San DiegoPosts: 65 ✭✭✭✭✭

    Same here started We'd night. Came here to find out why. Thanks to all who posted the temporary fix.

  • adrbadrb Toronto, CanadaPosts: 719 ✭✭✭✭✭✭

    IT may be, but I have several phones and tablets in the house and only the A2017U is doing this.

  • ronin550ronin550 Oak Grove, MOPosts: 151 ✭✭✭✭✭

    Yep that's what I did!!

  • It started happening to me yesterday, I contacted Google help and they gave me a bunch of instructions that either don't work or only fixed the problem temporarily. I would suggest you do the same, the more people complain the faster it will get fix.

    Anyway here's what Google suggested. I tried them all minus resetting the phone;

    Force a server check-in

    Sometimes, forcing a check-in with Google's servers will resolve this issue. You can do so using the Date and Time settings on your device.

    1. Navigate to Settings.
    2. Scroll down to System and touch Date & time.
    3. If the phone has the following choices, please un-check them:
      • Automatic Time Zone
      • Automatic Time Updates
    4. Manually change the date and time, so that they are incorrect.
    5. Touch the Home Screen button.
    6. Go back to Date & time settings (Step 2).
    7. Manually change the date and time, so that they are correct.
    8. Re-check the boxes for "Automatic Time Zone" and "Automatic Time Updates."

    Once the date and time on your device has been corrected by the Google servers, you can try downloading an app again.

    Clear the cache and data of the Play Store and Downloads:

    1. Go to Settings > Apps > Google Play Store > Storage.
    2. Tap Clear data > OK.
    3. Tap Clear cache.
    4. Next, go to Settings > Apps > Downloads > Storage and repeat steps 2 & 3.

    Note: this may reset Play Store settings. After clearing cache and data of the Play Store app, double check your settings: Open Play Store > Menu (3 horizontal bars) > Settings.

    Check that your device is supported

    Next, check to make sure that your device is on the Supported devices list. If not, your device might not support the Play Store app, and you should contact the manufacturer.

    Remove and re-add your Google account

    If the issue persists, you can try removing and re-adding your Google account:Note: This may delete settings and un-synced in-app content. However, your purchases and synced data (Gmail, Google contacts, etc.) are tied to your account and will be available after re-adding your account.  Make sure you remember your account password because you'll need to log back in after re-adding your account.

    1. Remove your account:
      1. Go to Settings > Accounts > Google and tap the name of the account you wish to remove.
      2. Tap More (three vertical dots) and Remove account. Tap Remove account again to confirm account removal.
    2. Add your account back to your device:
      1. Go to Settings > Accounts > Add Account.
      2. Select Google and enter your account information.

    Restart your device

    A device restart can also solve this issue. If you haven't already done so:

    1. Press and hold the power button until the device shuts down.
    2. Press and hold the power button again until the device turns back on.
  • adrbadrb Toronto, CanadaPosts: 719 ✭✭✭✭✭✭

    Well, ​ also contacted Google and he was told it was on their side. I quote

    "You are correct...I spoke with a Google technician and it was a known widespread problem with the Nexus phones and they recently became aware of problems with the Axon 7.  No known ETA but they have a team trying to fix it and I will be notified when solution is determined.   I've spent hours including the factory reset attempt  trying to fix on my own.  Google Services can't update now so Android Wear won't work which means my smartwatch is down now too.  What a mess....."

  • One thing is having a problem with downloading and upgrading apps but having an expensive piece of tech (some Android Wear watches can cost as​ much as the Axon 7) rendered useless, it will make people really mad.

  • a7lexa7lex ClevelandPosts: 49 ✭✭✭✭

    I have encountered this issue yesterday. After trying a pretty much everything with the Google account and wiping out the recovery partition I have resorted to FDR. Which helped.

    So FDR is looking as only solution for this issue at the moment.

  • Given I am able to update apps or install new apps by uninstalling the

    Google Play updates there is no way I going to wipe clean and start over.

    To much of a hassle. Perhaps if I could be guaranteed it wouldn't happen in

    the future, maybe, but not under present circumstances.

  • celticchryscelticchrys Posts: 234 ✭✭✭

    The problem comes back after about 5 minutes, after the Play Store automatically updates itself once more. You then have to uninstall updates again, to update another app. We just have to wait for Google to fix their screw-up.

  • celticchryscelticchrys Posts: 234 ✭✭✭

    This does the same thing for this problem that going into app settings and uninstalling updates for the Play Store does: put Play store temporarily back to the way it was on the Nougat factory image. After 5-10 minutes, the Play Store will silently auto-update itself, and the problem will return. Don't FDR when it does. Just go into app settings, and uninstall updates for a temporary fix. You'll have to do it repeatedly until Google fixes it.

  • adrbadrb Toronto, CanadaPosts: 719 ✭✭✭✭✭✭

    A friend of mine who had to do an FDR on his A2017U B15 and then later updated to B19, now does not have this Play store issue.

  • musicdjmmusicdjm United StatesPosts: 3,124 ✭✭✭✭✭✭✭✭

    Thats because it reverted the play store build back to the original that was saved on the device, once the play store updates itself again the issue comes back

  • It seems that this is linked to the recent Android 7.1.X update, on Axon 7, Pixel, and some Nexus devices. More devices may pop up as they get the OS update as well.

    Below is a temporary fix, but this will need to be repeated every time the Google Play Store updates silently in the background, which is very often, usually within the same day, or after a device reboot. The following should be considered a temporary fix until a patch has been released.

    To do this, go to Settings > Apps > Google Play Store > Uninstall Updates.

    Open the the Play Store. As soon as the Play Store opens, pull down your notification bar, look for the Google Play Store update progress bar to show up,  pull that down to expand it (if necessary), and press cancel before the update completes. This happens quickly, if you miss the cancel button, you'll need to uninstall updates again.

    Running the factory version of the Google Play Store will allow you to download apps. I've seen this remain functional from as short as half an hour, to as long as several hours, until the Play Store updates silently in the background, in which case the above steps must be performed again.

    It's annoying, I know, but it will allow you to download and update the apps you want for now until Google releases a patch.

  • scott779scott779 Posts: 140 ✭✭✭✭✭

    Yes, it is dependent on the version of the PlayStore.

    I have an older LG G3 that I keep in "Airplane" mode cuz I just use it for games and the camera only.

    When my Axon 7 displayed the "Waiting for Network" message (last night and this morning), I turned off Airplane mode on the G3 and I installed 23 updates over 25 minutes without any issue.

    And I would like to confirm that "rezobyte's" method of temporarily getting the PlayStore to work did indeed work for me:

    "To do this method, go to Settings > Apps > Google Play Store > Uninstall Updates. Open the the Play Store. As soon as the Play Store opens, pull down your notification bar, look for the Google Play Store update progress bar to show up,  pull that down to expand it, and press cancel before the update completes. This happens quickly, if you miss the cancel button, you'll need to uninstall updates again."

Sign In or Register to comment.