How I rooted my Axon 7

I will start off by saying none of this information has been created by me, all credit goes to the developers as they are incredibly hard working people to get you what you need. I will link the original threads under each step I attempted so you can do your own research and get the full details/downloads.

Secondly, I am not responsible for anything you do to your device, I am simply sharing my experience over the past few days and maybe help someone out. This is going to be a very basic explanation of the steps I did to find which method works for my Axon 7.

I have an Axon 7 US variant (A2017U) and I bought it used, came with the B27 build on it. I immediately updated to build B29 as I felt that there was more support with rooting B29, I was wrong.

So here is what I had tried:

The very popular XDA thread for force flashing TWRP recovery onto a locked bootloader using the "axon7tool" more popularly known as Tenfar's Tool, and I had tried many different versions of signed/unsigned/official/unofficial TWRP from 3.0.2-0 to 3.0.4, but every time it would not allow me to boot into TWRP no matter what I did. (Yes, after every attempt I rebooted into EDL mode for a fresh start) I even broke out one of my linux laptops to try the linux based tool, but that did not get me anywhere (and I dont recommend doing that unless you are familiar with creating .rules files in your system) However, on my Windows 8 computer (Windows 7 is what I use on my main adb/fastboot computer), I was able to use this tool to backup my recovery, gpt, and boot partitions (HIGHLY recommend doing this part first) and I was able to put back on my backed-up recovery each time TWRP failed to work, so I was in a safe(ish) position.

XDA link: axon7tool: Flash and backup boot/recovery us… | ZTE Axon 7

There is also another very popular thread on XDA for the A2017U variant about using MiFlash to flash a modified fastboot to the axon, even had specific files for the A2017U on B29, but no matter how many times I reinstalled drivers, switched USB ports, rebooted, etc, I would always get the "cannot retrieve hello packet" error, eventually leading to a timeout error. Tried that program on Windows 8, but no success either.

XDA link: [EDL][A2017/A2017U] Emergency DL Mode TWRP +… | ZTE Axon 7

Finally, I decided to go the old fashioned route, and looked it up on YouTube to see if there were a different reliable way of doing the whole process, and I came across RootJunky's tutorial and so far everything he has provided for other devices, have worked flawlessly in my own experience. It consists of downloading a zip file with everything you need inside of it, even a written step-by-step text file. Pretty much you downgrade to B20, apply the fastboot mod, then run the "fastboot oem unlock" command on your computer, then flash Twrp, then flash a file to update from B20 to B27, then one more file to update from B27 to B29, then flash SuperSU package to root your axon. It was the fastest method and worked first try for me, and all of it is done with the stock recovery and bootloader, all that is needed is an SD card and a computer with fastboot configured properly.

YouTube link: How To Unlock The Bootloader On The ZTE Axon 7 - YouTube

Obviously this is not for everyone, some people may have perfectly fine success with the first two methods, but I just wanted to post this to let others know about what I had to do to unlock the bootloader somewhat safely.

Been running B29 rooted, unlocked bootloader for a few days now, and the only issues I have seen are the same issues you would see on fully stock B29, and I am having some difficulties with AdAway applying properly, which I will make a post about when I get it working correctly.

Sign In or Register to comment.