When I set alarm with Okay Google, the alarm will only vibrate when it goes off (ZTE Zmax Pro)

When I set alarm with Okay Google, the alarm will only vibrate when it goes off. But when I set the alarm manually, it goes off just fine.  For example, I say, "Okay Google", and then I say, "Set alarm for 1 minute". 1 minute later, the alarm vibrates, it doesn't sound.  But when I manually set the alarm for 1 minute, the alarm does sound.  Can this be fixed? I use the alarm a lot, and it is much faster to verbally set the alarm and label.

Comments

  • alanhoustonalanhouston Posts: 659 ✭✭✭✭✭✭

    I have the same result.  If Google is involved (I was using Google Assistant to set alarms) the alarm may vibrate, but is never audible.

    I changed every possible setting and never got sound.  Then I did an internet search and found people with every sort of phone have been complaining about this for two years.

    Several people reported that you can open a Google menu connected to your Google Now account  and make changes that solve the problem. I have not been able to find a Google account menu that relates to this problem.

  • Thanks for the reply.On your tip, I went through all the menu items related to Google Now, and couldn't findThanks for the response. On your tip, I checked all the Google Now account menu items, but nothing seemed to apply.  I also downloaded Timely, as an ad said you could control Timely with Google Now commands, but I couldn't figure out how. Nothing seemed to work.

  • asianrockerasianrocker ILPosts: 243 ✭✭✭✭✭

    I tried it too with ok google and assistant pop up same as yours vibrate only. Here's the kicker, my cheap tablet suddenly is chirping. Why? Because it also set the alarm for 1 minute. LOL.

    My cheap tablet don't even have an assistant but only ok google but the alarm setting works with sound. Really ZTE?

  • alanhoustonalanhouston Posts: 659 ✭✭✭✭✭✭

    A Google search finds lots of complaints since 2015 from Samsung and LG owners that audible alarm clocks that are set by voice using "Google Now" or "Ok Google" and now with "Google Assistant" are not reliable.

    I use android phones from Samsung, LG, and ZTE.  I have, in the past, used android phones from Kyocera and Alcatel.  I have found that when a problem, such as the voice activated alarm clock problem, occurs with one brand using android 5.1, the other brands using 5.1 will have the same problem.

    Of any 100 problems, about 70 are a Google  android problem, about 15 are network created (T-Mobile WiFi calling) and maybe 15 are related to manufacturer mistakes with hardware and firmware.

    So, if you are frustrated with a ZTE Nougat phone, you are likely to be frustrated by a Samsung or LG Nougat phone, as android is, and will remain, a very buggy operating system.

  • Thank you Alan. Very helpful. My Zmax Pro has 6.0.1 Marshmellow, not 7.0 Nougat. I read you can upgrade with a beta Nougat.  Perhaps that would solve the issue?  Is the beta Nougat stable enough that it wouldn't be a nuiance?

    From: alanhouston <zte.community@zteusa.com>

    To: Michael Decious <m_decious@yahoo.com>

    Sent: Wednesday, March 22, 2017 7:24 AM

    Subject: Re: [ZMAX ] - Re: When I set alarm with Okay Google, the alarm will only vibrate when it goes off (ZTE Zmax Pro)

    Z-COMMUNITY

    |

    Re: When I set alarm with Okay Google, the alarm will only vibrate when it goes off (ZTE Zmax Pro)

    reply from alanhouston in ZMAX - View the full discussionA Google search finds lots of complaints since 2015 from Samsung and LG owners that audible alarm clocks that are set by voice using "Google Now" or "Ok Google" and now with "Google Assistant" are not reliable. I use android phones from Samsung, LG, and ZTE.  I have, in the past, used android phones from Kyocera and Alcatel.  I have found that when a problem, such as the voice activated alarm clock problem, occurs with one brand using android 5.1, the other brands using 5.1 will have the same problem. Of any 100 problems, about 70 are a Google  android problem, about 15 are network created (T-Mobile WiFi calling) and maybe 15 are related to manufacturer mistakes with hardware and firmware. So, if you are frustrated with a ZTE Nougat phone, you are likely to be frustrated by a Samsung or LG Nougat phone, as android is, and will remain, a very buggy operating system.

    Reply to this message by replying to this email, or go to the message on Z-Community

    Start a new discussion in ZMAX by email or at Z-Community

    Following Re: When I set alarm with Okay Google, the alarm will only vibrate when it goes off (ZTE Zmax Pro) in these streams: Inbox

    |

    © 1998 - 2016 ZTE Corporation and ZTE USA. All rights reserved.

    |

  • alanhoustonalanhouston Posts: 659 ✭✭✭✭✭✭

    My earlier reply was long, but not clear.  Setting an audible alarm clock with a voice command is not reliable because of bugs in the voice command software of Google Now/Google Assistant.  This is not a ZTE problem or Sansung problem, it is a problem for every phone with Google voice command software.

    The problem has been discussed on various forums for two years but never fixed.  Google adds features and deletes features, rarely does Google FIX a feature.

  • beachtraxbeachtrax SoCalPosts: 17 ✭✭✭✭✭

    My ZTE Axon 7 has 7.1.1 and does not have that issue. I just tried it and after one minute I get both vibration and the alarm with sound. I used Google Assistant.

  • alanhoustonalanhouston Posts: 659 ✭✭✭✭✭✭

    This problem has been discussed on different forums for the past two years.  It seems that there is a control menu for Google services including Google Now and Google Assistant that enables users to select audible alarms or vibrate only alarms.

    The problem is, nobody knows how to access that control menu.  The people who want to switch from audible alarms to vibrate only alarms can't find it.  The people who want to switch from vibrate to sound can't find it.

    With Nougat 7.1.1, are you able to give Google Assistant a verbal command to set a vibrate only alarm one day, and then give a verbal command for an audible alarm the next?

  • beachtraxbeachtrax SoCalPosts: 17 ✭✭✭✭✭

    Honestly I have never tried to give Assistant a verbal command to set a vibrate only alarm one day, and then give a verbal command for an audible alarm the next. My experience has been as I posted earlier. Mine just does alarm and vibrate by default.

  • producemaster1producemaster1 CaliforniaPosts: 3 ✭✭✭

    Bumping because I am having this same problem. Bought the phone 4 days ago. Any update or fix on this issue? News?

  • sshasansshasan Z-Community Moderator New York Posts: 3,154 admin
    edited November 13, 2017 12:08AM

    @producemaster1 said:
    Bumping because I am having this same problem. Bought the phone 4 days ago. Any update or fix on this issue? News?

    Here's what I've found to work:

    The default clock on the ZMAX Pro is not compatible with the Google Assistant (this is also the case with some other OEMs as well).

    Download the Google Clock from the Play Store ---> Use Google Assistant to set an alarm ---> It will ask you which app you want to use ---> Select it manually the first time --- Let that alarm go off and then going forward you should be able to use Google Assistant and it will automatically default to the Google Clock and allow an audible alarm.

  • producemaster1producemaster1 CaliforniaPosts: 3 ✭✭✭
    edited November 13, 2017 11:16PM

    @sshasan said:

    Download the Google Clock from the Play Store ---> Use Google Assistant to set an alarm ---> It will ask you which app you want to use ---> Select it manually the first time --- Let that alarm go off and then going forward you should be able to use Google Assistant and it will automatically default to the Google Clock and allow an audible alarm.

    Downloaded the Google Clock. Used Assistant. It didn't ask me which app it just did it on the stock clock.

  • sshasansshasan Z-Community Moderator New York Posts: 3,154 admin

    @producemaster1 Try setting an alarm manually direct from the Google Clock first and then try again with Google Assistant.

  • TatayoTatayo 29687 Posts: 1 ✭✭

    Borrowing ideas from here, I..

    1) installed Google Clock from Play Store
    2) from settings/apps disabled current clock

    That's all!

    Now, ok Google obeys correctly and controls your alarm needs.

  • producemaster1producemaster1 CaliforniaPosts: 3 ✭✭✭

    @Tatayo said:
    Borrowing ideas from here, I..

    1) installed Google Clock from Play Store
    2) from settings/apps disabled current clock

    That's all!

    Now, ok Google obeys correctly and controls your alarm needs.

    Trying this now..... aaand BINGO this did the job thanks!

  • DoppelgangerDDoppelgangerD USA Posts: 1,098 ✭✭✭✭✭✭✭✭

    @Tatayo said:
    Borrowing ideas from here, I..

    1) installed Google Clock from Play Store
    2) from settings/apps disabled current clock

    That's all!

    Now, ok Google obeys correctly and controls your alarm needs.

    Nice job, and great post for your first one on Z-Community. Welcome to the fold @Tatayo.

Sign In or Register to comment.