Axon 7 - DND (Do not disturb) - random activation

I've read in the forum about instances of DND not turning off at the appropriate time but haven't seen anything related to my problem.

Since updating to 7.1.1, my DND enables automatically at random times.  I go into setting to turn it off and somewhere between 3 and 30 minutes later it gets re-enabled.  I do not believe I have any background programs causing this issue (perhaps hiya?)

Is anyone else experience this?  It's frustrating and increasingly maddening because I'm missing important phone calls and notifications.

Thanks!

Comments

  • adrbadrb Toronto, CanadaPosts: 719 ✭✭✭✭✭✭

    Do you have any automation apps running, like Tasker ? Tasker and other automation apps can activate and deactivate DND with a custom task.

  • jasonejasone United States Posts: 2,039 ✭✭✭✭✭✭✭✭

    DND has been working perfectly for me and I have it scheduled to come on every weeknight. I have seen past reports of DND becoming enabled when taking a call. Does this happen after you've taken a call? It's also worth checking the schedule to make sure it's not scheduled to come on.

  • musicdjmmusicdjm United StatesPosts: 3,124 ✭✭✭✭✭✭✭✭

    I havnt run into this issues yet either but another thing you can do is go into the DND setting and simply set it to allow calls to come through and then you wont need to ever worry about missing anything.

    settings> sound > Do not disturb

    Do not disturb mode : priority only then go to the Sound allowed and for calls and messages set to everyone

    That away if it ever reactivates your not missing the calls or messages

  • adrb: I do not have tasker but I've purchased it before.  Is it possible for tasker to check if DND is on and have it turn off?

    jasone: I think there's some merit to DND turning on after a call (whether answered or not).  I just noticed hiya blocked a call a moment ago and I saw the DND icon.  It could be unrelated though.

    This morning I unchecked enable splam protection and callerid within the phone app and that seemed to keep DND at bay.  That's why I'm thinking there may be something related to Hiya that's causing this issue.

  • adrb: I do not have tasker but I've purchased it before.  Is it possible for tasker to check if DND is on and have it turn off?

    jasone: I think there's some merit to DND turning on after a call (whether answered or not).  I just noticed hiya blocked a call a moment ago and I saw the DND icon.  It could be unrelated though.

    This morning I unchecked enable splam protection and callerid within the phone app and that seemed to keep DND at bay.  That's why I'm thinking there may be something related to Hiya that's causing this issue.

  • musicdjm - I've tried changing DND to priority  only and changing sound allowed to all allarms, reminders, events, messages, and caller. Unfortunately that also resets itself when DND turns on

  • musicdjmmusicdjm United StatesPosts: 3,124 ✭✭✭✭✭✭✭✭

    ​ thank you for the quick response back, so looking into this issue it looks like this is something that is going on with alot of devices, and has been in issue within Android as the trouble ticket on the google android code site shows many people having the issue. Hopefully we can find some more suggestion for ya. Can you tell me do you use an Android Wear device ?

    Ill make sure this thread gets sent over to the Mod team at ZTE as well for you

    Issue 226328 - android - Phone changes to Do not disturb mode when a call is initiated - Android Open Source Project …

  • adrbadrb Toronto, CanadaPosts: 719 ✭✭✭✭✭✭

    Tasker and other automation apps can check DND most probably and turn it off, but Tasker is not 100% reliable on this phone for me most probably because of the aggressive ZTE power management.

  • adrbadrb Toronto, CanadaPosts: 719 ✭✭✭✭✭✭
  • musicdjmmusicdjm United StatesPosts: 3,124 ✭✭✭✭✭✭✭✭

    ​ Im confused are you asking a question or just pointing out an article ? Did you mean to reply to the thread not me?

  • adrbadrb Toronto, CanadaPosts: 719 ✭✭✭✭✭✭

    I am pointing out this article that seems to show that Google introduced this as a feature in the Google Phone app, not in Android 7.1

    But we do not have a Google phone app, the new versions cannot be installed on the A2017U

  • manjanmanjan Posts: 4 ✭✭

    Same problem here. This started happening to me last night (March 27), while I was messing around with the Daydream View. Initially I didn't understand what the "no symbol" in the notification bar was for. I search all over for "android no symbol notification bar" and "android circle with diagonal line through it notification bar" to no avail. Finally I figured out it's the DND symbol for Android.

    Anyway, every time I turn DND off, it keeps coming back within 30-90 mins. Like I said I didn't really change anything (consciously), and the only new thing I did was use the Daydream app for around 15-20 mins

  • ironbaybeedollironbaybeedoll United States Posts: 4,602 mod

      Hi Guys! Please join in the discussion already in progress here  In an effort to consolidate, this thread will be locked. Thank you.

  • theshriketheshrike CaliforniaPosts: 37 ✭✭✭✭✭

    Do not disturb started randomly turning on after I use the Daydream also. I just got Daydream a few days ago and since using it I have noticed do not disturb coming on at random times. I have it set to come on on certain days at night and never had a problem with it before.

  • This is a major problem for me. I just upgraded to Build Number A2017UV1.1.0B32 . Do Not Disturb is continually turning on at seemingly-random times, even though I always turn it off and have deleted my rules. I even disabled Daydream, but to no avail. The phone will restart with Do Not Disturb turned on as well, even though it was previously turned off.

    If I don't get notifications, this phone is NOT very useful. I have no idea what else to do to fix the problem.

  • theshriketheshrike CaliforniaPosts: 37 ✭✭✭✭✭

    Do you have an Android Wear watch connected to your phone?

  • murray.mitchellmurray.mitchell Posts: 2 ✭✭
    edited September 21, 2017 8:16AM

    The solution for me was simple... Factory reset and reconfigure everything. I still don't know what went wrong, but it is now working perfectly. Too bad it takes days to get everything right after a factory reset. I do not have Android Wear, and did not reinstall Daydream, for what it's worth.

  • I purchased a new ZTE Blade X Max. I do not have any watches or have installed any apps yet and when I make or receive calls, the DND is automatically activated. I thought had defect phone and sent in and got new on and it does same thing. Very frustrating as I missed an emergency phone call due to this.

  • scott779scott779 Posts: 140 ✭✭✭✭✭

    I wanted to say I've had my Axon 7 for almost a year and have never had this issue nor do I know how to navigate to or where this (I assume built-in) feature is inside the Axon 7. However I use "Silence Scheduler" and haven't ever had issues with it.

Sign In or Register to comment.