Issues with SD Card

new2axonnew2axon Posts: 41 ✭✭

I have been using an SD card for a will and just recently I figured I would format it with the AXON 7 to start fresh. I have tried multiple time to format the card through the phone and it fails every time. Has anyone here successfully formatted the card through the phones options?

The image attached shows the error and the format never gets past 20%.



  • runtohell121runtohell121 Analyst United StatesPosts: 2,157 ✭✭✭✭✭✭✭✭

    Is the card used on other devices before the Axon 7? If it's a new card, is it possibly a fake card? Or maybe the card itself is damaged in someways you might not have known?

    If you have a computer, I would suggest using SD Formatter and do an overwrite format to see if it can successfully overwrite the card, but that will most likely take an hour or more depending on the speed of the card reader and the card itself.

  • new2axonnew2axon Posts: 41 ✭✭

    The card was removed from my previous galaxy S4 and installed directly into the Axon 7. I don't believe it is fake since I have used it for over 2 years without an issue. Might be damaged, not suew how though. I will try formatting it the way you recommended. See what happens. Thank you.

  • dnewman007dnewman007 United StatesPosts: 3,402 ✭✭✭✭✭✭✭✭

    I had no issues formatting my SD card on my A7.

  • Hi is it old i had the same issue and i read it happens in old sd cards the suddenly become unable to erase the data in them and also you cant save anithing on them, the worst is that the celphone suffers in that case it become really sluggish and use lots of battery

  • razor512razor512 United States Posts: 2,535 ✭✭✭✭✭✭✭✭

    Often when this happens, it means that the card has locked itself into a read only state. Micro SD cards do this when a number of flash cells have failed, in order to prevent data loss.

    if the card cannot be formatted on another system, then this will likely be the case.

    PS, most micro SD cards have either a 10 year warranty, or a lifetime warranty, thus the companies will replace them for free as well as cover shipping both ways.

  • dnewman007dnewman007 United StatesPosts: 3,402 ✭✭✭✭✭✭✭✭

    Thanks for the info!!

  • new2axonnew2axon Posts: 41 ✭✭

    Hey, I downloaded SD Formatter from the web and attempted to run it as you suggested but was unable too. It tells me that the Micro SD Card is Write Protected. I looked for a switch on the card but there isn't any. I then looked at the SD card adapter but that didn't have a lock switch either. I went ahead and tried using command prompt to format the SD card but got stuck on which choice to format it to (Fat32). Any help to format my Adata 64gb Micro SD card would be greatly appreciated.

    Anyone chiming in would be helpful.

  • new2axonnew2axon Posts: 41 ✭✭

    I wonder if this is what I am dealing with. Do you think the card doesn't format because I took it out of my Galaxy s4 an placed it directly into my axon 7 without formatting it from the begging?

  • razor512razor512 United States Posts: 2,535 ✭✭✭✭✭✭✭✭

    Typically once that has happened, it means that the card's build in controller has locked the card permanently. This is a failure mode of more modern micro SD cards where if the error rate for reading data from the NAND gets too high, or if a number of flash cells fail, the card will enter into a read only state in order to prevent data loss. This mode is designed so that the user can backup any data left on the card, and then RMA the card if under warranty.

    Sadly, unless you go through some rather extreme measures, it is pretty much impossible to talk directly to that controller built into the micro SD card, and even then, there is no telling if you will get access to the write protect controls.

  • ntotrrntotrr Posts: 40 ✭✭✭✭✭

    I had no issue using a card that I had in my previous phone.  I formatted the card using my computer and then used it in the Axon 7.  After the update of the OS to Android 7, I was experiencing some very annoying glitches with the phone, including lockups.  I did a factory reset on the phone and that solved those issues.  I didn't remove the memory card prior to doing the factory reset and I think that's what my problem was because my card would no longer work in the phone after the reset.  I couldn't format it in the phone or using my computer.  I tried quite a few programs to format the card but to no avail as the card was locked.  I was able to RMA the card and get a new one.  My lesson learned is to remove the card if I ever have to do a factory reset again, this phone is a bit finicky with memory cards I suspect.

  • new2axonnew2axon Posts: 41 ✭✭

    Sounds like the same thing I went through. I gave up on the 64gb card and plan on ordering a 128gb in its place. Should I stick to Samsung memory cards or are there other reliable brands you all recommend?

  • ntotrrntotrr Posts: 40 ✭✭✭✭✭

    I have a variety of brands of memory cards fory cameras, tablets, and phones. I have quite a few Transcend brand cards that I use. That's the brand I use in my Axon 7 and my wife uses on her Sony Xperia phone. At this point, I'm assuming that the factory reset caused the issue with my memory card and I'm blaming the Transcend card.

  • dnewman007dnewman007 United StatesPosts: 3,402 ✭✭✭✭✭✭✭✭

    I'm using a Sandisk Extreme Plus ZC 1 64 Gb card that I formatted with my Axon 7. I have had no issues with it.

  • rizscottrizscott United StatesPosts: 9 ✭✭✭✭

    I used to use the phone to successfully format the SD card. Have you tried formatting the SD card on your PC? If the PC is failed to format SD card, then running CDM on the PC is a way to repair the SD card.

Sign In or Register to comment.