Z981 does not refresh tower

snn5snn5 Southeast USPosts: 662 ✭✭✭✭✭✭

For whatever reason once the phone loses signal I have to toggle airplane mode to reconnect when in spotty signal areas. When I come back to a strong area it doesn't reconnect. Have to toggle again. If I don't then it stays with No Signal until I refresh or power off and on.

Answers

  • sshasansshasan Staff Member United StatesPosts: 4,077 ✭✭✭✭✭✭✭✭

    You may have tried this already... Reset networks and connections.

    If that doesn't help, try giving your carrier a call and ask for them refresh the network on their side to your device.

  • snn5snn5 Southeast USPosts: 662 ✭✭✭✭✭✭

    I did try that, but manually refreshing is all that seems to work.  Not a huge deal usually since I have a strong signal on T-Mo most all the time, but going out to the sticks I didn't know it wasn't connected to LTE until 1.5 hours later.  Carrier isn't an issue since it's the same SIM I use in my G4 and iP7+ and both work fine with carrier SIM.

  • thecarpenterthecarpenter Mesquite, TexasPosts: 635 ✭✭✭✭✭

    You don't want to read this but.....you will likely need to factory reset your unit.  record all your login info in active apps before doing this.  Or use a Google account back up.  either way fdr is probably your solution here

  • snn5snn5 Southeast USPosts: 662 ✭✭✭✭✭✭

    Yes. Have tried that too. This is a warranty replacement issue. And if a FDR were in order, restoration from a backup would be ill advised.

    To to be fair. I've had network and Bluetooth connectivity issues with this Zmax line for some time.

  • IHS5452IHS5452 United StatesPosts: 14 ✭✭✭✭✭

    Try going into the dialer, and typing ##873283#. That will refresh the list of towers that are near.

Sign In or Register to comment.