Why Can't I choose a network mode in the Grand X Max 2

I have a new Grand X Max 2 and I can't find where to choose the network mode. Settings > Mobile networks > Mobile Data simply asks if I want to allow the phone to access data over mobile networks and Settings > More has nothing. What gives? Hardreset seems to think that this is possible, but I don't see any of those options.

I tried *#*#4636#*#*, but that didn't seem to do anything. I bought a booster for the house that worked fine when I could set 3G as the preferred network, otherwise my reception is poor.

How can I choose a preffered network to exclude LTE?

Comments

  • jimlloyd40jimlloyd40 Phoenix, AZ Posts: 15,863 ✭✭✭✭✭✭✭✭

    If it's like most phones go to the settings and scroll down to "mobile data". Don't click on the toggle that turns on and off "mobile data". Just click on where it says mobile data. Then on the next screen click on "network mode" and make your selection.

  • DrakenFXDrakenFX Los Angeles, CA Posts: 1,518 ✭✭✭✭✭✭✭✭
    edited July 19, 2017 12:11PM

    @chefjansheik
    I don't own this device, but you should have a " Sim Settings " under the main setting page, there you'll find " Network mode".

    Otherwise. You mind posting screenshit of the Setting Page?

  • chefjansheikchefjansheik Posts: 2 ✭✭✭

    @jimlloyd40: Unfortunately the only option behind mobile data is a "Standard data" toggle option.

    @drakenfx: Also, unfortunately there is no sim settings page. Instead of posting my entire settings page, I just searched for "Sim Settings" and have posted the results for that search.

    I spoke with ZTE Customer service, who seems to think that this is an issue related to the latest Android version (perhaps). They had the option on their phone, so there's hope, after a fashion.

  • jimlloyd40jimlloyd40 Phoenix, AZ Posts: 15,863 ✭✭✭✭✭✭✭✭

    @chefjansheik said:
    @jimlloyd40: Unfortunately the only option behind mobile data is a "Standard data" toggle option.

    @drakenfx: Also, unfortunately there is no sim settings page. Instead of posting my entire settings page, I just searched for "Sim Settings" and have posted the results for that search.

    I spoke with ZTE Customer service, who seems to think that this is an issue related to the latest Android version (perhaps). They had the option on their phone, so there's hope, after a fashion.

    I can promise you that it isn't because of the latest version of Android. It could be the way that ZTE implemented the latest version of Android but it's definitely not Android itself.

Sign In or Register to comment.