Alarm no longer working on Axon 7?

Hey folks, have a weird issue with my Axon really causing problems now. Started after the latest system update (along with the battery drain issues everybody else seems to have), where the alarm would randomly just not go off when it was supposed to wake me up. Been late for work because of it. Now I'm finding the alarm will not function, period. I've deleted all the alarms, reset power saving functions, and set the alarm every night. The alarm icon will go on, showing the alarm is set according to the system, but it never goes off in the morning like it should. When I look at the phone at that point, the alarm icon is gone until I actually open the alarm/clock app and suddenly the icon appears again up in the notification area. It's like the app is being closed out, but since there's not even a power saving entry to select to manage the deep sleep/close on lock/etc like with other apps, I'm not sure how I would even begin to try to fix it.

Any advice? The battery issues and lag after the latest system update were bad enough, but this is an absolutely essential feature that I have to get working correctly. If not, I may have to just go find a different phone that I can rely on to wake me up in the morning so I don't miss work.

«13

Comments

  • razor512razor512 United States Posts: 2,631 ✭✭✭✭✭✭✭✭

    That is strange, which alarm app are you using as the default?

    If you press and hold the home buton to open google assistant, and tell it "Show me my alarms" which window does it pull up?

  • musicdjmmusicdjm United StatesPosts: 3,124 ✭✭✭✭✭✭✭✭
    edited July 20, 2017 2:08PM

    Have you tried clearing your cache after the update?

    Power the phone off > Then press and hold volume up key and the power button
    The phone will boot into recovery mode > Using the volume down, select the clear cache option
    Press power to select this option and then the volume down to confirm by selecting YES > Press power to select yes.

    Another thing to double check is go into the settings menu > go to APPs> then click the clock app >
    select the notification option > and make sure that sound notification in do not disturb mode is on and if you want it to display on lock screen select that as well

    Then select the storage options and just clear the data and cache in the app to be sure as well

    Also while in there just my make sure under advanced is says Modify system settings > YES (just in case)

  • compmanio36compmanio36 Posts: 27 ✭✭✭✭✭

    It's the stock alarm app that comes with the phone. I'm guessing ZTE made it because it's not Google's version.

    And yes, I cleared the cache both on the recovery mode and the app cache as well, no change.

    And while there is a clock app that shows, when you try to into any options, it brings up the "system" process instead, so I guess it's included in that umbrella process (also seems to be the process stealing all my battery life...related?)

  • compmanio36compmanio36 Posts: 27 ✭✭✭✭✭

    But it also does say that "modify system settings" and "draw over other apps" is turned to ON in the first screen, so I think it's already set properly.

  • samsamhasamsamha United States Posts: 2,136 ✭✭✭✭✭✭✭✭
    edited July 20, 2017 4:15PM

    Do you use Do not disturb? If so, Make sure that under Do not disturb mode, you have alarms only enabled. If you have scheduled DND, then make sure you go into the schedule and set the mode to alarms only too.

    In addition, in the alarm, when you tap on the gear icon, make sure the volume is set to high level and you enable the "sill rings in silent mode or vibrate"

  • compmanio36compmanio36 Posts: 27 ✭✭✭✭✭

    Don't use "do not disturb" but I changed that setting from priority only to alarms only just in case. Alarm is turned all the way up and that option for ringing in silent/vibrate is set.

  • N8theM8N8theM8 Posts: 5 ✭✭✭

    Just wanted to jump in and say both my girlfriend and I have both had this exact same problem with our identical gold 64gb models for the last two days now.

    We are very clear on how DND works and we know we've been setting the alarms and volumes correctly for the last two days as we always have.

    We've only been successful in getting the alarm to trigger after multiple phone resets and short alarm durations meant to test this specifically. Even then two mornings in row now, neither of our alarms have gone off. Something is broken in ZTE's default alarm/clock app.

  • thinkbkthinkbk Posts: 3 ✭✭

    another user chiming in with the same issue. my gmail notifications also stopped working.

    checked the power settings, nothing made a difference. exact same symptoms shown by above users.

    stock ROM, non-rooted.

  • guidagguidag Posts: 8 ✭✭

    I'm having the same issue with my alarm not working. Downloaded another app for now. Also having issues on receiving notifications for Signal (messaging) and Friendly (Facebook app).

  • niwmikniwmik Posts: 1 ✭✭

    registering to say i have the same issue

  • Same issue here. Tried third party apps.

  • runderekrunrunderekrun Posts: 20 ✭✭✭✭

    Hour late to work today because my alarm didn't go off. What is the deal?

  • tzktzk Posts: 1 ✭✭
    edited July 21, 2017 11:41AM

    Same issue as well. Stock alarm clock doesn't fire.. AVG Alarm Clock Xtreme doesn't fire. However, setting up a couple of test alarms those didn't fire at their set times, but the alarms went off about 30 minutes later.

    Also receiving delayed notifications. For example, will take a Lyft in the morning and the notifications from the app will be severely delayed and are spread out throughout the entire day.

    **At least on my phone, I have a feeling that a subset of my alarms/notifications are firing off on the 38th minute of every hour. I will need to do more testing to verify if this is the case and will update this post accordingly. **

    It seems to have started sometime this week. I believe my alarm hasn't been working for 3+ days?

    Model: ZTE A2017U
    Build: A2017UV1.1.0B25

    Stock / not rooted

  • samsamhasamsamha United States Posts: 2,136 ✭✭✭✭✭✭✭✭

    Have you guys check the volume setting:
    1-Press the volume down button
    2-On the slider, tap the down arrow,
    3-Make sure the Alarm sound slider is turned up and not in silent mode.

  • runderekrunrunderekrun Posts: 20 ✭✭✭✭

    @samsamha said:
    Have you guys check the volume setting:
    1-Press the volume down button
    2-On the slider, tap the down arrow,
    3-Make sure the Alarm sound slider is turned up and not in silent mode.

    My volume was definitely not muted. I tested right before bed actually since I just switched to my 6th(!) refurbished phone from ZTE.

  • razor512razor512 United States Posts: 2,631 ✭✭✭✭✭✭✭✭

    If you go to Android settings > Advanced settings > Date & time, is the detected time info correct?

    If possible also check if location mode is set to high accuracy. It can be found in Android setting > Advanced settings> Location.

  • dsprockeee1dsprockeee1 United StatesPosts: 76 ✭✭✭✭✭

    Strange to see others are having this same problem. I was an hour and a half late to work yesterday because my alarm did not go off. First time of my ownership this has ever happened on this phone. Later on at work I set alarms to go off in 1 minute intervals, and none of them worked. The icon would be in the status bar, but when I unlocked my phone the icon would be gone after my 1 minute interval alarms.

    I rebooted my phone and they seem to be working, for now. I noticed when I rebooted my phone I got maybe 5-6 text messages all at once which I thought was strange.

    My guess is there might've been a problem with the carrier time sync because if the sync is off, the alarm won't function properly since it won't know what time it is. I am using T-Mobile, so I'm curious what other carriers you guys are using.

    In the meantime, just reboot your phone and set alarms for 1 minute ahead of the current time and turn your screen off and see if it goes off. And to take an extra precaution, go to Advanced Settings -> Date and Time -> Uncheck both Automatic date and time and Automatic time zone. And set both the date and time, and timezone manually.

  • runderekrunrunderekrun Posts: 20 ✭✭✭✭

    Also I was on B19, so it's effecting more than just b25.

  • N8theM8N8theM8 Posts: 5 ✭✭✭

    @samsamha said:
    Have you guys check the volume setting:
    1-Press the volume down button
    2-On the slider, tap the down arrow,
    3-Make sure the Alarm sound slider is turned up and not in silent mode.

    Yeah, this definitely isn't the issue. My girlfriend and I have been correctly setting our alarms for over a year now. Nothing has changed except that the app has stopped working.

  • runderekrunrunderekrun Posts: 20 ✭✭✭✭

    I'm on Cricket (AT&T). I will try with time sync turned off over the weekend. I hope that's the issue. I bet it has something to do with the damn power manager killing stuff in the background again, unfortunately.

  • dosloverdoslover Posts: 8 ✭✭✭✭

    Well, glad it's not just me. I've had issues for a while where games will notify me that a thing has been completed before it's actually done but it's never been a big deal. Now that my phone has decided to not wake me over the last few days, it's a much bigger deal (if even related). Has anyone factory defaulted yet?

  • compmanio36compmanio36 Posts: 27 ✭✭✭✭✭

    Glad it's not just me. Weird how there hasn't been a system update pushed or anything, but out of the blue, everybody's alarm and notifications were all broken. After a reboot yesterday a ton of notifications I missed just showed up as well. Sounds as if we're all having a related issue. Some bad update from a Play Store app?

    I'm also on Cricket.

  • blake_seablake_sea Posts: 3 ✭✭✭
    edited July 21, 2017 12:26PM

    Wound up fixing this issue, plus a few more: alarm not working, gmail notifications not appearing, "OK Google" detection not working, Google search widget not working, google weather widget not working.

    I'm not sure what of the below fixed the issue, but things seem back to normal now:

    • rebooting
    • clearing cache on all affected apps (clock, gmail, google app, google now launcher, google play, google play services etc.)
    • reinstalling google now launcher
  • compmanio36compmanio36 Posts: 27 ✭✭✭✭✭

    If I have to do a FDR, I'm just switching over to Lineage at the same time. It's ridiculous to say that the only option to fix issues on a phone that shouldn't be there in the first place is to reset your device and lose all your customizations in the process.

    If I told one of my users to just reimage their PC every time they had an issue, I wouldn't be working in IT very long.

  • N8theM8N8theM8 Posts: 5 ✭✭✭

    @dsprockeee1 said:
    Strange to see others are having this same problem. I was an hour and a half late to work yesterday because my alarm did not go off. First time of my ownership this has ever happened on this phone. Later on at work I set alarms to go off in 1 minute intervals, and none of them worked. The icon would be in the status bar, but when I unlocked my phone the icon would be gone after my 1 minute interval alarms.

    I rebooted my phone and they seem to be working, for now. I noticed when I rebooted my phone I got maybe 5-6 text messages all at once which I thought was strange.

    My guess is there might've been a problem with the carrier time sync because if the sync is off, the alarm won't function properly since it won't know what time it is. I am using T-Mobile, so I'm curious what other carriers you guys are using.

    In the meantime, just reboot your phone and set alarms for 1 minute ahead of the current time and turn your screen off and see if it goes off. And to take an extra precaution, go to Advanced Settings -> Date and Time -> Uncheck both Automatic date and time and Automatic time zone. And set both the date and time, and timezone manually.

    T-Mobile here.

    @runderekrun said:
    I'm on Cricket (AT&T). I will try with time sync turned off over the weekend. I hope that's the issue. I bet it has something to do with the damn power manager killing stuff in the background again, unfortunately.

    I'm doubtful only because both of us have our phones plugged in all night, so I would think the power manager would be doing much. Could be wrong though.

  • N8theM8N8theM8 Posts: 5 ✭✭✭

    @blake_sea said:
    Wound up fixing this issue, plus a few more: alarm not working, gmail notifications not appearing, "OK Google" detection not working, Google search widget not working, google weather widget not working.

    I'm not sure what of the below fixed the issue, but things seem back to normal now:

    • rebooting
    • clearing cache on all affected apps (clock, gmail, google app, google now launcher, google play, google play services etc.)
    • reinstalling google now launcher

    Just a heads up. Rebooting has temporarily resolved the problem only to revert by the next morning. Be aware your fix may not be permanent.

  • compmanio36compmanio36 Posts: 27 ✭✭✭✭✭

    So I set an alarm for 5 minutes from now, didn't go off, alarm icon disappeared, and now the Google apps aren't working again. Definitely related. Now the alarm says "9:25 AM tomorrow" instead of today, but it's not showing as set in the notifications.

    The alarm not functioning, notifications not coming in, and Google apps not functioning, all releated to each other and started at the exact same time. WTH Google and/or ZTE?

  • N8theM8N8theM8 Posts: 5 ✭✭✭

    @peterium said:
    Same issue here. Tried third party apps.

    Did they work?

  • compmanio36compmanio36 Posts: 27 ✭✭✭✭✭

    Anybody here with Lineage on their Axon having the same issue or is this only a problem with MiFavor?

  • blake_seablake_sea Posts: 3 ✭✭✭

    @N8theM8 said:

    @blake_sea said:
    Wound up fixing this issue, plus a few more: alarm not working, gmail notifications not appearing, "OK Google" detection not working, Google search widget not working, google weather widget not working.

    I'm not sure what of the below fixed the issue, but things seem back to normal now:

    • rebooting
    • clearing cache on all affected apps (clock, gmail, google app, google now launcher, google play, google play services etc.)
    • reinstalling google now launcher

    Just a heads up. Rebooting has temporarily resolved the problem only to revert by the next morning. Be aware your fix may not be permanent.

    Thanks for the tip. Rebooting was step 1, which didn't seem to do the trick. I'll post back if this doesn't stick, though.

Sign In or Register to comment.