Blocked/Private Numbers Go Directly To Voicemail

mhyltonmhylton CaliforniaPosts: 4

I've already tried to resolve this through my carrier and they couldn't help me. Why do Private/Blocked numbers go directly to voicemail? I can't seem to change this (unblocked numbers continue to ring and let me answer it).

Also, I'm using Nova Launcher and can't find the stock phone app in my list of apps. Any idea why I can't see it?

Michael

Comments

  • @mhylton Good afternoon. What app are you using to block calls, Hiya? I don't use the Nova launcher, but I do use another one and still show the default calling app. Let's see if perhaps one of our CPAs can assist you further. @musicdjm @coldheat06

  • razor512razor512 New York Posts: 1,999 ✭✭✭✭✭✭✭✭

    If using Hiya, open your app drawer and look for Hiya. Once loaded, click on the 3 horizontal lines in the upper-left hand corner of the screen, and then click on "Call settings".

    In that menu you will have options to select how it handles calls.

  • jasonscarterjasonscarter Tallahassee FLPosts: 757 ✭✭✭✭✭✭✭✭

    @razor512 is on the right page. This sounds like the Hiya app all the way.

  • DoppelgangerDDoppelgangerD USA Posts: 1,098 ✭✭✭✭✭✭✭✭

    @razor512 said:
    If using Hiya, open your app drawer and look for Hiya. Once loaded, click on the 3 horizontal lines in the upper-left hand corner of the screen, and then click on "Call settings".

    In that menu you will have options to select how it handles calls.

    It's a shame there is no option for spam/scam calls to be blocked and NOT sent to voicemail.
    It seems counterproductive to keep the phone from ringing, just to have to go back later and listen to the scammers message and have to delete it from your voicemail.
    This has been an issue with HiYa since the first day that ZTE added it to the Axon 7 software.
    While HiYa has improved since that time, it baffles me why they still haven't fixed this specific issue.

  • jimlloyd40jimlloyd40 Phoenix, AZ Posts: 14,099 ✭✭✭✭✭✭✭✭

    @DoppelgangerD said:

    @razor512 said:
    If using Hiya, open your app drawer and look for Hiya. Once loaded, click on the 3 horizontal lines in the upper-left hand corner of the screen, and then click on "Call settings".

    In that menu you will have options to select how it handles calls.

    It's a shame there is no option for spam/scam calls to be blocked and NOT sent to voicemail.
    It seems counterproductive to keep the phone from ringing, just to have to go back later and listen to the scammers message and have to delete it from your voicemail.
    This has been an issue with HiYa since the first day that ZTE added it to the Axon 7 software.
    While HiYa has improved since that time, it baffles me why they still haven't fixed this specific issue.

    Great point @DoppelgangerD and it's why I don't use the Hiya phone app.

Sign In or Register to comment.