WiFi calling - can't connect (REG99 error code)

kmb877kmb877 Posts: 164 ✭✭✭✭✭

Hello Axon 7 enthusiasts!

Tried to do WiFi calling in Cancun back in October, got " REG99 - Unable to Connect". Now, I'm getting this message home too. I'm not using on the regular basis the WiFi calling, but It is useful overseas.
Please note, I'm using UltraMobile service with SIM 1 and ProjectFi data only with SIM 2.
Anyone dealt with this REG99 issue?
Thank you.

Best Answer

  • louisdlouisd Arguer in Chief United StatesPosts: 1,133 ✭✭✭✭✭✭✭✭
    Accepted Answer

    One additional point, as I've travelled, I've found that more and more hotels/public places are blocking the ports needed for wifi calling. They're lumping it in with other streaming protocols and blocking it to preserve network bandwidth. It sucks, but I've found this to be more and more common.

    That being said, I'm curious, are you using Ultra Mobile at home and are able to make wifi calls with their service and your A7?

Answers

  • kmb877kmb877 Posts: 164 ✭✭✭✭✭

    NOTE: My Axon was few minutes next to me (I wrote the article), now shows "Ready for Calls", the WiFi calling works again. Anyone elese expected the REG99 code?

  • samsamhasamsamha United States Posts: 2,093 ✭✭✭✭✭✭✭✭

    hi, @kmb877 , I don't often use wifi calling since my coverage is quite good but I did test it awhile back.

    The code you saw often means the phone is not able to establish the wifi calling. I saw it sometimes when I move in and out of the wifi coverage area and it failed to establish the wifi calling (I think sometimes due to weak wifi signal or somehow it just failed to register with the network). Sometimes if I toggle the wifi off and on then off will work. On some rare instances, I had to shut the phone down. and then and reboot and then it will work. (I think once I turn the wifi off, shut down, turn it on and turn wifi on and then it will work). Once I can establish the connection, then it will work without any issue.

    One thing do be aware though, the wifi calling on the phone technically only support t-mobile's network so there is a chance that your issue can also be related to the UltraMobile nvmo .

  • kmb877kmb877 Posts: 164 ✭✭✭✭✭

    Hi @ louisd, I'm using UltraMobile as SIM1. Yes, except the REG99 I saw recently (Cancun middle October), I can use WiFi calling. Tested Wifi Calling from several US locations and from Germany. Roaming works fine (and cheap). Because UltraMobile does not provide data during international roaming, I'm using the SIM2 with ProjectFi.

  • theshriketheshrike CaliforniaPosts: 37 ✭✭✭✭✭

    I had lots of problems with the reg99 error code when I was at home when I first started using WiFi calling. It drove me crazy. I am on mint sim which uses the T-Mobile network. I reset my home router and after that it started to work great. It's been working fine for a few months now and connects with no error about 99% of the time.

  • kevinmcmurtriekevinmcmurtrie Silicon Valley areaPosts: 317 ✭✭✭✭✭✭

    Problem #1:
    A large number of consumer and small-business grade routers handle UDP packets incorrectly. For example, all Comcast Business routers malfunction when the firewall is enabled. Even with that off, they eventually pick up some configuration-of-death that causes UDP to permanently stop working and it needs to be replaced.

    When UDP transport is malfunctioning, web pages work fine (TCP packets) but VPN, video conferencing, and telephone protocols will not.

    Problem #2:
    WiFi Calling needs to establish some secure digital signatures before it can start. This may be blocked or fail validation if the connection passes through oppressive countries that prohibit secure communications. China is a problem. Russia has claimed that they're going to start blocking secure comms too. US and UK governments have not yet been successful in prohibiting it.

  • maverickmaverick NJPosts: 423 ✭✭✭✭✭

    Yeah I keep getting error or the wifi-calling icon in the top left goes on and off nonstop. Cant seem to fix it even after factory reset. Oh and Tmobile.

  • kmb877kmb877 Posts: 164 ✭✭✭✭✭

    After over 3 months, I figured myself:
    1. Wifi on, Axon connected to a network;
    2. Wifi calling on, doesn't connect, error code REG99;
    3. On the top horizontal bar, short click for data connection from SIM-1 to SIM-2 and back to SIM-1,
    4. Wifi calling will connect just fine, etc.

    All, thank you for your suggestions.

  • hollaphollap United States Posts: 8,370 ✭✭✭✭✭✭✭✭

    Thanks for the info @kmb877 !

  • kmb877kmb877 Posts: 164 ✭✭✭✭✭

    Finally 3 weeks ago I solved the problem: I brought back the phone to factory settings, no more headaches with wifi calling!

Sign In or Register to comment.