USB Tethering not working

Hello guys,

I have a ZTE AXON 7 A2017G and want to use it as personal hotspot on my PC via USB. The interface MUI of this phone is not so good not intuitive and when I switch the USB Tethering supposed to do just that it's bringing a screen of how I want to connect by USB and not working to share the 4G connection to my PC. I tried all options from ‘only charge’ to ‘MTP’ etc. I use Windows 10 64bits, already installed the driver from the phone and I tried many solutions like changing the network adapter driver from device manager on Windows 10 to RDNIS 6 or ZTE RDNIS remote share network ect. But it still doesn't work actually it does stuck the UI screens related to network when I connect the phone.

Anyone has a solution to make this work without rooting the phone?

Thanks !

Answers

  • smh032395smh032395 Posts: 268 ✭✭✭✭✭✭

    I've never been able to connect any device via USB to a laptop to use my data without using a third-party app. I'll advise checking out some apps on the Play Store that can help you do this!

Sign In or Register to comment.