Why don't I see the wi-fi calling options on my Axon 7

mchassymchassy Posts: 8 ✭✭✭✭

I have an unlocked Axon 7
ZTE A2017U
Android Version 7.1.1
I am on T-Mobile, and I would like to set up wi-fi calling.

According to the documentation, this is in
Setting ==> ... More ==> wi-fi calling
But I don't have the setting there.
I am attaching a screenshot of "about phone" and the "... More" settings


Can someone tell me where to find this setting?

Answers

  • kmb877kmb877 Posts: 164 ✭✭✭✭✭

    Normally it is between NFC and Android Beam.
    I believe you should manually install the update B19 (from March 16), and B25 (from May 06). Finally you can reinstall B35 (the latest one from January 27).

  • hollaphollap United States Posts: 8,369 ✭✭✭✭✭✭✭✭

    I'm not sure exactly which build they added Wifi Calling, but I have T-Mobile on B35 and I see it just fine. It's just below the NFC option. @mchassy, which build are you running? As @kmb877 stated, it looks like you are out of date.

  • kmb877kmb877 Posts: 164 ✭✭✭✭✭
    edited February 23, 2018 9:47AM

    Build B19 added wifi calling and B25 provided fixes.
    A friend of mine got early January a brand new Axon 7 made recently. The only way to fix multiple wifi calling problems, was to install manually the build B19.
    How to instal it? https://www.zteusa.com/axon-7#support

  • hollaphollap United States Posts: 8,369 ✭✭✭✭✭✭✭✭

    @kmb877 said:
    Build B19 added wifi calling and B25 provided fixes.
    A friend of mine got early January a brand new Axon 7 made recently. The only way to fix multiple wifi calling problems, was to install manually the build B19.
    How to instal it? https://www.zteusa.com/axon-7#support

    Thanks for the info @kmb877!

  • duirduir United StatesPosts: 10 ✭✭✭✭

    I notice you're using both SIM slots, any chance only one of them is T-Mobile and it's not in the 1st slot?

    If so, Wi-Fi Calling only works with SIM1

  • mchassymchassy Posts: 8 ✭✭✭✭

    Hey ... sorry, notifications on my own question are not set automatically, so I thought that nobody had answered. Thanks for all of the help.
    So, I will take a look at manually installing B19 and B25, but I have to admit that as an IT profession, this seems pretty sloppy. Shouldn't the latest update include anything from previous releases?
    As to the last question by @duir, it's true that my T-mobile is set in position 2. So I will see that part later.

  • mchassymchassy Posts: 8 ✭✭✭✭

    @kmb877 I checked and found B19, but not B25. There is B19 and B32. If both are necessary, where can I find B25? And once I have found B25, should I then reinstall B35 on top?

  • hollaphollap United States Posts: 8,369 ✭✭✭✭✭✭✭✭

    Have you tried dropping to 1 sim first? Try TMobile only in slot 1 and see if it shows.

  • mchassymchassy Posts: 8 ✭✭✭✭

    @hollap that is a step in the right direction. I switched the SIM cards so that the T-Mobile SIM was in position 1. Now I get the option for Wifi calling, but when I activate it, I get the error ER05 Invalid SIM card.

  • hollaphollap United States Posts: 8,369 ✭✭✭✭✭✭✭✭

    Can you try rebooting with only that card in slot 1 if you haven't already? If you have, try wiping the cache partition from recovery and try again.

  • mchassymchassy Posts: 8 ✭✭✭✭
    edited February 27, 2018 9:41AM

    Correction @hollap ... I've got it working now. The T-mobile SIM must be in position 1 AND must be active for data. Thanks to everyone for the help.
    So to resume:

    • You don't need to install the previous updates manually. Simply updating to the latest build worked fine.
    • You do need to put the T-Mobile SIM in the first SIM slot otherwise the option does not appear.
    • You must have the T-Mobile SIM active for data
  • hollaphollap United States Posts: 8,369 ✭✭✭✭✭✭✭✭

    Thanks for the update @mchassy and glad you figured it out without too much tinkering!

Sign In or Register to comment.