Axon 7 right capacitive navigation key not working.

Hi all,

I have an Axon 7 here that is having total non-response of the right navigation key. I have the haptic feedback enabled so I can be sure when button presses are made and the right key is completely dead. I have cleared cache in both recovery and in settings, restarted many times, and even did a full reset... None of these are fixing the issue. To me, it seems to be a hardware issue. Switching around the function of the nav keys in settings does not matter, the home and left button work fine regardless of their functionality while the right key is completely lifeless. I have searched the forum here and tried to find solutions, but anything suggested that I found I had already tried. I'm at a loss with this thing at this point... Any other suggestions? Is it possible to send in to ZTE for repair? I want to get that key working because I want to give the phone to my friend who is in dire need of a phone. The phone is in great shape and works great otherwise, but that damn key stopped working (and having back / recent apps keys working is pretty necessary for android).

Thanks for the help.


  • td76td76 Posts: 7 ✭✭✭


    Thanks, that's what I was thinking. I'm unsure if the phone is still under warranty or if its eligible, this was a backup phone I purchased in case my primary A7 bellied up somehow. Funny that the backup that doesn't get used bellied up and my primary phone is doing great. I guess I'll have to try to contact them and see if something can be done.

  • samsamhasamsamha United StatesPosts: 2,362 ✭✭✭✭✭✭✭✭

    hi, @td76,

    sorry about the issue. If it is hardware issue, you can certainly check to see if it is under warranty. If it is not, you do have an option as the Axon 7 has a feature called "mi pop" where you can enable to have a floating navigation button. This will still let you use the phone without the physical button.

Sign In or Register to comment.