Axon 7 and Android Wear watch - frequent pairing / disconnect

smatofusmatofu Posts: 10 ✭✭✭✭

Hi Guys,

I have Axon 7 and LG Urbane 2 LTE watch. After the phone and watch get out of Bluetooth range, they switch to WiFi, as expected. But then when BT is in range again, frequently re-pairing is needed. BT re-pairing is not needed every time, it could be a few times per day, depending how often I leave the phone in another room.

Phone and watch are on latest firmwares. The issue has been happening for months. I tried multiple factory resets. Very small number of apps installed, mostly bank apps to access my credit card accounts. Power saving is off for Android Wear/Google OS app.

Please help me! Thank you in advance!
Sam

Comments

  • jasonejasone TennesseePosts: 1,877 ✭✭✭✭✭✭✭✭

    Try going to the power manager in the settings menu and look for ZTE's battery saving settings. I forget what they call it and disable everything for the Wear OS app. I believe this is what helped me when I had issues.

    Android already asks you to ignore optimizations for doze on their end but ZTE has its own battery management system which also needs to be told to ignore messing with the Wear OS app.

  • smatofusmatofu Posts: 10 ✭✭✭✭
    edited April 17, 2018 10:22AM

    Jasone, thank you!

    [and disable everything for the Wear OS app.] Yes, I already did it.

    Currently, I am testing BT device name changes: I removed spaces from watch and phone names, and made them uppercase. Knock on wood. So far, 2 days and no re-pairing.

    (Spaces, upper/lowercase in names... those are frequent coding/programming errors...)

    Thank you again,
    S.

Sign In or Register to comment.