Broken Dolby Atmos App

pasonal11pasonal11 United StatesPosts: 8 ✭✭
Any thoughts on how to fix the broken new version of Dolby Atmos app that came with the Oreo update?. The app worked fine for short time after applying the update, but then the app stopped working. The toggles, the presets, or simply changing equilizer settings does nothing, the audio remains the same. I performed a factory reset and the same thing happened again, it worked for short time and then went broken again. I am afraid that this is also causing audio distortion from the frontt facing speakers. What could be causing this? ... a new Dolby Atmos version with bugs maybe? Solutions are welcomed.

Comments

  • hollaphollap United StatesPosts: 8,311 ✭✭✭✭✭✭✭✭
    You could try going to settings->Dolby Atmos->storage->clear data and clear cache.  I actually had similar issues with Dolby in B35 Nougat and my issues went away with Oreo update. 
  • pasonal11pasonal11 United StatesPosts: 8 ✭✭
    Thank you for the advise but unfortunately after clearing the app's data and cache, the problem remains, Dolby Atmos still doesn't work, 
  • hollaphollap United StatesPosts: 8,311 ✭✭✭✭✭✭✭✭
    edited November 8, 2018 8:55AM
    The only other thing I can even think of is to try force stopping the app in settings->apps and notifications->app info->Dolby Atmos->Force Stop. Otherwise I'm not sure what else to try at this point. Are you using Bluetooth devices, or wired ones, or both?
  • 125125 EcuadorPosts: 2 ✭✭
    edited November 15, 2018 6:44AM
    I have a similar problem. With update to 8.1 the new Dolby Atmos in my Axon 7 only works by 3.5 aux Jack and phone speakers: with Bluetooth doesn't works. Somebody has a solution for this issue? Thanks
    WiIliam


    PD: I tried disabling applications, I went back to update the firmware again and the audio by bluetooth, auxiliary 3.5 or speakers of the phone has lost the brightness and sharpness that I had with nougat. I realized that sometimes the sound is fixed when I turn off the phone for a few seconds but it only lasts a few minutes and again the sound quality is lost, that is, Dolby Atmos works for brief moments and then impoverishes the level and audio quality and finally it sounds horrible.
    I regret having made the update to oreo 8.0. Can someone help me return to Nougat 7.0 please?

    REGARDS
    WILLIAM
  • pasonal11pasonal11 United StatesPosts: 8 ✭✭
    I force stopped the app, cleared data and cache with no success. The Dolby Atmos app doesn't work for me when using headphones or 3.5mm aux cable (to car) or even with the phone speakers. I haven't used Bluetooth yet so I don't know if it works or not but based on the comment above it's very likely that it won't.
  • NevesNoxaNevesNoxa United StatesPosts: 4 ✭✭✭
    It is definitely broken with this oreo update. The only way I got it to start working again was to turn it on and restart the phone, even then there's this hissing static noise coming from the speakers. 
  • pasonal11pasonal11 United StatesPosts: 8 ✭✭
    NevesNoxa said:
    It is definitely broken with this oreo update. The only way I got it to start working again was to turn it on and restart the phone, even then there's this hissing static noise coming from the speakers. 
    Thank you for your input, that really worked!!! Dolby Atmos is back working again... now let's see for how long or if it's fixed permanently. I did the same as you, restarted the phone with Dolby Atmos on and now I can hear sound changing with the different equilizer settings, presets and toggles.
  • NevesNoxaNevesNoxa United StatesPosts: 4 ✭✭✭
    pasonal11 said:
    NevesNoxa said:
    It is definitely broken with this oreo update. The only way I got it to start working again was to turn it on and restart the phone, even then there's this hissing static noise coming from the speakers. 
    Thank you for your input, that really worked!!! Dolby Atmos is back working again... now let's see for how long or if it's fixed permanently. I did the same as you, restarted the phone with Dolby Atmos on and now I can hear sound changing with the different equilizer settings, presets and toggles.
    Glad to know it worked for you too...I'm still hearing that hiss/crackling noise in audio that has 'soft' volume areas. It disappeared at some point in the past but now it's back  :/ This is the first time I'm having audio problems with the phone since I bought it 2 years and 2 months ago....
  • abozhinabozhin Moscow, RussiaPosts: 51 ✭✭✭✭
    I suppose that there are conflicts with another system-wide equalizer — Snapdragon Audio+. It has similar to Atmos features and maybe it is the source of problems. As far as I understood, it can be disabled via freezing MusicFX system app, and after reboot Atmos should work.
  • pasonal11pasonal11 United StatesPosts: 8 ✭✭
    edited November 14, 2018 11:24AM
    Excuse my ignorance, what is MusicFX and what does it do, or what is its purpose? If I disable it, would it affect audio quality, cause audio issues or will affect the DAC performance?
  • abozhinabozhin Moscow, RussiaPosts: 51 ✭✭✭✭
    pasonal11 said:
    Excuse my ignorance, what is MusicFX and what does it do, or what is its purpose?
    That's an equalizer like Atmos. Asahi Kasei DAC is completely independent.
  • 125125 EcuadorPosts: 2 ✭✭
    I tried disabling applications, I went back to update the firmware again and the audio by bluetooth, auxiliary 3.5 or speakers of the phone has lost the brightness and sharpness that I had with nougat. I realized that sometimes the sound is fixed when I turn off the phone for a few seconds but it only lasts a few minutes and again the sound quality is lost, that is, Dolby Atmos works for brief moments and then impoverishes the level and audio quality and finally it sounds horrible.
    I regret having made the update to oreo 8.0. Can someone help me return to Nougat 7.0 please?
    Regards!

    William
  • 125125 EcuadorPosts: 2 ✭✭
    Update my precious Axon 7 A2017U to Oreo 8.0 and now the "magic sound" of the Axon 7 is gone. To try to solve this problem I have deactivated applications, I returned to update the firmware again but the audio through bluetooth, auxiliary 3.5 or speakers of the phone has lost the brightness and sharpness that I had with Nougat. I realized that sometimes the sound is fixed when I turn off the phone for a few seconds but it only lasts a few minutes and again the sound quality is lost. With or without Dolby Atmos (which works sometimes) the volume level and sound quality are very poor. Finally the good audio qualities that the Axon 7 had have been lost.
    Does anyone have any lasting solution to this problem? Thank you!
    William
Sign In or Register to comment.