Axon 7 signal drop (Straighttalk)

shimicatshimicat United StatesPosts: 4 ✭✭✭✭
I'm having issues with calling on my axon 7 I am using straighttalk and bought this phone unlocked. I switched my sim over and at first I wasn't able to make calls but it's been a week and when I get calls it won't go through or when I pick it up I'll lose signal. Is there a way to fix the signal issue??

Comments

  • ram1220ram1220 Allen TexasPosts: 449 ✭✭✭✭✭✭✭
     I was having the same issue with my A7. I am on Mint which is an MVNO of T-Mobile. In my area T-Mobile towers are overloaded at times. What I did was go into Settings in my A7. Then Dual Sim Settings. Select Network Mode and then select Straight Talk (mine was Mint). Select WCDMA/GSM and wait for the phone to automatically switch networks. Then exit out of the menus. Since the Mint/T-Mobile LTE network was overloaded selecting the WCDMA/GSM has solved all of my signal issues. I no longer miss calls and texts. And running speed tests, my speeds are actually higher than they were on the congested LTE network. Hopefully this solves your issue too until the congestion improves in your area.
  • shimicatshimicat United StatesPosts: 4 ✭✭✭✭
    I think mine is a bit different, I can't fin the network settings and I'm
     on Oreo the new update.
Sign In or Register to comment.