Axon M Notifications not showing.

PesoenPesoen DenmarkPosts: 10 ✭✭✭
i got a ZTE Axon M just a few days ago, all my important stuff has been transferred over from my old phone, and i am ready to make the switch, i only miss one thing. i have no notifications on the Axon M at all, unless i force an app to make a notification. i tried disabling all power saving stuff(did not make my battery last longer anyway for some reason) but it still fails to show any notification. restarting and factory resetting the phone also does nothing.

The specs on the phone are the following.
System Version: Axon M CN 2.8
Model: Z999
Android Version: 8.1.0
Build Number: Axon M CN 2.8
Hardware Version: ufnA

Any help would be greatly appreciated, as a lot of my phone ussage happens due to notifications from various apps. so i am currently walking around with two phones, the Axon M because my sim card is in the phone, and my old phone, a Oneplus One with LineageOS.

Comments

  • sshasansshasan Staff Member United States Posts: 3,690 admin
    edited January 23, 2019 2:15PM
    @Pesoen In the past others have ran into this issue when transferring data over from a different device. 

    If you transfered over all of your information from your previous device you may want to go back and set up the Axon M as a brand new device.
  • PesoenPesoen DenmarkPosts: 10 ✭✭✭
    sshasan said:
    @Pesoen In the past others have ran into this issue when transferring data over from a different device. 

    If you transfered over all of your information from your previous device you may want to go back and set up the Axon M as a brand new device.
    the problem with that is i did set it up as a brand new device, i just transferred over some of the files fro my old phone(images, music, everything the camera shot/recorded) as well as installed various apps from the play store(installed from the zte market app) i only get one notification, and that is my Gear S3 watch Disconnect/connect message(which it spams, due to poor bluetooth performance when in closed mode)

    i am currently asking people on a discord server to spam me with messages, on my old phone, they show up just fine as well as on my computer, but the axon m still does not show any notifications.

    even locking the apps and leaving the screen on does not help at all.


    an app i used heavily on my old phone due to the battery life not being what i expected, was Carat, an app that runs in the background and collects data about apps running on the phone, and helps you figure out which apps are bad for your battery life, but it only gets about 1-5 samples pr day, where on my old phone i would get 200+ pr day. i think its because as soon as you leave the app, it puts it to sleep somehow(even if that is disabled in settings) but i cannot be sure of that.. so far a pretty bad experience with a new phone, that i was sure i was going to love instantly.


    i am considering using my old phone as my daily driver, and using this one for reading, and other tasks, that do not require me to get notifications, but that would be such a waste though.
  • PesoenPesoen DenmarkPosts: 10 ✭✭✭
    First notification i have ever received on the device just came in, messenger apparently can do notifications, have yet to receive any other notifications so far, but at least that is something...
  • samsamhasamsamha United States Posts: 1,860 ✭✭✭✭✭✭✭✭
    With Android Oreo, you can customize the notification per app basis. Have you looked under the app info in the setting-->apps (I don't have the Chinese version of Axon M, so the wording and option can change or moved). Just look at each app and see if you happen to have the notification disabled (or reset them back to default setting to see if that fixed the issue). 
  • PesoenPesoen DenmarkPosts: 10 ✭✭✭
    samsamha said:
    With Android Oreo, you can customize the notification per app basis. Have you looked under the app info in the setting-->apps (I don't have the Chinese version of Axon M, so the wording and option can change or moved). Just look at each app and see if you happen to have the notification disabled (or reset them back to default setting to see if that fixed the issue). 
    that was one of the first things i looked into, only one app is not allowed to give me notifications, but that's a personal prefference due to its notifications annoying me, and i already have the info on my gear s3 watch(samsung health app)

    but thanks for the suggestion.
  • PesoenPesoen DenmarkPosts: 10 ✭✭✭
    also just had a thought, could it be due to multiple devices being active at the same time? i have two devices currently running(my old and new phone) could that do something funky with the notifications only being displayed on one of them?
  • PesoenPesoen DenmarkPosts: 10 ✭✭✭
    Okay quick update, after disabling the wifi on my old phone and rebooting both devices i have begun receiving some notifications.. Not sure how many will work, but i will test that tomorrow. 
  • sshasansshasan Staff Member United States Posts: 3,690 admin
    @Pesoen it's a start
  • PesoenPesoen DenmarkPosts: 10 ✭✭✭
    @sshasan it sure is, better than no notifications at all, still have a slight issue with apps not running in the background properly, but its a start to getting it to be my daily driver.
  • PesoenPesoen DenmarkPosts: 10 ✭✭✭
    okay all notification issues have been resolved. android does not like sending the same notification to multiple devices as far as i know.. so that was my issue, after completely turning off wifi on my old phone, and rebooting both, all notifications showed on my new one(the Axon M) so this issue has now been resolved for me.
Sign In or Register to comment.