Need help about Axon M

enan007enan007 BangladeshPosts: 9 ✭✭✭✭

I bought an Axon M from Amazon. I live in Bangladesh. While setting the device from zero, it gets stuck in the TV mode app setup screen. There should be some apps visible for TV mode at that screen. But it doesn't show in my device. I go to the setting to select manually TV mode app. When I press on the app to set, it crashes. Says stopped working every time. I tried hard resetting several times. But it remains the same. But I have country unlocked. somebody please help me. What should I do now?


  • samsamhasamsamha United StatesPosts: 2,363 ✭✭✭✭✭✭✭✭

    Try to clear the app cache. Go to settings-->Apps-->tap on the 3 dots and tap "show system". Navigate to Setup_TV. Force close it. Then tap on Storage and then clear data and cache.

  • enan007enan007 BangladeshPosts: 9 ✭✭✭✭

    Thank you.I just tried it.but it still remains the same. The first screenshot is the final step of setting up the new TV app shows up there.but I have both Google play movies and TV and YouTube. When I go to the setting manually the 2nd screenshot says setting has stopped.

  • samsamhasamsamha United StatesPosts: 2,363 ✭✭✭✭✭✭✭✭

    Few other things you could try (don't recall 100% what I did in the past:))

    1-clear the cache under recovery.

    2-Toggle TV mode off using the drop down menu. Then, disable long press. Go to "Quick setting"-->long press--> change to some other app so it is not pointing to tv mode. Then go to tv mode setting and change to another apps that is not currently selected. Afterwards, try it again to see if it works for you.

    3-I am not too sure but I think in the past, I bypass setting up tv mode during ATT''s setup when I configure the phone, then enable it after the phone has set up to get it to open other apps.

  • enan007enan007 BangladeshPosts: 9 ✭✭✭✭

    Thank you so much. I'm so much grateful to you. .I'm halfway there. I applied 1 and 2. Now the 2nd screenshot doesn't appear anymore. I can select any app as tv mode app now. Setting doesn't crash anymore.

    But the 1st screenshot is still there as it used to be. Still no TV app shows up there that I need to select,save and go further, even after selecting the app by going to the setting by drop down menu. What can I do about it now?

    One important thing is I'm not from the USA, I live in Bangladesh. We don't have AT&T sim here.

    Thank you.

  • samsamhasamsamha United StatesPosts: 2,363 ✭✭✭✭✭✭✭✭

    If you are able to select any app for the TV mode. then it is working correctly. This particular setting simply let you quick launch an app when you press the button on your phone. Since you are not using ATT network, you will not be able to accesss TV app, so you can just set the button to launch any app you wish to.

  • enan007enan007 BangladeshPosts: 9 ✭✭✭✭

    Thank you,but sir,maybe i couldn't make you understand it. I'm OK without the TV mode. I can now select the app for TV mode,also for long pressing that dedicated button. But when buy a brand new Axon M, or after a Factory Reset,you turn it on,then you go one by one from blue language setting screen to WiFi, ATT etc setup, right? So, at a certain point of setting the device for using, this first screenshot menu comes where you have to select an app icon for TV mode that should appear below the writing "Visit setting anytime to add or select another app". Then you mark the app by tapping on it, and then you tap on the "Save(->)" button, then the device is ready to use. But in my case, no app icon appears for selecting TV mode app here in the first screenshot. And the phone is stuck there. It is not going any further. I can go to setting by drop down menu, I can use an app only if any notification comes of that app,I tap on it to use it. I can't use it as a normal phone. Please sir, provide me a solution if you can.

    Thank you for your response.

  • samsamhasamsamha United StatesPosts: 2,363 ✭✭✭✭✭✭✭✭

    If I understand you correctly, you mean that during setup process, you will not be able to bypass the first screenshot to go to the phone's homescreen. If that is the case, I believe, you could tap back button (or try without any sim card during setup or try to set up the phone without wifi or any network connection) to see if it will let you bypass that screen.

    Unfortunately, that screen is part of ATT's own setup process and it will always shows up during the setup process so you would still see it when you factory reset.

  • enan007enan007 BangladeshPosts: 9 ✭✭✭✭

    Yes, you understood my problem correctly this time. I just tried all of those. But none of them helped. I press the back button it goes back to this attached screenshot, and when I press the "Set up", it takes me to that same 1st screenshot page. I tried without sim, it goes okay, but it requires wifi as compulsory. The wifi connecting page has no skip button. I definitely have to connect wifi to go forward.

    Maybe it won't get fixed anymore :( :(

    I feel so much upset about it. I waited so long to get it in my hand. I wish i could use it as I expected. It's my bad luck :( :(

    Thank you so much for your responses my friend. I really appreciate it.

  • samsamhasamsamha United StatesPosts: 2,363 ✭✭✭✭✭✭✭✭

    I dusted out the Axon M I have here and factory reset the phone. During the setup, I saw the screen you posted, however, I do have "Play Movie & TV" showing up on the list where I can tap on it to save, then the screen goes away. After I rebooted, it pops back up again but after I save it again and reboot. It does not show up anymore.

    Maybe try to factory reset. Then go into recovery, wipe cache and factory reset in the recovery again. Then, see if you possibly see what I saw. if not try, a few more times and hopefully you are able to set Play Movie as default to bypass the screen.

    If that does not work, then I have no idea what else can be done. Really sorry if I could not help you to resolve the problem. Carrier branded phone sometimes have their own software that really requires their own sim card to get it to work and manufacturers do not have much control what what to do.

  • enan007enan007 BangladeshPosts: 9 ✭✭✭✭

    Thank you so much for the effort you gave for my problem. I'm so much grateful to you for that. I saw many setup videos on YouTube. Nobody has the problem that I do with this phone. Maybe it's because of the sim and my region. Although I tried, I'll try again as you said. I'll let you know if that works. Thank you.

  • enan007enan007 BangladeshPosts: 9 ✭✭✭✭

    Thank you so much for the effort you gave for me. You tried a lot for my my problem. I really appreciate those. The solution was simple. I got help from a guy from YouTube moments ago. He said as it is the American version,just to install Netflix then it will be okay. I just did as he said and it worked. I installed Netflix, then it came to that TV mode app selecting screen, I selected it, and its done. :)

  • samsamhasamsamha United StatesPosts: 2,363 ✭✭✭✭✭✭✭✭

    @enan007 , so glad that you are able to find the solution and share that with the community. It would be helpful for others for sure.

    Hope you have happy holidays.

  • apc032092apc032092 United StatesPosts: 1 ✭✭
    edited March 13, 2020 9:12PM

    Hello there, I just got a new zte phone and it is having the same issue you described. Is there a way you can link the video? It would be very helpful for me.


Sign In or Register to comment.