GPS problem after Android 10 upgrade

zzhangpzzhangp Posts: 18 ✭✭✭✭✭

I noticed that GPS will stop working after a few days. The only way to fix it is to reboot the phone. However, it takes long time to get initial GPS fix after the reboot.

Anyone noticed similar issue?



  • samsamhasamsamha United StatesPosts: 2,363 ✭✭✭✭✭✭✭✭

    Have you looked under your location setting to see if you happen to have "google location accuracy" turned off. If so, you could turn it on to improve on the location accuracy and speed at pinpoint your location. (Turning this on would let the phone also use WiFi, cell tower and GPS to help pinpoint the location)

    I did not notice GPS stopped working on my unit. Though, I did noticed that the Axon 10 Pro's GPS is a tad weaker. I have the phone set to use GPS only and the initial pinning may take a little bit longer if I am in area that does not have the best reception (like in underground garage and going out of the building, it would take a bit of time for Google Map to get the current location.)

  • david_l312david_l312 Posts: 24 ✭✭✭✭✭

    I've seen both these problems. The Axon 10 generally has a harder time getting a GPS lock in the car then my prior phone. And since Android 10 sometimes it doesn't lock at all until the phone is rebooted.

    I just checked and my "Location Accuracy" is turned on.

  • markjc2002markjc2002 United StatesPosts: 7 ✭✭✭
    edited March 24, 2020 11:09AM

    I commute over 60 miles a day one way, back and forth to work. Prior to the upgrade to Android 10, GPS worked perfectly fine. I had two map programs and two GPS speedometer programs on my phone, prior to the upgrade from Android 9 to Android 10.

    Sometimes it takes 5 minutes for any one of the apps GPS, to find the satellites, with Android 10, whereas it was instantaneous with Android 9.

    I'm not sure whether it's a problem with base Android 10 or the ZTE version of Android 10.

    I don't know if the flaw is in the conversion of Android 10 into what the ZTE version is, or if it is the original Android 10 to begin with.

    The phone obviously didn't physically change between Android 9 and Android 10.

    I actually installed another map service, however it also doesn't know where I am a lot of the time. it acts as if location services are turned off.

    This GPS problem interferes with my ability to pay for fuel, because the fueling app thinks I'm not near the fueling station.

    This interferes with my ability to commute to work, because there are several different routes I could take, but depending on traffic jams or wrecks or something, I don't know what is the best route to take anymore, because the map program sometimes takes 10 minutes when I'm moving in my car to first figure out that I am moving,then where I actually am located.

    When I originally purchased the phone, Android 9 was the operating system, GPS was never a problem.

    When I changed phones from my axon 7, my current apps were automatically downloaded, all of my programs and they all ran exactly the same as they did on my axon 7 with Oreo.

    After the update I have noticed three things. Many apps periodically tell me I'm not connected to the internet, both with your data or Wi-Fi, GPS doesn't work for a long time and then finally does, and rebooting may or may not fix the problem, sometimes it comes back after a reboot and GPS and location services still don't work.

    I'm not sure if ZTE can fix the problem because if it's in Android 10, then any version they make for their phones won't function correctly by default.


  • jasonscarterjasonscarter United StatesPosts: 1,963 ✭✭✭✭✭✭✭✭

    What are these apps and where are you located?

    I use Google Maps, Strava, and Fitbit for fitness tracking and they connect to the GPS just fine quickly.

    Facebook, Instagram, Twitter also work fine with GPS for check in/location features.

    AccuWeather is my weather app and knows where I am as well.

  • jc1003jc1003 United StatesPosts: 2 ✭✭

    I'm having the same issue with maps using Android 10. Takes 5 to 10 minutes to locate me. Going to start using Waze to see if it helps.

  • dsprockeee1dsprockeee1 United StatesPosts: 78 ✭✭✭✭✭

    Glad I am not the only one affected by this. After owning the A10 for a while, it seems that my GPS is also suffering from this problem. I have contacted Waze to see if it's just a software issue with their app and incompatibility. Google Maps also suffers from the same problem with having a hard time locking onto a GPS signal. It seems the GPS can find my location, but does not follow my location. Using Waze/Google Maps, it'll lock to where I am at my house, but when driving it does not follow me and will jump/skip every minute or so trying to lock onto the signal/location. Kind of a deal breaker and hopefully it's a minor software fix and not my phone.

  • wiseman13wiseman13 United StatesPosts: 726 ✭✭✭✭✭✭✭✭

    My issues with GPS are intermittent. Usually after it connects to a signal I do not have any more issues, but sometimes it takes a while before it will show my proper location or display navigation in Google Maps.

  • jasonscarterjasonscarter United StatesPosts: 1,963 ✭✭✭✭✭✭✭✭

    If it's taking 5-10 mins then it's gotta be a device issue. Try a factory reset and if that doesn't help, RMA with support.

    Mine is instantaneous when opening a app (leave GPS on all the time) like Google maps. No jumping around either.

  • wiseman13wiseman13 United StatesPosts: 726 ✭✭✭✭✭✭✭✭

    I have done a factory reset. Issue did not happen until Android 10 upgrade, so I continue to work with them on it. There are about half a dozen people here and on XDA with the same issue.

  • jasonscarterjasonscarter United StatesPosts: 1,963 ✭✭✭✭✭✭✭✭

    Don't know how it couldnt be more widespread if it was software.

  • jc1003jc1003 United StatesPosts: 2 ✭✭

    ZTE already replaced my phone and I am still having the same issue. Have used both waze and google maps with the same results. Sucks that I wait 4 years for a new phone and my old LG's maps works better than this. I'm very disappointed with the phone.

  • samsamhasamsamha United StatesPosts: 2,363 ✭✭✭✭✭✭✭✭

    Do you have google location acccuracy turned on? If not, turn it on will help with pinpoint the location.

  • wiseman13wiseman13 United StatesPosts: 726 ✭✭✭✭✭✭✭✭

    Yep turned on. We shall see what ZTE does with video and debug logs if anything. It's not 100% of the time, but happens once or twice a week for me. Other times it's johnny on the spot.

  • dsprockeee1dsprockeee1 United StatesPosts: 78 ✭✭✭✭✭

    Well this is very disappointing to say the least. ZTE has yet to answer to my ticket/email after replying back to them twice with the needed info such as my IMEI and serial. I am still having GPS issues even after about 2-3 factory resets. Is anyone else suffering from this problem or is it just my device? Not sure if it's an app compatibility issue, or just an overall Android 10 issue on this device.

  • monkeygodmonkeygod Posts: 64 ✭✭✭✭✭

    I have similar issues with my GPS when using Waze... It can easily take 5 minutes for the GPS to pick up. I don't remember Android 9 having this problem, at least not to this extent.

  • wiseman13wiseman13 United StatesPosts: 726 ✭✭✭✭✭✭✭✭

    Seems like they are no longer actively selling the device as it listed as out of stock on the zte website.

  • jasonscarterjasonscarter United StatesPosts: 1,963 ✭✭✭✭✭✭✭✭

    B and H still has stock.

  • MyBabyCarrotsMyBabyCarrots United StatesPosts: 3 ✭✭✭

    I got this issue. Just bought this phone couple weeks ago. Is there solution?

  • wiseman13wiseman13 United StatesPosts: 726 ✭✭✭✭✭✭✭✭

    The new ota is helping some users. I am still having issues, but have not done a full reset yet.

  • Robert95zRobert95z United StatesPosts: 1 ✭✭

    I am having this problem also. Very annoying.

  • MyBabyCarrotsMyBabyCarrots United StatesPosts: 3 ✭✭✭
    edited August 14, 2020 11:44AM

    After some searching, there is a potential solution mentioned in this thread,for%20at%20least%205%20seconds.

    Try the app GPS Essentials, download in Google Play, install it, open and tap on Compass. Hold the phone and draw the figure 8 in the air for a few times. It might help to calibrate the compass. I just did this, and google map seems better. I will test navigation when driving.

    When I use the app GPS Essentials, I can see multiple satellites were connected instantly, and the compass works flawlessly. So it looks like the hardware has no problem. The problem should be setting/OS/app.

  • MyBabyCarrotsMyBabyCarrots United StatesPosts: 3 ✭✭✭

    I tried google map navigation on driving just now, it works well so far. So this solution may have fixed the GPS issue. You guys can try it and let us know.

  • xyz_llxyz_ll United StatesPosts: 3 ✭✭✭

    try turn off the battery optimizer . works on mine, ,,for now.

  • rkewlanirkewlani United StatesPosts: 14 ✭✭✭✭

    Still having the maps navigation issue even after recalibrating using GPS essentials app. Any suggestions on how to fix this? I would hate to return the phone back.

  • cjcummingscjcummings Posts: 8 ✭✭✭✭✭
    edited November 5, 2020 2:20PM

    I got the phone in Late october, and upgraded it to the latest OTA updates before adding or configuring anything. I then immediately did a factory reset. Waze navigation app and GPS has been working well so far. Google Maps was a bit weird but I was traveling on foot at the time.

  • rkewlanirkewlani United StatesPosts: 14 ✭✭✭✭

    Are seeing any delays in GPS locking your location? It's working for me but takes a few minutes before maps or waze is able to lock my exact location and navigate properly.

  • wiseman13wiseman13 United StatesPosts: 726 ✭✭✭✭✭✭✭✭

    I still have the same delays, but it is not everytime like before the last update.

  • ccraziccrazi United StatesPosts: 14 ✭✭✭✭

    I am seeing similar issues after the upgrade to Android 10. GPS takes long time to fix in Google Maps or any other navigation apps.

    Also, I notice sometime notifications stop showing when phone is connected to Wifi. It works after I disable Wifi and switch to mobile data. I see all old notifications which were not shown earlier. Possibly another issue after upgrade.

    Is there a way to rollback or downgrade to Android 9? I don't see this model Axon 10 Pro on ZTE device list, from where we can download the stock builds. Though I see Axon 9 Pro but not Axon 10 Pro. Looks like ZTE discontinued Axon 10 Pro and not supporting any more.

  • xyz_llxyz_ll United StatesPosts: 3 ✭✭✭

    I sent back to phone to ZTE for repair (somewhere in TX) and the gps issue seems solved, not sure what they did over there

  • ccraziccrazi United StatesPosts: 14 ✭✭✭✭

    @xyz_ll, how many days it took for the phone to be repaired? Does it fix the location immediately when you open the GPS Test app?

Sign In or Register to comment.