GPS problem after Android 10 upgrade

2

Comments

  • rkewlanirkewlani United StatesPosts: 14 ✭✭✭✭

    I called up customer care and they said that they have a new OS version with the GPS fix. You can call them and have them send send you a RMA shipping label. They'll reflash the phone and said the issue should get fixed. If your phone is under warranty, ZTE will cover everything. Quick note: they don't have loaner phones and said it may take a week or two. Just make sure you back up everything and have a temp phone ready meanwhile.

  • ccraziccrazi United StatesPosts: 14 ✭✭✭✭

    Thanks for the information. I created the RMA after a month of buying this phone but did not send as I heard on the public forums that people are still seeing the issue after their phone is repaired by ZTE. Also, they do not guarantee to send back the same phone, they can send refurbish phone in place of your phone and mine was almost brand new phone. Finding a loaner for 2 weeks is also painful. I thought if they can share A9 image, I can flash my phone with A9.

    Did it work for you? Is your phone now fix to a location within seconds if you use GPS test to check or in Google Maps/Waze?

  • rkewlanirkewlani United StatesPosts: 14 ✭✭✭✭

    Just sent mine a couple days back. Yet to get it back. I also saved a copy of my IMEI was told that I'll get the same phone back as this is just a software reflash. Will keep you posted once I get it back. Fingers crossed!

    PS: Customer care rep on phone did confirm that this was a known issue and reflash should fix it. Last time I called, which was late 2020, I was told they were waiting for a fix from Google for this. Hopefully this build version is the one with the fix

  • ccraziccrazi United StatesPosts: 14 ✭✭✭✭

    Thanks for the update. That's good to know.

    They could have just sent OTA for this fix as many of Android 10 users are facing this issue. Or gave us a image, we could flash it using SDcard through their Settings->System_Update

    Did you also face issue with app notifications on Wifi? Sometimes after I turn off Wifi and switch to LTE, immediately I see tons of notifications for Whatsapp and other apps which should have popped up before. After restarting phone it works fine for some times, sometime few days and then it needs a restart. Lot of issues with A10

  • antunantun United StatesPosts: 7 ✭✭✭

    I sent mine back today - it was very smooth process. The support agent was very helpful. I actually asked the agent why they don't do this as an OTA fix, and he said that it's not every phone that suffers from the problem. Perhaps there are some differences in phone batches?

  • ccraziccrazi United StatesPosts: 14 ✭✭✭✭

    @rkewlani please update if your phone is back and working without any GPS issues?

  • rkewlanirkewlani United StatesPosts: 14 ✭✭✭✭
    edited February 11, 2021 5:04PM

    Yes. Got it back last a week ago. Still haven't tested fully but the issue isn't completely gone. Still takes a couple minutes at times for it to lock the gps but it hasn't failed me so far like before. And I did get my original phone back if it helps :)

    Also, I'm getting much faster lock with gmaps compared to waze.

    I'll keep you posted if the gps-will-not-lock-ever issue comes back.

    Build Number says: GEN_NA_A2020U_PROV2.09

  • ccraziccrazi United StatesPosts: 14 ✭✭✭✭

    Thanks for the update. Glad that it worked for you 👍️. After cleaning the dalvik cache on my phone, it is getting lock in max 2 min in gmaps.

    For Axon 10 Pro they provide enhance care warranty but they are refusing to provide loaner phones these days even though they still have that coverage published on their website. I will probably wait for LOS based on A11 for this phone and try.

  • rkewlanirkewlani United StatesPosts: 14 ✭✭✭✭

    @ccrazi I would agree with that. Unless the issue is unbearable and renders your phone useless for gps purposes, I would recommend waiting for A11.

  • xyz_llxyz_ll United StatesPosts: 3 ✭✭✭

    @ccrazi one day repair. please ship to and from. two weeks in total

  • wiseman13wiseman13 United StatesPosts: 726 ✭✭✭✭✭✭✭✭

    So that is the same build out via OTA, but I guess a factory reset does not resolve the GPS issue, so that seems to mean they are changing some files with the reflash without changing the build. Any details on what we can do without sending out devices in under RMA?

    GEN_NA_A2020U_PROV2.09

  • rkewlanirkewlani United StatesPosts: 14 ✭✭✭✭

    Yes. It's the same build. The issue still persists after couple weeks of testing. I called customer care and they are suggesting to send the phone in AGAIN for thorough testing. Not sure what they'll do differently this time.

    I would recommend waiting for A11. I don't think ZTE has the fix yet for A10. Also, customer care rep claimed that this issue is not there on every axon 10 pro. Not sure how true is that. Seems it a sizeable population after looking at the comments history on this community channel.

  • ccraziccrazi United StatesPosts: 14 ✭✭✭✭
    edited February 19, 2021 2:01PM

    I read on some other thread that someone is able to fix the issue by rolling back to A9 through their official package, I had email communication with China team and asked for rollback package for A9. They said that this build cannot be rolled back. This package is available for other versions of Axon 10 Pro. Not sure why they don't want to give for US version. Other option is to try LOS16 (which is A9 based) but then it will void warranty.

    Clearing dalvik cache through recovery mode has made it to fix to a location little faster. Slight improvement but not the fix. Worth a try if you use maps/GPS quite often.

  • ccraziccrazi United StatesPosts: 14 ✭✭✭✭

    @rkewlani Finally I am able to get GPS working and no issues with notifications getting stuck on wifi after flashing with the stock A9 using EDL tool. You can find details on this thread. Now GPS locks in 3-5 sec.


  • antunantun United StatesPosts: 7 ✭✭✭

    Hi all, I got my phone back from ZTE last week - they re-flashed it. As far as I can tell, GPS is working perfectly now. It gets a satellite lock within a few seconds. The shipping was heavily delayed because of the winter storm in Texas, where ZTE's repair facility is.

    The whole process was really easy. ZTE's support was excellent: no wait on the phone, the first support person I spoke to was knowledgable and arranged the whole return, and he was familiar with the issue. Didn't make me jump through any hoops at all (e.g. factory reset). Although it would have been a warranty fix, I had also dropped my phone and cracked the screen so I paid for the screen repair part (which was reasonably-priced.)

  • rkewlanirkewlani United StatesPosts: 14 ✭✭✭✭

    Great news @ccrazi I sent my phone back again for repairs & apparently they couldn't fix it so sending me a replacement. Will be receiving it today and shall keep this group posted.


    @ccrazi Happy that you could downgrade to A9. Does that void your phone warranty in any way? I never had this issue with the same device until I upgraded to A10. Hopefully A11 should fix it.


    For all, I agree with @antun on the customer service part. Their customer care folks are super helpful and easy to work with. Especially Benny. He's the floor supervisor and my go to person now. Would recommend all to get transferred over to Benny if you have any issues with the phone. And ZTE easily acknowledged the GPS lock issue without too much convincing or going through the typical call center checklist of reboots/factory resets.

  • ccraziccrazi United StatesPosts: 14 ✭✭✭✭

    @antun Good to know that you phone is working fine after repair. Can you post the build number it shows in phone settings?


    @rkewlani I don't think so it will void warranty as I didn't root or unlocked the bootloader. I can still take the OTA update and bring the phone to same build number it was before. Hopefully the replacement had the issue fixed. Keep us posted whether they sent the same model or 5G as replacement as they have stopped selling/discontinued A10 4G. I hope it works for you after replacement

  • rkewlanirkewlani United StatesPosts: 14 ✭✭✭✭

    @ccrazi Glad to know my friend. Will let you know if it's the newer model. And s would suggest you also opt for a replacement if it works for me.

  • antunantun United StatesPosts: 7 ✭✭✭

    @ccrazi the build number is now GEN_NA_A2020&_PROV2.09

  • ccraziccrazi United StatesPosts: 14 ✭✭✭✭

    @antun seems like same build. Hopefully they patched it internally without changing build number. If it's working fine then it's good.

  • rkewlanirkewlani United StatesPosts: 14 ✭✭✭✭

    Folks, received my phone today & have been literally stress testing the GPS lock feature since then using multiple different apps. So far, the issue is completely gone and lock is almost instantaneous (back to A9 days). Build number is the same. And I ended up getting my original phone back as well, no refurbs thankfully.

    After checking with their customer service team, I learnt they replaced the motherboard on this finally. Earlier they just tried reflashing. Probably others who sent their phones to TX service center also got some sort of hardware fix done. Unfortunately, I didn't keep a track of my original IMEI so not sure what exactly they switched out. I was also told that they replaced it with NEW parts, no swaps from other refurbs/faulty devices.

    @ccrazi I would suggest the same for you. CS did mention that A11 may or may not fix this issue and hardware replacement was the only sure shot way. Staying on A9 is a good workaround but if keeping your phone up-to-date with the latest & greatest is in any way important, let ZTE fix it for you. As I said, ask for Benny the floor supervisor when you call them and he can take care of everything for you.

    Hopefully this is it for me guys ! Will keep you posted if anything changes.

  • kumarkuldeep6kumarkuldeep6 IndiaPosts: 2 ✭✭✭

    I am seeing similar issues after the upgrade to Android 10. GPS takes long time to fix in Google Maps or any other navigation apps.

  • antunantun United StatesPosts: 7 ✭✭✭

    Just an update that it looks like the GPS issue is not fixed after all. It worked fine for the first few days after I received it, but now it's back to not getting a lock. Perhaps the factory reset I did before shipping it to ZTE made it appear to work for a bit.

    I did get a call back from ZTE support to check if everything was OK, and they said that if for some reason the problem comes back I should reach out to them again. I think I'll do that.

  • rkewlanirkewlani United StatesPosts: 14 ✭✭✭✭

    Agree with you @antun I'm also in observation mode and at times the lock still does take slightly longer. Just funny that even after sending my phone to the service center twice, this may still be an issue for me.

    Make sure you figure this out with their customer care before you send your phones for repair AGAIN ...

  • ccraziccrazi United StatesPosts: 14 ✭✭✭✭
    edited March 15, 2021 7:52PM

    @rkewlani I am glad that it worked for you. Finally they had to change the hardware. Surprisingly it works great with A9 for my phone. I don't see any GPS issues after I managed to have A9 on it. Immediately I see mph speed in google maps after leaving home. Otherwise it used to show "--" and took almost 2 to 3 min to fix to location and show speed. There is definitely something wrong with GPS software driver in A10 that they are not able to fix.

  • ccraziccrazi United StatesPosts: 14 ✭✭✭✭
    edited March 15, 2021 7:50PM

    @antun I think you might have to send the phone to ZTE again like what @rkewlani did. Otherwise if you are ok with going on A9 you can look at this thread https://forum.xda-developers.com/t/where-can-i-download-a2020u-stock-android-9-image.4205251/


    @kumarkuldeep6 you can also look at the above thread to fix the GPS issue

  • rkewlanirkewlani United StatesPosts: 14 ✭✭✭✭

    @ccrazi Couldn't agree more. Definitely a drivers issue. I remember even lot of samsung folks had similar issues (numerous forums talk about it), and google had to push out an update for these marque brands to shut them up. ZTE and other small players were left in the lurch as a similar update was supposed to be provided to them as well. Which I guess still hasn't happened to date.


    I'll switch to A9 if this issue still persists. Kudos to you @ccrazi for figuring out at least one definitive solution for all of us. Hopefully A11 puts an end to ask these woes.

  • antunantun United StatesPosts: 7 ✭✭✭

    @rkewlani now that you've had your phone with the replaced motherboard for a few weeks, is it still getting GPS lock reliably? If so, I'll push to have mine replaced too.

    Mine was fine for the first few days after the supposed reflash (not sure if they did or didn't do that), but now it's unreliable.

  • rkewlanirkewlani United StatesPosts: 14 ✭✭✭✭

    @antun not really. To the point where I don't really trust if they did actually do anything. It's back to taking a while to lock in. Not worth the hassle in my opinion.

    I see only two solutions to this problem now. If you can wait long enough for A11, and hopefully it fixes it. Or revert to A9 and follow steps which @ccrazi mentioned in his previous post. That is a sure shot fix and ends this problem for good.

  • antunantun United StatesPosts: 7 ✭✭✭

    I see @rkewlani . Now that I think back to when I received the phone back from ZTE, it did do an auto-update right away. I didn't really have the option to not update. So maybe they did re-flash it to A9, but it auto-updated to A10.

Sign In or Register to comment.