If your ZTE Blade A7 Prime is giving you bluetooth disconnects...

redtailhawkredtailhawk United StatesPosts: 8 ✭✭✭

I just spent many hours troubleshooting. Bluetooth would connect and disconnect as soon as it connected to headset. Over and over and over.

I removed all devices many times - reinstalled headset many times - cleared bluetooth cache many times - cleared all bluetooth memory many times - tried safe mode problem still there - cleared all system settings - and could not solve this problem UNTIL I backed up and did a whole factory reset!

Now works fine - just passing this on - I am very experiences with phones and this is the first time that I had to reset to fix bluetooth... If it starts going wonky again I will update...

Comments

  • redtailhawkredtailhawk United StatesPosts: 8 ✭✭✭

    After testing all day I isolated the problem to Android Wear app for my smartwatch - once installed it got wonky again and needed a factory reset.

  • redtailhawkredtailhawk United StatesPosts: 8 ✭✭✭

    Update 2: I also installed the Huawei Smart Band 4 App - another health tracker - same thing bluetooth went bonkers and had to do a full wipe and restore. It seems this BT implementation needs a bit of work... Keeping it to headset, car and GPS - no problems...

  • JesseKnowsJesseKnows United StatesPosts: 5 ✭✭✭

    This worked for me:

    After I had tried to connect and encountered the repeating disconnect and message about exception, my device (Bose Hearphones) was present in the list of previously connected devices. I clicked on the wheel to go to device details. There I toggled phone calls Off, to the left. Then turned my Hearphones on and they connected to the phone (and if they don't you can click on Connect). After the connection was established I can toggle phone calls back on.

    After this connection succeeded I could disconnect and reconnect with no problems. However, after I rebooted the phone I needed to perform this sequence again to get a good connection.

  • SbogeeSbogee United StatesPosts: 17 ✭✭✭✭✭

    What are your model numbers?

    System------

    About phone------


    Z6201V - Blade A7 Prime?

  • JesseKnowsJesseKnows United StatesPosts: 5 ✭✭✭

    Edit:

    I tried to repeat this - specifically, to enable phone calls after connecting - and I got the disconnect loop again. Not a solution.

    Model number is Z6201V. Running Build number Z6201VV1.0.0B07. I got it with Z6201VV1.0.0B06 and it installed one update. I didn't try bluetooth before the update.

Sign In or Register to comment.