hotspot problem after android 10 update

le011le011 Posts: 11 ✭✭✭✭✭

hi all

i have the U version of the AXON 10 PRO.

after update the phone to the new android 10 system (clean install . wiped everthing)

the hotspot not working -no internet-not in the phone not in the other conected device.

i try the sim in another phone (axon 7)-all good.

any sugestions?



Best Answer

  • le011le011 Posts: 11 ✭✭✭✭✭
    Accepted Answer

    well ,friends i found a solution : in another forum i found this:

    " Go to your "access point names" setting in your sim settings. Then choose the selected APN and add "DUN" to the comma separated list of "APN Type". This solved the issue for me on my OP6"

    so i add the DUN and all great. HOTSPOT WORKING GREAT.....😀

    TY all for the on 10 again...

    best regards



  • samsamhasamsamha United StatesPosts: 2,363 ✭✭✭✭✭✭✭✭

    hi, David

    I have no trouble with hotspot on Axon 10 Pro with T-Mobile network on Android 10. Have you tried "network reset" (Under settings-->System-->Reset options)? Also, have you tried the sim in the other slot?

    Who is your carrier?

  • le011le011 Posts: 11 ✭✭✭✭✭


    i tried the sim in the other slot to.

    did the netwokl reset- no t working.

    i reset the system- factory reset- no use.

    on other phone-the sim works good.

    im from israel. i hade np problem like this in android 9.

    how can i go back to 9?



  • DrakenFXDrakenFX Mobile United StatesPosts: 2,128 ✭✭✭✭✭✭✭✭


    Which is your carrier?

    I have use 2 different Sim-Cards with my A10Pro and haven't had any Hotspot issues...

  • le011le011 Posts: 11 ✭✭✭✭✭


    im from carier is Partner.

    in ANDROID 9 system hotspot worked great.

    after moving to 10 ,problem started:

    when i activate the hotspot,the celular data stops working.not for my phone not for the conected device.

    i try the same sim in my old AXON 7 and all works great.

    try to reinstal the 10 again ,clean insall,wiping everything-same thing/

    i have stock phone-bootloader loked.

    is there a way to go back to android 9?



  • AerospacemanAerospaceman United StatesPosts: 1,517 ✭✭✭✭✭✭✭✭

    Hello @le011 I'm not sure why you are having issues, and yours is the first post about this. There is a SD card downgrade package back to Android 9 Pie available; for some reason it is not on our website anymore that I can find. I should have a link or answer for you tomorrow to download the package. Please remember that this will delete all data on your device by uploading via the SD card method. Please be patient and as soon as I hear back I will update here with the link.

  • le011le011 Posts: 11 ✭✭✭✭✭

    Ty for the answer.

    i will wait. i hope the downgrade will help.

    Ty all


  • wings4anniewings4annie United StatesPosts: 1,471 ✭✭✭✭✭✭✭✭
    edited February 24, 2020 5:38PM

    I run dual SIM, and my hotspot works. My hotspot is on sim 1.

    Hint: if you are trying to hotspot to an older unit, change your mhz in configuration.

    My older laptop doesn't see 5mhz

    So change it to 2.4mhz and works fine.

  • AerospacemanAerospaceman United StatesPosts: 1,517 ✭✭✭✭✭✭✭✭

    @le011 Please check your community DM(Direct Messages). I have just sent you one.

  • le011le011 Posts: 11 ✭✭✭✭✭

    hi all

    as i suspected , after switching back to Android 9 the hot spot works again.

    ty for your support so far. the sd downgrade file was excellent.

    now i will ty to update again to 10 and will see what will happen/

    ty all


  • le011le011 Posts: 11 ✭✭✭✭✭

    Hello again.

    i update, again to android 10 .

    and again-when i activate the hotspot- the cellular data stop working- no internet.

    disable the hotspot -all good.

    what i noticed is that the APN in the 10 system is different from 9. in 9 i have only one APN/

    in 10 i get 3 - picture attached. and when you go in the APN i see something that wasn't in 9

    its called : Bearer. what's


  • AerospacemanAerospaceman United StatesPosts: 1,517 ✭✭✭✭✭✭✭✭

    I was going to mention APN but wanted to see what happened after you went back to 10. From what I have read and heard Android 10 likes to input a bunch of APN's into the device that might not be exactly what matches your carrier. This is not just ZTE. If you want Android 10 I would suggest writing down what your APN settings are in Android 9 and then create a custom APN in Android 10 with the same values. I cannot guarantee if it will work or not as my hotspot works fine. Please let us know if this works for you.

  • le011le011 Posts: 11 ✭✭✭✭✭

    whell ,i add new APN from 9. not working.

    grrr....really bad.😣

  • AerospacemanAerospaceman United StatesPosts: 1,517 ✭✭✭✭✭✭✭✭

    I wish I had an answer for you. Let's see if anyone here in the community has more suggestions. Since this is not a widespread issue with the device it might take an idea from someone.

    @yinli @sshasan

  • AerospacemanAerospaceman United StatesPosts: 1,517 ✭✭✭✭✭✭✭✭

    That's great. I'm going to change this thread to a question and mark your answer as correct for anyone who runs into this in the future. Thank you for posting your resolution. 👍️

  • davettasdavettas CanadaPosts: 6 ✭✭✭

    My service provider is Telus in Toronto, Canada. I have the dual screen Axon M. The mobile hotspot APN settings cannot be edited and the hotspot was disabled after the upgrade. How do I and DUN to the APN settings?

  • ccraziccrazi United StatesPosts: 14 ✭✭✭✭
    edited January 31, 2021 4:59AM

    Hi @Aerospaceman can you please DM the link to stock Android 9 package to me as well. I am facing GPS issues after the upgrade. Not once I could get it to fix to location immediately.

Sign In or Register to comment.