[GUIDE][UNOFFICIAL][SAFE METHOD] Unlock Bootloader - USA Axon 7 ONLY -



  • wescariocawescarioca Posts: 16 ✭✭✭

    Hello drakenfx

    I believe you can help me.

    My axon 7 to 2017u is with boot problems is not starting

    In TWRP it flash the roms but it does not start

    Adob sideload of error

    In EDL mode with miflash and the factory rom it goes into bootloop

    I hope you can help me

    Thank you

  • wescariocawescarioca Posts: 16 ✭✭✭

    I'm from Brazil

    I do not know how to mention it.

  • DrakenFXDrakenFX Mobile United StatesPosts: 2,128 ✭✭✭✭✭✭✭✭


    as far as i can tell, you own the A2017 (Chinese model) , I recommend posting back in XDA.

    P.S. using A2017U (USA) Nougat software with A2017 (Chinese) model is RISKY and i DON'T recommend and YOU ARE lucky you still able to boot to TWRP and not get stuck in DFU mode.

  • kylefromjakylefromja United StatesPosts: 27 ✭✭✭✭

    ​ I'm on B25 too and I need to know if there is anything in the guide that we need to do differently

  • roybmroybm United StatesPosts: 2

    Nevermind I just figured it out.
    Here is what i did in case anyone else runs into this issue:

    after step 3.3, but before step 4, boot the phone normally into the os.

    Activate developer options again, and turn on oem unlocking and usb debugging.

    Then go onto to step 4.

    hmmm I get to step 5 and it says in the command prompt:

    "FAILED (remote: oem unlock is not allowed)


    I DO have the oem unlock checked under developer options also have usb debugging enabled.

    Going to try it all again and see if the same error comes up.

  • DrakenFXDrakenFX Mobile United StatesPosts: 2,128 ✭✭✭✭✭✭✭✭

    You don't have to do anything different, just follow the guide ( downgrade to MM ) and you'll be fine

  • Many thanks to ​ for this write up. I had given up hope on getting TWRP on my Axon 7 but this did the trick.

    Two questions:

    1) Now that I'm on B15, can I upgrade to B19 and then B25? If so, do I need to reinstall any of the above .zip files to keep TWRP?

    2) Do you have an Amazon wishlist? You can DM me the link.

  • Sorry to reply to my own post, but  the Axon seemed bound and determined to upgrade to B19. It downloaded the update and rebooted into TWRP. From that point I just rebooted back into the system, and now, on B15, it says it's up to date.

    Since I'd like to have the security patches in B19 and B25, is there a way to automatically apply the updates, or do I need to find them and install them manually? Finally, I guess I really need to know if TWRP will still work on a later O/S.

  • nsd33nsd33 perthPosts: 1


    I tried those steps but when I am trying to update the zip files from sd card it says invalid siganture.

      Can you help me please!

  • I have decided to sell my Axon 7, how do I go about restoring the boot lock?  I have spent all day trying various posts I have found, but have had zero luck.

    Even tried restoring B07 using the EDL but that failed so I had to go back to B20.I'm hoping someone can help me out!

  • Okay, the answer is "it depends".

    If you have adb and fastboot installed, try

    adb reboot bootloader


    fastboot oem lock

    If it says the command is not found, you can try reloading the


    file back, which should restore the fastboot command.

  • DrakenFXDrakenFX Mobile United StatesPosts: 2,128 ✭✭✭✭✭✭✭✭

    NOOOOOO, Don't do it like, you'll end up in bad shape, and that's how several people been soft-bricking their devices....

    Which Axon 7 model you're using?

  • I have the Axon 7 USA version. 

  • Weird. Why did it work for me do you think? After following your instructions above I got to Nougat B15 then decided I'd rather try LineageOS. Installed that, decided I wasn't keeping the phone, so factory reset it, reloaded MM B20 and then locked it via fastboot.

    I just get lucky?

  • DrakenFXDrakenFX Mobile United StatesPosts: 2,128 ✭✭✭✭✭✭✭✭
     wrote:I have the Axon 7 USA version.

    What's your current Recovery?

    * TWRP or Stock Recovery

     wrote:Weird. Why did it work for me do you think? After following your instructions above I got to Nougat B15 then decided I'd rather try LineageOS. Installed that, decided I wasn't keeping the phone, so factory reset it, reloaded MM B20 and then locked it via fastboot.I just get lucky?

    LoL, Oh i see.

    you were all stock before proceeding with the lock commands, that's the reason why you didn't came across with a softbrick,

  • I am on stock recovery.  The person I sold it to doesn't care that it is unlocked.

    I have it on the latest build of stock software B19.

    Not sure I'm going to worry about it at this point.  Thanks anyway! :-)

  • Yuppers - went back to stock before the lock.

    Heh, it rhymes.

    After I could boot to stock recovery and to the main OS where it prompted me to set up the phone again, so I assume all was well.

  • Thanks for the guide. I was able to root and install custom ROM. Every time i boot, I get this message for 10 seconds  and then device works fine - "Your device software can't be checked for corruption. Pl lock the bootloader. Visit g.co/ABH". How do I get rid of this?

  • Thanks for the info. I rooted my LePro3 last week and  i dont see this msg with LePro3. i was just curious..

  • I rooted my A7 and still see this.. I don't think root plays a role a here..

  • romeoromeo Irvine CAPosts: 59 ✭✭✭✭

    Hello ​​, I'm having a little issue on my phone and I wanted some advice. Whenever I use your files (boot stack and system files) to upgrade to a new update I lose data connection after reboots or shut down, and the only way to get it back is to either do another reboot or toggle the air plain mode. also since the Nougat release the unlocked bootloader warning screen during boot takes longer than 5 second. do you have any idea to resolve this issues?

    Thanks in advance.

  • dontedübdontedüb City of the RosePosts: 1

    Ok, so when downloading A2017U1.0.0B20_MoveToSDCard.zip & A2017UB20Fastboot_ssl_MoveToSDCard I get

    Installing update...

    Warning: No file_contextsThis package is for "ailsa_ii" devices; this is a "".

    E:Error in /sideload/package.zip

    (Status 8)

    Installation aborted.

    Any files specifically for ailsa_ii models?

  • Is this still the most current set of instructions for unlocking A2017U?

    Had my phone for about 6 months, finally had enough of the poor battery life so Im going to try to get myself on lineage. theres so many different threads, across all the different forums. its hard to determine which is the most current and safe method of unlocking/rooting.........

  • Hmm. Guess no point then. I cant get any where near 6 hours SOT. I did a couple times, before any OTAs. Now the very best i can do is about 4.5 hours, and that's if i don't listen to ANY type of audio. if i listen to any audio at work for a few hours, by the end of the day I'm around 10% battery with 2-3 hours SOT. So far that i can see, changing app/power management settings hasn't had any noticeable effect either way. Otherwise the phone works fine though. guess ill just have to ride it out until its time for a different device.

Sign In or Register to comment.