Brand new Axon 7 - screen problem / corruption

Hello,

I just bought a new Axon 7 from Amazon. Unpacked it, charged it up fully, and turned it on. Here's what I see:

20170602_135902_resize.jpg

20170602_135909_resize.jpg

20170602_135921_resize.jpg

20170602_140948_resize.jpg

20170602_140953_resize.jpg

The jumble of craziness jumps around both on its own and especially if I touch the screen. I took off the clear plastic protector in case that was an issue, but it still is the same. Any ideas what's going on and how to fix it?

Out of habit, I booted to recovery and cleared data/formatted the thing and cleared cache, but still the same. The issue does not appear to be visible in the recovery menu, but of course, there is just text and no graphics there.

Answers

  • adrbadrb Toronto, CanadaPosts: 719 ✭✭✭✭✭✭

    I would strongly advise to return it ASAP.

  • hollaphollap United StatesPosts: 8,377 ✭✭✭✭✭✭✭✭

    While the affect is kinda cool looking, I would heed the advice of the others and return it immediately.

  • hollaphollap United StatesPosts: 8,377 ✭✭✭✭✭✭✭✭

    Actually i can't do that, as i have to send mine in for repair.  I have the camera issue where the OIS can't focus and it vibrates making the picture blurry. Someday I'll get it taken care of.  I'm enjoying using the Mini right now anyway.

  • problem is you got the silver or gray version, thats pretty lame

  • sgarrandsgarrand MA, USAPosts: 177 ✭✭✭✭✭

    It's good to know I had the same problem as a forum vet such as yourself. My replacement works great. Took two days to get my advanced replacement.

Sign In or Register to comment.