Home button stopped working!

mg-70mg-70 Mid-AtlanticPosts: 1

To my surprise, the home button stopped working. This shouldn't be happening on a phone that's only three or four months old, and not abused or even over used. What can I do to fix this, other than installing a home button app, which is what various youtubers consider a fix?

Right now, I'm thinking maybe I should've gone with Motorola...

Any help is appreciated

Answers

  • sshasansshasan Staff Member United StatesPosts: 4,077 ✭✭✭✭✭✭✭✭

    A few things you can try if you haven't already:

    -Power Cycle The Device

    -Clear The Storage Cache

    -Factory Reset (Last Resort)

  • klevklev Posts: 122 ✭✭✭✭✭

    It happened with me once and Power cycle corrected it, like sshasan said

  • dnewman007dnewman007 United StatesPosts: 3,663 ✭✭✭✭✭✭✭✭

    If what sshasan says does not work thsn call ZTE customer service for help and possible replacement.

  • twinturboztwinturboz SocalPosts: 219 ✭✭✭✭✭

    @jimlloyd40 said:
    I should have added that I'm sure that Motorola has had the same thing happen.

    I guess it would depend on what model you're referring to, my G5 Plus has been absolutely flawless. Most other Motorola's are on screen buttons so i would think it would never fail.

  • twinturboztwinturboz SocalPosts: 219 ✭✭✭✭✭

    @jimlloyd40 said:

    @twinturboz said:

    @jimlloyd40 said:
    I should have added that I'm sure that Motorola has had the same thing happen.

    I guess it would depend on what model you're referring to, my G5 Plus has been absolutely flawless. Most other Motorola's are on screen buttons so i would think it would never fail.

    I'm referring to any model from any manufacturer.

    Ive had tons of phones, i personally haven't had one fail yet but i know of plenty of iPhone owners who had power buttons and home buttons fail on their iPhones lol, even my old iPhone 4s is still ticking away perfectly.

Sign In or Register to comment.