Blade V8 Pro - with or without AWS (Freedom Mobile - Canada)

jacktheman18jacktheman18 Posts: 44 ✭✭✭✭✭

I recently purchased this device based on the website specifications.

However, this phone (model Z978) will NOT work on the FreedomMobile Network. Band: UMTS 1700/2100/ B4/ AWS.

(It doesn't even pick up the network on a network search)

What is going on?

(P.S. The very same SIM will work on the ZTE AXON 7, so it's not a problem with the SIM card)

Furthermore, the word is now getting out that ZTE misrepresented this phone on its website, as more and more FreedomMobile (formerly WIND) users find out that its not working.

(This is a problem that many users have now reported.)


Best Answer

  • jacktheman18jacktheman18 Posts: 44 ✭✭✭✭✭
    Accepted Answer

    To sshasan. I wasn't referring to LTE service on this phone, I was referring to regular  UMTS 1700 3G AWS service.

    However, as per john111, I was able to see those bands, only after I had done a factory reset along with a "wipe cache".

    In addition, this phone has the option of "network setting reset". However, whenever I tried that, (even after a factory reset), I would get a message that the Settings app was being closed with an error.


  • I own a Blade V8 Pro and I can confirm it's working just fine with Freedom Mobile. What worx is coming out? This is just rumors spreaded by some people.

  • jacktheman18jacktheman18 Posts: 44 ✭✭✭✭✭

    John111: How did you get it to work?

    Which SIM Card slot did you use?

    Which FreedomMobile network are you using?

    Please confirm your general location.

  • Slot #1, I am south of To, using 3G, not lte. Make sure you insert the sim card with the phone turned off. I had issues when I inserted the sim card with the phone on, it recognized only the "AWAY" networks, but after I did it right, it worked perfectly since

  • jacktheman18jacktheman18 Posts: 44 ✭✭✭✭✭

    I am north of TO, using 3G, not LTE. Turned off the unit. Inserted the Sim into Slot 1. It recognizes only the AWAY networks.

    Available Networks -> Search Networks -> only AWAY networks.

    Note: Network mode set to LTE/WCDMA/GSM




    GSM only.

    What else did you do?

  • sshasansshasan Staff Member United StatesPosts: 4,077 ✭✭✭✭✭✭✭✭

    Please update your title of your thread to reflect your region (Canada).

    We'd like to avoid confusion with US Carriers including T-Mobile in which these bands are fully compatible.

    Edit: Title Edited To Reflect OPs Region and Carrier

  • sshasansshasan Staff Member United StatesPosts: 4,077 ✭✭✭✭✭✭✭✭

    Canada's Freedom Mobile operates on AWS - 3 Spectrum which is band 66 and brand new. The only device currently released that runs on band 66 is the LG V20 ( there may be a few more out by now but not many).

    The Blade V8 Pro runs on the older AWS-1 which is band 4.

    You won't be able to get ''LTE'' on your carrier.

    I would not call this misrepresentation on the side of ZTE as the specs do not call for B66 anywhere on any material provided by ZTE. This is the carrier ''Freedom Mobile'' not educating their customers correctly.

  • jimbo23jimbo23 Posts: 1 ✭✭✭

    The Blade V8 Pro has 2 IMEI numbers.  Dial *#06# and try using the second number.

    I know it sounds strange but it worked for me on AT&T in the U.S.

  • I just want to make sure could your blade v8 pro is now able to use 3G network with freedom mobile? As you mentioned about factory reset, do you need to root the device or just use the option in the setting? (Im planning to buy this device + using freedom) Thanks.

  • LolaLola Posts: 2 ✭✭✭✭

    Did you get it to work?

Sign In or Register to comment.