Weather widgit


I'm having issues with the weather widget. My phone and watch is set to high accuracy, but when I access the widget their is a light blue circle that just spins. Kinda like its thinking, or trying to access the information. Ultimately it just defaults back to the watch face and doesn't load. HELP!


  • sshasansshasan Staff Member United StatesPosts: 4,077 ✭✭✭✭✭✭✭✭

    @RIERIE which device are you referring to?

  • jasonejasone United StatesPosts: 2,118 ✭✭✭✭✭✭✭✭

    @RIERIE it appears you're talking about a watch. Are you using the ZTE Quartz or another Android Wear watch? On my ZTE Quartz, it is setup for location from phone & watch and mode is device only. The weather app works fine for me like this.

    Can you use OK Google and ask for the weather? Does it work if you do this? Is your watch setup to use WiFi and cellular connections? I can disable Bluetooth on mine and get it to update the weather just over WiFi or cellular.

    When you first opened the weather app did it ask for permission for your location? If it did not that could be the issue. I tried to find a way to access permissions for the weather app but I couldn't find it where all the other app permissions are. It might be worth trying disconnect & reset from the settings. This will reset the watch back to default and then try not changing the location settings and opening the weather app again.


    I'm refering to the watch. I have done all of the suggested items except to try and ask google and use the cellular network. If you have particular steps to follow please post them and I will try it out!!


    It's the zte quartz watch

  • jasonejasone United StatesPosts: 2,118 ✭✭✭✭✭✭✭✭

    So you have done a disconnect & reset on it and left the device location settings alone the way they are set by default. As mine was set to device only by default and that's what I leave mine on and it has always worked. I've used it with 3 different phones and never had an issue with viewing weather data.

    I generally launch mine by lifting my wrist, saying OK Google, show me the weather. You've also made sure to launch the weather app and allowed location permissions when it launched.


    I haven't changed any of the settings, I will try it from Google. I also have a similar issue with the reminders wiget. I'm supposed to be able to add one by pressing the add reminder, but the 4 dots just rotate. I'm being told you have to add it from your phone but I don't understand why if the watch is supposed to work independently from the phone

  • samsamhasamsamha United StatesPosts: 2,363 ✭✭✭✭✭✭✭✭


    you can add reminder with "Ok google" voice command.

    As for the weather, I think it can be due to the location setting. is your location set to local device only or high accuracy (if it is former, then maybe try to set high accuracy as it will be using, wifi, cellular and gps).

    The easiest way is probably follow what Jason suggested and do a factory reset and pairing. With AW, it is rather easy to do and only takes about 20 min.

  • razor512razor512 United StatesPosts: 2,683 ✭✭✭✭✭✭✭✭

    When you first launch the weather app on the app, did you give it permission to access your location? It sometimes will just not ask for permission again again if denied the first time.


    Yes I gave it full access, ok Google was the only thing that worked. You can't tap and add on the watch itself.


    Thank you for the suggestions, I'm willing to try any other suggestions there may be!

Sign In or Register to comment.