After factory reset, I can no longer use my SD card in my Blade ZMax

I have had this issue with both the ZMax Pro and the Blade ZMax. After receiving an error on my phone and having to reset the phone back to the factory settings I received an error message that the card is unsupported. I backed the card up and tried reformatting and still no luck. I have had to purchase new cards after each reset. I purchased the Blade on it's release date in August. Sunday the phone shut off and when I powered it up, it said the launcher was not working, this is the same issue I had with the Pro. I cleared the data for the launcher and reset the time and I eventually had to reset the phone. Now I have to purchase a new SD card. Is this supposed to happen? Has anyone else had this issue?

Comments

  • razor512razor512 United States Posts: 2,620 ✭✭✭✭✭✭✭✭
    edited November 21, 2017 6:22PM

    If you can, try using the card on a PC, and see if you can reliably format the card and write to it using the PC.

    Also, if a micro SD card fails, pretty much all of the major brands offer a 10+ year warranty on then, thus there is no need to purchase a new one.

    A factory reset shouldn't harm a micro SD card, at least not with any of the brands I tested (Sandisk, kingston, and Samsung).

    If the card truly failed, let us know which model of card it is.

Sign In or Register to comment.