z958 with B24: phone's microphone no longer works! [ZMAX 2]

Anyone got any ideas? It appears that the on-board mic no longer works. The bluetooth option works fine, and I use it when I call, but it's not usable in the long term.

Answers

  • maulgandhimaulgandhi New JerseyPosts: 519 ✭✭✭✭✭

    I want you to try this couple of troubleshoot steps, which might help you fix the problem.

    Sol 1. Settings > Storage > Phone > Cached Data. Click on Cached Data, which will clear all the app cache and see if this fixes your problem. If not,

    Sol 2. Enter your device into recovery mode. Press Power button and click on restart, while your device is restarting, press volume up button, as soon as you see ZTE logo, let go off Volume up button. Your device will not enter recovery mode. Move down to "Wipe Cache Partition" by using volume buttons. Use Power button to select and volume down button to move highlighter to Yes, and select power button to confirm. This will wipe Cache partition. Once Done, select reboot your device. This should fix your problem. if not,

    Sol 3. I am afraid, you might want to factory reset your device. 

  • Thanks for the suggest, Malvin. The data, cache, and factory resets haven't improved the situation. Any other ideas?

  • I had an issue with my microphone not working at all. It was not after the B24 update however. I fixed it, I think the issue was that the phones vibrating motor is near the connector for the microphone causing it to slowly vibrate loose. I disconnected and reconnected the ribbon cable for the microphone module.


    I know many do not want to take apart their device, but thankfully it is easily accessible.


    You'll Need:
    * Precision Phillips head screw driver
    * Thin (non-metal) prying tool.  (A flat head screw driver will work. Plastic is preferred so accidental scratches don't happen. Low risk of that happening, so that's your call)

    First:
    Remove the battery cover and remove the battery. Unscrew the 7 screws along the bottom of the backside of the device (They're small and easy to loose, I was able to unscrew them all without actually removing them so that when I lifted up they all stayed in their holes)Screws.png

    Next:
    Gently pry upward on the silver connector of the ribbon cable. You may even be able to use your fingernail here) open panel.png

    Push back down on the connector (you'll feel it snap into place) and replace the plastic panel and screws.


    Sadly if this doesn't fix the problem, I'm at a loss for what the issue could be.

  • This seems like the answer. But, the phone still doesn't send audio. The weird thing is, I got another copy of the phone that had gone swimming in a spa. The phone had been in rice for weeks, but the digitizer no longer functioned. You can tell where I was headed, right? I took the board with the microphone out of the swimmer and put it in my original phone. Turns out that the digitizer interface is on the same board, so now I couldn't even activate my phone once it had been powered up.

    I've pretty much given up on it now. Spent $50 and bought an LG Phoenix 2. Hope that works better!

  • I created this account to say that this is the solution that worked for me.  I bought a set of precision screwdrivers to do this.  The head you will need is J000.

    I previously had a phone that was able to make calls, use sms and data but no one could hear me through the phone or Skype/G-chat.  I would hear my own echo but the other line could not hear me at all.  Speakerphone did not work for me either.  I initially thought it was a software issue, so I tried downloading SoundAbout to change the source, after that didn't work I knew I had a hardware issue.  I found CJE200's picture above and it seemed very plausible that my microphone port was loose because I drop my phone quite often.  I opened up the back, unplugged the ribbon completely, blew on the area, and then plugged the ribbon back on and VOILA!

    THANK YOU​​  !!!!

  • Holy cow. Cje200 you are the man! Performed the same steps. Then tried to test microphone by doing a voice recording and it worked! Did same steps as others. Unplugged, blew on it little, then snapped it back in and it worked!

  • utsc123utsc123 United StatesPosts: 1 ✭✭

    ZTE ZMAX 2 (Z958) | Android 6.01 | Baseband: Z958H01 | Hardware Vision: u02A

    After the B26 Update I have audio problems. When I make a call I could hear the the other party but they could NOT hear me.

    I then opened the voice recorder & recorded a test message & I was able to playback the recording with good volume.

    However when I tried calling a friend again this time he is able to hear me well But I could not hear him ? !!!

    I have already performed a full wipe and factory reset but the problem persist.

    What should I do?

    I went to the ZTE Test Menu

    Type '983'2567336# to go to ZTE Test Mode
    '
    Type '9830# to go to the Test Menu,

    I selected Audio Loop Test
    Handset MIC Test Failed **
    Speaker MIC **Test Failed

    Auxiliary MIC Test Pass

Sign In or Register to comment.