How to fix ZTE axon 7 mini stuck on boot screen

FoxToGoFoxToGo United StatesPosts: 2 ✭✭
edited June 9, 2018 5:05PM in Axon

Hi, I brought a ZTE axon 7 mini a few months ago. So one day I decided to root it
And installed TWRP and all that. Then I went to install supersu and it said done.then I rebooted the phone but it was Stuck on ZTE logo. I can enter TWRP but I can't do much. All I can really do is format the data but that didn't work. And then today I was looking around in TWRP and I went into the file manager and I saw folders root and supersu. I tried deleting them but when I would reboot the phone into TWRP they would come back. Can anybody help me out with this? Thank you


  • samsamhasamsamha Posts: 1,559 ✭✭✭✭✭✭✭✭

    If you follow the guide for rooting carefully then you should rooted the phone successfully. After you have rooted the device and install the TWRP, you would need to flash the rom that you want to install.

  • FoxToGoFoxToGo United StatesPosts: 2 ✭✭

    Yes I tried to install the super su but when it said finished installing it rebooted and it was stuck on the ZTE boot screen

  • cf07cf07 CanadaPosts: 103 ✭✭✭✭✭

    You can't root Axon mini7..only big brother Axon 7 can be rooted.

  • samsamhasamsamha Posts: 1,559 ✭✭✭✭✭✭✭✭

    no, not supersu, rather, you need to install ROM image. Since rooting and installing custom rom voids the warranty, you would have to be careful as if not done correctly, it can render the phone useless. I would suggest you check XDA for more information.

Sign In or Register to comment.