required permission

jenpittsjenpitts FlordaPosts: 2 ✭✭

Somehow I "disabled a required permission" in my contacts and I can't click on a contact without this message popping up and it won't go to the contact. How do I change this setting?

Answers

  • runtohell121runtohell121 Analyst United StatesPosts: 2,217 ✭✭✭✭✭✭✭✭

    Not sure what device you have, but it's usually under Settings -> Applications (or Apps for short) -> Go to the app you need permissions for -> Tap on the Permissions -> and toggle on/off for that app for the permissions required.

  • jenpittsjenpitts FlordaPosts: 2 ✭✭

    I already tried that, I don't see a place to toggle on/off. Majesty Pro

  • DEMONICK_KREAPERDEMONICK_KREAPER OhioPosts: 2 ✭✭✭

    I am having the same issue, it is an ZTE Majesty pro lte, through safe link, and after I put in one contact, it asked if I would allow it to have my contacts, pictures and media shared with my contacts, and I denied it, because why would I let them have that information. Now when I go in to delete a contact, I hard press the contact and this message appears "you have disabled a required permission", now if I go to factory data reset (I don't have a external SD card), I'll lose what I have on the phone, just so I can allow it access. Please, how do I undo and allow it access so I don't lose anything, thank you

  • DEMONICK_KREAPERDEMONICK_KREAPER OhioPosts: 2 ✭✭✭

    Ok I figured it out, I went into settings, apps, contacts, permissions, and turned on all of the boxes (ex. Calander, contacts location, etc.) And now it let's me delete contacts

  • hollaphollap United States Posts: 8,370 ✭✭✭✭✭✭✭✭

    @jenpitts can you try what @DEMONICK_KREAPER did above to see if that fixes your issue? Thanks!

  • Finally the answer. Go to Storage and you will find Contacts and turn on

  • Go to Settings and Search for Storage and under Storage you will find Contacts and you turn on Contacts in the Storage settings

  • Thank you so much Sandralynn87

  • CrystalCrystal United StatesPosts: 1 ✭✭
    edited April 18, 2018 9:37AM

    Thank you guys so much for posting how to fix this issue with the contacts. I just got the phone yesterday, and couldn't figure out how I "disabled the permission", or how to fix it lol. I have it fixed now :-)

  • shawnee08shawnee08 United StatesPosts: 1 ✭✭

    I have some how done the same thing and receive the message I'm missing a permission to create contact. Above it says go to storage. Only thing in my storage is storage info. In settings under apps then contacts it's all enabled. HELP and thank you

  • samsamhasamsamha United States Posts: 2,094 ✭✭✭✭✭✭✭✭

    @shawnee08 said:
    I have some how done the same thing and receive the message I'm missing a permission to create contact. Above it says go to storage. Only thing in my storage is storage info. In settings under apps then contacts it's all enabled. HELP and thank you

    you could try to go to setting, apps, contacts. Clear the app data and cache. This will clear all of the settings and data for the contact app (including the permissions and such). Be sure you also have your contacts saved to your gmail account and not on the phone before you clear it so you won't loose any of the info. Afterwards, when you open contacts again, it will ask you to agree on the permission it needed and re-sync contacts from google account. See if this helps.

  • hardihardi United StatesPosts: 2 ✭✭

    Have zte majesty pro plus. Suddenly, can not make calls. Get error message, "can't hold calls" and hangs up. Can message, text but no calls. Help.

  • chucknobullschucknobulls United StatesPosts: 1 ✭✭✭✭
    @DEMONICK_KREAPER & @Sandralynn87 thank you so much this helped me tremendously. 
Sign In or Register to comment.