Lost Wi-Fi on Blade X max (z983) after firmware update

chatsworthosbornejrchatsworthosbornejr United StatesPosts: 3 ✭✭
I was using my phone on  home wi-fi and received notification that firmware update was ready. I opted to accept and update. Once update and reboot had completed, I had no connection to wi-fi. Phone will detect wi-fi with good signal, but just shows it as saved. Repeated tries will switch to disabled. I have called and talked to your tech(Aaron). We tried forgetting and refreshing network, resetting network settings, factory reset. No change. All my other devices connect fine, including my old samsung that my wife uses.
Any help welcome, before I go to get another phone.   


  • samsamhasamsamha United StatesPosts: 2,363 ✭✭✭✭✭✭✭✭
    It seems to me that you have done typical troubleshooting on the phone (factory reset and network reset).

    Sometimes, wireless problem can be due to the router itself. Have you try to maybe reset the router? Maybe try to disable the wireless password to see if the phone would connect to it? Check the router's access control (if you have that enabled) to see if the phone  is being blocked? Try different radio frequency?
  • chatsworthosbornejrchatsworthosbornejr United StatesPosts: 3 ✭✭
    Wi-Fi is thru dsl modem, simple WEP password.  Not able to change.  Modem has been rebooted several times. All other devices are still working fine with no problems. The phone firmware is at fault. Either in communication program or wi-fi manager. Maybe manager doesn't consider my dsl service as a good enough connection even though it has a strong signal. I don't know if manager has speed qualifier in code,  if it does,  it shouldn't, not everyone has a fast connection. The idea of using  Wi-Fi is to avoid data charges,  now I have to eat up my quota trying to figure out what's up with this. 
  • hollaphollap United StatesPosts: 8,377 ✭✭✭✭✭✭✭✭
    edited October 17, 2018 9:50AM
    @chatsworthosbornejr what device is it that you have? You posted in the Blade X Max thread so I'm assuming that's what you have.  If it is, I could be wrong, but I didn't know there was an update for the Blade X Max at all? Can you post a screen shot of the build number you are running please? Thanks!
  • chatsworthosbornejrchatsworthosbornejr United StatesPosts: 3 ✭✭
    Screenshot:  hope this helps,  provider= cricket 
  • hollaphollap United StatesPosts: 8,377 ✭✭✭✭✭✭✭✭
    As @samsamha mentioned, it looks like you have tried a myriad of fixes. When you attempt to connect to your wifi, are you getting any sort of error? Does it allow you to put your WEP password in?  Have you tried using WPA on your router which is more secure? Can you connect to any other access points anywhere else or is it just your home wifi?
  • ajewellajewell United StatesPosts: 1 ✭✭
    I have the exact same phone with the exact same details as listed in your screenshot. I've noticed that I can connect to my home wifi, but it will not stay connected even though it has a strong signal.  I also did a recent firmware update. I've noticed when it does connect, it usually says something like "wifi, but no internet", even though my other devices have no trouble connecting and getting to the internet.
  • devcolon28devcolon28 United StatesPosts: 5 ✭✭
    I'm having a similar problem; i can connect to my 2G wifi,  but within a 5min time frame it cuts off then reconnects
  • devcolon28devcolon28 United StatesPosts: 5 ✭✭
    My phone can also not see my 5G network; it sees someone elses where i live, but it cant see mine. Even me putting my 5G In saved network; it wont allow to connect. 
Sign In or Register to comment.