New user--need simple help to connect phone to computer

DarkMoonDarkMoon United StatesPosts: 4 ✭✭

I am trying to connect the phone to my computer. All phones I've had in the past have been easy--but this phone--whew! I have a ZTE Majesty pro plus. I have downloaded the 'files' twelves times and when it connects it won't let me do anything except look at screen. It doesn't even list any music I already have on my phone which was on memory card I placed in phone. Help!


  • samsamhasamsamha United StatesPosts: 2,363 ✭✭✭✭✭✭✭✭

    hi, with Android, you really do not need to download anything special. When you connect the phone to your computer. Then you typically will have a prompt asking to you to choose what you want to do. If not, you can just swipe down the drop down menu and there you typically has option to select USB setting and you can select "Transfer Files".

  • DarkMoonDarkMoon United StatesPosts: 4 ✭✭

    My phone doesn't have that displayed. It says: charge only, install driver, media device (mtp), camera (ptp) Like I said, I've installed the driver twenty times now and it won't install or won't do anything.

  • DarkMoonDarkMoon United StatesPosts: 4 ✭✭

    I'm just trying to copy pictures from my computer to my phone. It worked with other phones and this one is unbelievable!!

  • samsamhasamsamha United StatesPosts: 2,363 ✭✭✭✭✭✭✭✭

    Different version of Android may show different thing when you plug in the usb (I took the screenshot with phone running Android 8, but your phone is running Android 7, and that's why you won't see exactly the same thing). :)

    what is the operating system of your PC? Have you try to tap on MTP? Have you try to use a different USB port or different USB cable (sometimes they do make difference).

    I know sometimes there can be driver conflicts. Have you consider maybe just use a cloud service like uploading pictures to google drive or photos and download to your phone?

  • DarkMoonDarkMoon United StatesPosts: 4 ✭✭

    Hello Smasmaha,

    Thank you for answering twice, I have been too busy trying to fix my phone to thank you. Sorry. LOL Yes, I have tried to use different USB cables, I can't use the Cloud because I can't get online. It is a newer computer, not brand I have to research the exact operating system. I think that is where I should try to look for answers right now. Yikes. Maybe my operating system isn't updated enough. I will try there now. Thank you for your help :)

Sign In or Register to comment.