RCS Messaging (Google Hosted)

david_l312david_l312 Posts: 21 ✭✭✭✭✭
edited December 3, 2019 3:56PM in Axon 10 Pro

Anyone get this ?

Supposedly Google is in the process of rolling it out in the states (it's been in EU for awhile). At this point RCS is Google hosted and used automatically if both parties support it. Otherwise it automatically uses SMS/MMS. The carriers are still claiming to be adding it as well.

You have to enable it in the google "Messages" App (under settings).

At this point all I see is (T-Mobile - Chat features unavailable for this device):


  • xphylexphyle United StatesPosts: 73 ✭✭✭✭✭

    I have it. I enabled it manually via the workaround and got officially updated shortly thereafter. Did my son's phone also. T-Mobile.

  • jasonscarterjasonscarter United StatesPosts: 1,907 ✭✭✭✭✭✭✭✭

    Yep. Been on the tech news sites for a few weeks now. Have it enabled on mine, my wife's and a few co workers have done it as well.

  • samsamhasamsamha United States Posts: 2,307 ✭✭✭✭✭✭✭✭

    This feature only works when you are connected to WiFi and not cellular network.

  • david_l312david_l312 Posts: 21 ✭✭✭✭✭

    I've been avoiding the work-around. I'm hoping it'll just show up officially.

    I didn't know wi-fi is requred. I just tried again with wi-fi on -> still not available.

    I appreciate the responses. I just wanted to make sure it's not an issue with the Axon 10.

    Hopefully it'll show up soon.


  • louisdlouisd Arguer in Chief United StatesPosts: 1,179 ✭✭✭✭✭✭✭✭

    Yup, Working on our A10 Pro on Cricket.

    @samsamha RCS works perfectly on cellular as long as you have cellular data. It does not require wifi.

  • samsamhasamsamha United States Posts: 2,307 ✭✭✭✭✭✭✭✭

    I had no idea. Whenever I disable wifi and using cell, my status shows connecting. Maybe it was because I enable the feature using guide I found online before google opens this up to everyone.

  • louisdlouisd Arguer in Chief United StatesPosts: 1,179 ✭✭✭✭✭✭✭✭

    I actually find it more reliable on cellular because many public/business wifi networks have ports blocked that keep RCS from working.

  • samsamhasamsamha United States Posts: 2,307 ✭✭✭✭✭✭✭✭

    I just reset my network setting and it indeed is working with cellular connectivity. Thanks for the info, learn something new everyday.

  • david_l312david_l312 Posts: 21 ✭✭✭✭✭

    I had it... and now lost it (RCS).

    Anyone lost RCS since getting the December Security Patch (1.13)?

  • david_l312david_l312 Posts: 21 ✭✭✭✭✭

    False alarm, it seems to be back now.

Sign In or Register to comment.