Android 10: Updates and patches direct from Google ?

david_l312david_l312 Posts: 24 ✭✭✭✭✭

So I just noticed that under settings/about_phone/Android_Version/Google_Play_System_Update....

I'm guessing these updates come from Google?

Was this in version 9 too (I don't remember it -> but may not have noticed it) ?

So, I was initially showing:

Security Patch Level: Dec 1, 2019 & Play System Update: 2019-11-01

Hitting "Google Play System Update" lets you check for updates (12 Meg). I did that and it went to:

Security Patch Level: Dec 1, 2019 & Play System Update: 2019-12-01

I then checked for updates again, It said another update was available (6.2 Meg). But when I hit "Download & Install" it jumps back to the previous screen, hit "Download & Install" again and it starts downloading, then gives an error:

I'm not really sure if these Google updates are supposed to work.


  • AerospacemanAerospaceman United StatesPosts: 1,502 ✭✭✭✭✭✭✭✭

    Yes. Any Google Play system updates should come directly from Google. I am not seeing the same screen as yours. Can you provide the previous screenshot after selecting "Android Version"? Mine is showing as "Google Play System Update 2020-01-01".

  • jasonejasone United States Posts: 2,118 ✭✭✭✭✭✭✭✭

    I see this as well but mine is already updated to 01/01/2020. It appears this is part of Project Mainline that was first instituted in Android 10 and allows Google to update certain components of Android like security and others without a full OTA.

  • dnewman007dnewman007 United StatesPosts: 3,660 ✭✭✭✭✭✭✭✭
    edited January 19, 2020 5:19PM

    @Aerospaceman I am seeing the same thing as @david_l312. Here are the screen shots you requested. I have got my device to restart but it doesn't update to 01/01/20. This could be an issue on Google's end. Personally I am not worried it. I will keep trying to update it.

  • david_l312david_l312 Posts: 24 ✭✭✭✭✭

    Here's what I see in sequence when I get the error. I guess I'm still a version back. Is there a cache (somewhere) to be cleared that might help ?

  • AerospacemanAerospaceman United StatesPosts: 1,502 ✭✭✭✭✭✭✭✭

    Here is what I see from some screenshots I took last night. You can try clearing the Play Store Cache or restarting the phone and performing a partition cache wipe. I am unsure of how to force this. @sshasan any ideas on this?

  • david_l312david_l312 Posts: 24 ✭✭✭✭✭

    Thanks, Tried a play store cache clear -> no change.

  • AerospacemanAerospaceman United StatesPosts: 1,502 ✭✭✭✭✭✭✭✭

    I would reference everyone to please note the POST by @jasone above about Project Mainline and google being able to directly update parts of the Android system without a FOTA push from the OEM.

  • david_l312david_l312 Posts: 24 ✭✭✭✭✭

    Thanks. Project mainline is looks great. Patches straight from Google is the best way.

    I'm just trying to figure out why I'm getting an error when it tries to take an update.

  • dnewman007dnewman007 United StatesPosts: 3,660 ✭✭✭✭✭✭✭✭

    The Google Play System Update is now working. I manually downloaded and updated the morning.

  • maximusunomaximusuno Posts: 19 ✭✭✭✭✭
    edited January 24, 2020 8:38AM

    I can't manually update as well. I tried everything form reset and taking sim and storage cards out and deleting cache. All the above screen shots apply to me as well. Will check back here to see if we have solution.

  • david_l312david_l312 Posts: 24 ✭✭✭✭✭

    Mine did eventually decide to take the update (after many attempts).

  • AvanRJAvanRJ BrazilPosts: 1 ✭✭

    My DTS:X Ultra stop to work after the Android 10 upgrade. What's happening?

Sign In or Register to comment.