ZTE Spro 2 rendered useless due to stuck in a boot loop

dnicholson101dnicholson101 United StatesPosts: 2 ✭✭✭
My ZTE Spro 2 is stuck in a boot loop after being on for only a few moments the device restarts. Sometimes when the device restarts it will not even make it to the home screen. I've tried fixing from recovery screen and even that gets interrupted with a boot loop. I have not rooted my device, I have been able to reset the device and the problem still exists. Help!!!


  • Reinstall firmware. Make sure you wipe out from Android boot recovery screen at least a few times before installing. 

  • emilee2525emilee2525 United StatesPosts: 1 ✭✭

    I believe mine is having the same issue. When you power it on, the screen says android with a beep every 15 seconds or so. I am unable to leave that screen and touching any of the other buttons/screen, does nothing. I have also tried to do a reset of it by pressing the reset button on the side of it, but all it does is turn it off and back on to the same “android” screen. Help!

  • DrakenFXDrakenFX Mobile United StatesPosts: 2,128 ✭✭✭✭✭✭✭✭

    If you are willing to do a Factory reset, I believe that will be the best way to go....

    Note : if you have any files in your Internal storage, I would recommend moving them to a USB Thumb drive / Hard Drive or SD Card if you are using any.

  • jasonscarterjasonscarter United StatesPosts: 1,963 ✭✭✭✭✭✭✭✭

    I am willing to see my SPRO 2 is someone wants it. I stopped using it now I can cast to everything and we don't take I camping anymore.

Sign In or Register to comment.