Can't open Chrome after update to Android 10 on Axon 10 Pro

SteveMSteveM United StatesPosts: 3 ✭✭

I'm not sure if this issue belongs here or with google or android. I received my phone a few days ago and during setup it updated to android 10. Chrome also updated. I sync'd my google account to the phone and it appeared everything transferred over. I'm not sure if I caused a problem with chrome or something during the updates did. Here's my problem. Every time I click on the chrome icon I get a screen flash like chrome is trying to open then it kicks right back to the home screen. Also, any time I clink on something that would normally open in chrome the same thing happens. I also get the message you can hopefully see in the attachment.

I have tried everything everything I could find on the internet to fix the problem, clearing cache and data, deleting the chrome update and reinstalling it, restarting and anything else. Nothing helps. According to chrome usage access I had 3 minutes of screen time yesterday but chrome opened 105 times. Every one of these was what I described above. So far today it has supposedly opened 25 times with the same message every time. Has anyone else had this problem?



Comments

  • samsamhasamsamha United StatesPosts: 2,362 ✭✭✭✭✭✭✭✭

    Have you try to clear the app data completely. Open settings-->Apps--> See all apps-->chrome. Force stop it. Then tap on Storage and cache, then clear the cache and storage.

  • jasonscarterjasonscarter United StatesPosts: 1,958 ✭✭✭✭✭✭✭✭

    Wondering if it could somehow be related to the web view update that got stuck on a few devices. Do you see the web view system in Play Store stuck updating? Can you try another Chrome based browser, like Brave and see if it works as a troubleshooting measure?

  • SteveMSteveM United StatesPosts: 3 ✭✭

    Yes, samsamha, I tried all of that and nothing helped. But thank you. jasoncarter, no other chrome based browsers will download including brave. In fact, I can't download firefox or opera either. When I click install I get the message "can't download Brave private browser" or whichever browser I'm trying to download. As for updates, I've got an update for google pending in playstore but when I click update it says can't update google. I've had the phone less than a week and it's driving me crazy. BTW, I was able to download a browser called Browser for Android and it works. It's not much but it beats nothing. I still need to figure out what is wrong with this phone. Thanks both of you for your help

  • jasonscarterjasonscarter United StatesPosts: 1,958 ✭✭✭✭✭✭✭✭

    Factory reset is a pain but you may need to do that

  • samsamhasamsamha United StatesPosts: 2,362 ✭✭✭✭✭✭✭✭

    When you set up your phone, did you set it up as a new device or with some sort of backup that restore all of your app setting and data. If you restore from a backup, I wonder maybe something was not restored correctly or has conflicts. You should not have issue download apps from the playstore. I think doing a factory reset is definitely a good option and do not restore data if you could and just set it up as a new device.

    Also, are you using microSD card? If so, maybe try without it, in case maybe the card is corrupted and cause issue.

  • yuanyasmineyuanyasmine United StatesPosts: 5 ✭✭

    Hi steven,

    What is the final solution then? i am also facing the same issue . i am on A2017 7.1.1 B13 . modem is pretty stable but not the apps which dependent on google. Chrome, maps, paytm etc..

  • SteveMSteveM United StatesPosts: 3 ✭✭

    Thanks everyone for all the help. I finally ended up calling tech support and he walked me through a factory reset. He also had me remove the sd card. Everything seems to be working ok now. I'm keeping my fingers crossed.

Sign In or Register to comment.