Zte blade l2 firmware corrupt !!

Hello guys

my phone is stuck on boot logo ... i did recovery reset but the problem still the same

yasterday i've downloaded the firmware file from the Support site . but when i try to extract it .it shows me an error like that

also i have tried on many other pc's and this error pop's up every time !

1.png

2.png

Answers

  • AerospacemanAerospaceman Z-Community Administrator United States Posts: 1,291 admin

    ​  Thank you for your post.  I am going to submit this to official ZTE Support for an official reply.  Thank you for your patience and you should hear back soon.

  • i hope so. because i really need my phone as soon as possible

  • Hello guys . Any help ?

  • sshasansshasan Staff Member United States Posts: 3,738 admin

    Hi, has been notified. This isn't a product that we normally deal with on Z-Community. Typically we deal with devices launched in the US. is working on getting you to the correct support channel.

  • i have contact ztedevice support 5 days ago ... but without any result

    my phone is broken from a week ago now

  • zte_usazte_usa United States Posts: 176 ✭✭✭✭✭

    We're looking into this right now, for you.

  • zte_usazte_usa United States Posts: 176 ✭✭✭✭✭

    Could you please Direct/Private Message us on www.Facebook.com/ZTEUSA or www.Twitter.com/ZTE_USA? We need to collect contact information for you so we can get your issue supported.

Sign In or Register to comment.