Can't install EDL drivers

I tried to update my device and now it boot loops and can only enter EDL and fastboot modes.

Windows is not able to install fastboot or EDL drivers.

I tried with zadig, QUSB_BULK drivers and Qualcomm Drivers.

I also tried under Windows 7 and Windows 10.

Any ideas?

Thanks.

Comments

  • DrakenFXDrakenFX Mobile United States Posts: 1,802 ✭✭✭✭✭✭✭✭

    Hi

    1. How were you trying update your device?

    2. Where you trying to do something else beside "update" before getting the bootloops?

    3. Are you able to enter Recovery Manually? ( When device is Power off, press & hold volume up &power for 10 secs.)

    If you can answer the questions above and explain me what where you doing or wanted to do , I can help you getting your device back on track.

    P.S. if you want to know if QCOM drivers are install, head over "Device Manager" and look for " Com & Ports " while your device is in EDL Mode.

  • I discovered that my device can only enter DFU mode.

    Is there a way to boot into EDL from there?

  • DrakenFXDrakenFX Mobile United States Posts: 1,802 ✭✭✭✭✭✭✭✭

    If you can only enter to DUF mode, that means you have the A2017G ( international model ) and NOT the USA model then. (USA Model have FTM mode instead of DFU)

    And I'm sorry to say this, but I don't own the G variant and as far as I know, unless I'm wrong once the G model is stuck in DFU mode you're stuck there.

    Unless you buy a special cable to force the device to Boot to EDL, just don't remember the name of such cable.

  • I do have the U version, but flashed the chinese 7.1.1 to it after seeing a couple of users do so.

    I managed to enter FTM mode once, but after that it was impossible, it just tries to boot to system. And power + vol up and down only enters DFU and not EDL.

    So, to summarize:

    I can enter fastboot

    I cannot enter recovery

    System bootlops (I can see the boot animation)

    vol up and down + power boots into DFU

  • DrakenFXDrakenFX Mobile United States Posts: 1,802 ✭✭✭✭✭✭✭✭

    That's why I said about " explain me what you were doing or trying to do".

    Know that I know what's going on will be easy to troubleshoot....

    1. You have Unlock bootloader (I assume you do base on you Previous answer)

    2. Have you try flashing TWRP 3.0.4-1 via fastboot if you have Unlock bootloader?

      - fastboot flash recovery path_ofFile_and_name.img

  • I cannot seem to get the device recognized by Windows.

    It shows as "Android" under device manager while in fastboot mode.

    I tried with the google usb drivers but adb doesn't find my device.

  • EDIT:

    C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot flash recovery recovery.img

    target reported max download size of 536870912 bytes

    sending 'recovery' (17917 KB)...

    OKAY [  0.409s]

    writing 'recovery'...

    FAILED (remote: unknown command)

    finished. total time: 0.433s

    adb devices shows 0 devices, by the way

  • DrakenFXDrakenFX Mobile United States Posts: 1,802 ✭✭✭✭✭✭✭✭

    You have to revert the Android driver back to Fastboot drivers,

    Go to this thread and check how to revert them back is right after the ======Fixed======

    [RESOLVED] fastboot not recognizing phone in… | ZTE Axon 7

    I'm not home , neither have my laptop to guide you , but that thread fix can help you.

    After that you are going to be able to use Fastboot and reflash TWRP 3.0.4-1 look for MY RollbackModded B29 at XDA then do the following :

    1. In TWRP > Mount > Check "MOUNT System as Read-only"

    2. Flash RollbackModded B29 zip

    3. Reflash TWRP if you want to keep TWRP.

    THOSE 3 STEPS are if you successful get fastboot and flash TWRP via fastboot.

  • Draken, I have the dummy bootloader that doesn't even let you do "fastboot reboot" so flashing something via fastboot is out of the question.

  • DrakenFXDrakenFX Mobile United States Posts: 1,802 ✭✭✭✭✭✭✭✭

    Send me PM ,please

    Follow me and I'll follow you

Sign In or Register to comment.