Time Warner Cable App (TWC)

I am unable to get my ZTE Spro 2 to project content from my TWC app.  The app tells me it doesn't support HDMI output.  This makes no sense as I'm streaming from the app and not from a connected HDMI input.

Does anyone have a solution to this problem?

Thank you!

Answers

  • musicdjmmusicdjm United StatesPosts: 3,124 ✭✭✭✭✭✭✭✭

    I dont have TWC so I cant test this out, but It does make sense, because of DRM it probably doesnt allow any type of external output, since the projector needs to send the information to a separate chip to project the picture it is probably not going to work for you you can log into the apps for the channels though with your TWC info and most of them have worked for far, with the exception on i think it was TruTv that didnt work for me but it was a few months ago..

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    Sorry I am just now seeing this. I am assuming you are referring to live tv. I would actually uninstall the app, and then reinstall. I use the TWC app daily on the Spro2 and I have only had a few issues. I am willing to work to help you find out what is going on, as I know how frustrating this can be, and I would also be lost with out TWC live app on my Spro2. Please try reinstalling, and let me know how that works. I will watch for your reply

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ TWC app does fully work with Spro2, all of the features are amazing actually. You do have to have an active service account with them, and login to the app with your account credentials to receive anything beyond the local guide.:)

  • musicdjmmusicdjm United StatesPosts: 3,124 ✭✭✭✭✭✭✭✭

    Thank you ​ for answering, I have Charter in my area so I was shooting in the dark on this one lol.

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ Your Welcome!  I'm hoping by the member re-installing it will correct the issue. I love the app, and I rarely turn my tv on anymore.

  • musicdjmmusicdjm United StatesPosts: 3,124 ✭✭✭✭✭✭✭✭

    I hope so to, If my Charter wifi wasnt so crappy for streaming I would love to use charter tv app on mine but my cell data is faster than my home data most of the time lol

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    that sucks. I had issues with TW when I first bought my house, and I couldn't pull the speeds I was paying for. Their corporate office finally, (after like 20 different tech specialist coming out) jumped my speeds up 2 tiers, and now my connection is nice! They tried everything to get the lines unclogged, but....

  • Did you get any help? I installed the TWC TV application and have the same problem. I do not have CAST on wireless enabled.

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ Good Evening! Were you able to get it working? If not, can you please give me more details as to what is happening, and I will try to assist you.

  • i downloaded the TWC TV app, but it will not let me watch "Live TV". See

    attached screen shot for the error about screen casting.

    I do not have casting enabled.

    Thanks

    Ron Lueb

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ Good Afternoon.I have never seen this error before, but I will try to help you.  I will need a little information, what model is your Spro2, what build is it on? Also can you please tell me what version of TWC app you are using. Does it give the error if your connected on WIFI or just Data or both?

  • Thanks, l also have TWC looking into the error. I've attached a screen

    capture of my system info. The TWC TV app is also copied.

    Ron Lueb

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ I would tried clearing the app data and cache if you haven't already. At this point it can't hurt. I have the WIFI model, and the only hiccup I hit was being told to turn off usb debugging when I haven't used the app in a while. I am going to see what information I can gather, and will post back. Please do not feel I have forgotten you, if you don't hear back immediately. Also, should you have further information or questions please mention/flag me ( @ symbol followed directly by my username) so that I see it much quicker

  • musicdjmmusicdjm United StatesPosts: 3,124 ✭✭✭✭✭✭✭✭
    rlueb wrote:Thanks, l also have TWC looking into the error. I've attached a screencapture of my system info. The TWC TV app is also copied.Ron Lueb

    Can you please Clarify ​ do you have a Zmax or a Spro 2? Your model number shown in the screenshot is for a Tmobile Zmax

  • sshasansshasan Staff Member United States Posts: 3,959 admin

    TWC actually removed the ability to screencast in their most recent update. The SPro 2 is being registered as a casting device. This is something they would have to fix on their end in a future update. The issue also plagues devices such as Google's Chromecast.

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ As ​ states TWC has made changes to their app. Reading through comments on the app store, they state that reinstalling the app could actually remove this error. I can't promise that it will, but I would definitely give it a go

  • Reinstalled, no luck. I'm still getting the same message to turn off

    screencasting.

    Ron Lueb

  • TW app now Spectrum only works on device when projection is NOT running. Local display only.

    Once projector is turned on, app kicks in with copyright nag screen.

    No hacks avail just yet BUT you can have the TW app running on a different device and cast it over to the SPRO2. This will allow you to view content with the use of the projector being active.

    I found the SPRO2 casting options work quite well.

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ Do you have USB debugging turning off? I know this has nothing to do with the error message directly, however I was just speaking with someone with similar issues, and this corrected their error. I am at a loss as to why you, and others are having issues with this app, and yet having it working perfectly. I haven't forgotten about you.

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​  I am fully updated, and still am able to run the app and projection is working fine. I'm not having to do anything different. I use it to watch live tv almost daily. Are you able to post a screenshot of the "nag screen" I am really curious what is going on. I wonder if perhaps our location has something to do with it. What model are you currently using, I have the WIFI model.

  • Thank you for the follow-up.

    I decided to just check if the app started working....And it did. They must

    have fixed the bug in the last release. I have 5.1.1.39321 updated on Feb

    23.

    Thank you again for your time!

    Ron Lueb

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ Thank you for updating this thread

  • I have Comcast and their xfinity app gives me the same error, which I find is just another way for them to add another receiver to my bill.

    I was able to get it working by deleting the app and installing an older version from any apk website. The only downside is that I can only view on demand and saved DVR content, no live streaming, which I'm fine with. I had to use an apk from last January.

    It seems that they added live streaming to the app sometime after that older version and that's when they blocked any miracast capabilities. I don't see why this wouldn't work in your case as well.

    Make sure to uncheck auto-update from the playstore so that the app doesn't update. I also had to do the same for Netflix since the newest updates killed the audio when watching from my spro 2. I believe I installed a version from October for Netflix.

    Hoped I helped out some of you.

  • Just saw that this thread was updated and TWC updated their app to add support back. I'll leave my post up incase it does help someone else. Here's hoping Comcast gets their stuff together and updates their policy.

  • ironbaybeedollironbaybeedoll United States Posts: 4,611 mod

    ​ Good Evening. As you stated TWC is working great now. It was actually odd that only some people had issues with it, and others, myself included had no issues at all. I agree leaving your post about Comcast up. It may help other members, and is good reference Definitely let us know if, and or when Comcast changes their stance.

Sign In or Register to comment.